1 %define _prefix
/opt
/gnome
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
15 # "buildname" needs to be e.g. gtk2ud for debug builds
20 %define buildname gtk2u
22 %define buildname gtk2
31 %define name wx
-%{portname}-unicode
32 %define wxconfig
%{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic
%{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx
%{portname}u-%{ver2}-config
36 %define name wx
-%{portname}-ansi
37 %define wxconfig
%{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic
%{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx
%{portname}-%{ver2}-config
43 %define wxbasename wx
-base
-unicode
44 %define wxbaseconfig base
-unicode
-release
-%{ver2}
45 %define wxbaseconfigstatic base
-unicode
-release
-static
-%{ver2}
46 %define wxbaseconfiglink wxbaseu
-%{ver2}-config
48 %define wxbasename wx
-base
-ansi
49 %define wxbaseconfig base
-ansi
-release
-%{ver2}
50 %define wxbaseconfigstatic base
-ansi
-release
-static
-%{ver2}
51 %define wxbaseconfiglink wxbase
-%{ver2}-config
54 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
58 License: wxWindows Licence
60 Source: wxGTK
-%{ver}.tar.gz
61 URL: http
://www.wxwidgets.org
62 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
69 # BuildRequires: gtk+-devel >= 1.2.0
72 BuildRequires
: zlib
-devel
, libjpeg
-devel
, libpng
-devel
, libtiff
-devel
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
81 wxWidgets is a free C
++ library
for cross
-platform GUI development.
82 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
83 Motif
, MS Windows
, MacOS X
, Windows CE
, GPE
) from the same
source code.
86 Summary: The translations
for the wxWidgets library.
89 %description -n wx
-i18n
90 The translations files
for the wxWidgets library.
93 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
100 The GTK
+ %{gtkver} port of the wxWidgets library
, header files.
103 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, OpenGL add
-on.
105 Requires: %{name} = %{ver}
109 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
111 %package -n
%{wxbasename}
112 Summary: wxBase library
- non
-GUI support classes of the wxWidgets toolkit
113 Group: Development
/Libraries
116 %description -n
%{wxbasename}
117 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
118 lists
, arrays
), portable wrappers around many OS
-specific funstions
(file
119 operations
, time/date manipulations
, threads
, processes
, sockets
, shared
120 library loading
) as well as other utility classes
(streams
, archive and
121 compression
). wxBase currently supports Win32
, most Unix variants
(Linux
,
122 FreeBSD
, Solaris
, HP
-UX
) and MacOS X
(Carbon and Mach
-0).
124 %package -n
%{wxbasename}-devel
125 Summary: wxBase library
, header files.
126 Group: Development
/Libraries
127 Provides: wxBase
-devel
129 %description -n
%{wxbasename}-devel
130 wxBase library
- non
-GUI support classes of the wxWidgets toolkit
,
134 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
, contributed libraries.
136 Requires: %{name} = %{ver}
139 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
141 %package contrib
-devel
142 Summary: The GTK
+ %{gtkver} port of the wxWidgets library
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
147 %description contrib
-devel
148 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWidgets library.
151 %setup -q
-n wxGTK
-%{ver}
154 if [ "$SMP"
!= ""
]; then
155 export MAKE
="
make -j$SMP"
160 mkdir obj
-shared
-no
-gui
162 ..
/configure
--prefix
=%{_prefix} \
174 ..
/configure
--prefix
=%{_prefix} \
193 mkdir obj
-static
-no
-gui
195 ..
/configure
--prefix
=%{_prefix} \
208 ..
/configure
--prefix
=%{_prefix} \
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj
-static
-no
-gui
; make DESTDIR
=$RPM_BUILD_ROOT
install)
231 (cd obj
-static
; make DESTDIR
=$RPM_BUILD_ROOT
install)
232 (cd obj
-shared
-no
-gui
; make DESTDIR
=$RPM_BUILD_ROOT
install)
233 (cd obj
-shared
; make DESTDIR
=$RPM_BUILD_ROOT
install)
235 # --- wxBase headers list begins here ---
236 cat
<<EOF
>wxbase
-headers.files
357 wx
/protocol
/protocol.h
370 # --- wxBase headers list ends here ---
371 cat
<<EOF
>wxbase
-headers.paths
372 %{_includedir}/wx-%{ver2}/wx
/afterstd.h
373 %{_includedir}/wx-%{ver2}/wx
/app.h
374 %{_includedir}/wx-%{ver2}/wx
/apptrait.h
375 %{_includedir}/wx-%{ver2}/wx
/archive.h
376 %{_includedir}/wx-%{ver2}/wx
/arrimpl.cpp
377 %{_includedir}/wx-%{ver2}/wx
/arrstr.h
378 %{_includedir}/wx-%{ver2}/wx
/beforestd.h
379 %{_includedir}/wx-%{ver2}/wx
/buffer.h
380 %{_includedir}/wx-%{ver2}/wx
/build.h
381 %{_includedir}/wx-%{ver2}/wx
/chkconf.h
382 %{_includedir}/wx-%{ver2}/wx
/clntdata.h
383 %{_includedir}/wx-%{ver2}/wx
/cmdline.h
384 %{_includedir}/wx-%{ver2}/wx
/confbase.h
385 %{_includedir}/wx-%{ver2}/wx
/config.h
386 %{_includedir}/wx-%{ver2}/wx
/containr.h
387 %{_includedir}/wx-%{ver2}/wx
/datetime.h
388 %{_includedir}/wx-%{ver2}/wx
/datetime.inl
389 %{_includedir}/wx-%{ver2}/wx
/datstrm.h
390 %{_includedir}/wx-%{ver2}/wx
/dde.h
391 %{_includedir}/wx-%{ver2}/wx
/debug.h
392 %{_includedir}/wx-%{ver2}/wx
/defs.h
393 %{_includedir}/wx-%{ver2}/wx
/dir.h
394 %{_includedir}/wx-%{ver2}/wx
/dlimpexp.h
395 %{_includedir}/wx-%{ver2}/wx
/dynarray.h
396 %{_includedir}/wx-%{ver2}/wx
/dynlib.h
397 %{_includedir}/wx-%{ver2}/wx
/dynload.h
398 %{_includedir}/wx-%{ver2}/wx
/encconv.h
399 %{_includedir}/wx-%{ver2}/wx
/event.h
400 %{_includedir}/wx-%{ver2}/wx
/except.h
401 %{_includedir}/wx-%{ver2}/wx
/features.h
402 %{_includedir}/wx-%{ver2}/wx
/ffile.h
403 %{_includedir}/wx-%{ver2}/wx
/file.h
404 %{_includedir}/wx-%{ver2}/wx
/fileconf.h
405 %{_includedir}/wx-%{ver2}/wx
/filefn.h
406 %{_includedir}/wx-%{ver2}/wx
/filename.h
407 %{_includedir}/wx-%{ver2}/wx
/filesys.h
408 %{_includedir}/wx-%{ver2}/wx
/fontenc.h
409 %{_includedir}/wx-%{ver2}/wx
/fontmap.h
410 %{_includedir}/wx-%{ver2}/wx
/fs_mem.h
411 %{_includedir}/wx-%{ver2}/wx
/fs_zip.h
412 %{_includedir}/wx-%{ver2}/wx
/hash.h
413 %{_includedir}/wx-%{ver2}/wx
/hashmap.h
414 %{_includedir}/wx-%{ver2}/wx
/hashset.h
415 %{_includedir}/wx-%{ver2}/wx
/html
/forcelnk.h
416 %{_includedir}/wx-%{ver2}/wx
/iconloc.h
417 %{_includedir}/wx-%{ver2}/wx
/init.h
418 %{_includedir}/wx-%{ver2}/wx
/intl.h
419 %{_includedir}/wx-%{ver2}/wx
/iosfwrap.h
420 %{_includedir}/wx-%{ver2}/wx
/ioswrap.h
421 %{_includedir}/wx-%{ver2}/wx
/ipc.h
422 %{_includedir}/wx-%{ver2}/wx
/ipcbase.h
423 %{_includedir}/wx-%{ver2}/wx
/isql.h
424 %{_includedir}/wx-%{ver2}/wx
/isqlext.h
425 %{_includedir}/wx-%{ver2}/wx
/list.h
426 %{_includedir}/wx-%{ver2}/wx
/listimpl.cpp
427 %{_includedir}/wx-%{ver2}/wx
/log.h
428 %{_includedir}/wx-%{ver2}/wx
/longlong.h
429 %{_includedir}/wx-%{ver2}/wx
/math.h
430 %{_includedir}/wx-%{ver2}/wx
/memconf.h
431 %{_includedir}/wx-%{ver2}/wx
/memory.h
432 %{_includedir}/wx-%{ver2}/wx
/memtext.h
433 %{_includedir}/wx-%{ver2}/wx
/mimetype.h
434 %{_includedir}/wx-%{ver2}/wx
/module.h
435 %{_includedir}/wx-%{ver2}/wx
/msgout.h
436 %{_includedir}/wx-%{ver2}/wx
/mstream.h
437 %{_includedir}/wx-%{ver2}/wx
/object.h
438 %{_includedir}/wx-%{ver2}/wx
/platform.h
439 %{_includedir}/wx-%{ver2}/wx
/process.h
440 %{_includedir}/wx-%{ver2}/wx
/ptr_scpd.h
441 %{_includedir}/wx-%{ver2}/wx
/regex.h
442 %{_includedir}/wx-%{ver2}/wx
/scopeguard.h
443 %{_includedir}/wx-%{ver2}/wx
/snglinst.h
444 %{_includedir}/wx-%{ver2}/wx
/sstream.h
445 %{_includedir}/wx-%{ver2}/wx
/stack.h
446 %{_includedir}/wx-%{ver2}/wx
/stackwalk.h
447 %{_includedir}/wx-%{ver2}/wx
/stdpaths.h
448 %{_includedir}/wx-%{ver2}/wx
/stockitem.h
449 %{_includedir}/wx-%{ver2}/wx
/stopwatch.h
450 %{_includedir}/wx-%{ver2}/wx
/strconv.h
451 %{_includedir}/wx-%{ver2}/wx
/stream.h
452 %{_includedir}/wx-%{ver2}/wx
/string.h
453 %{_includedir}/wx-%{ver2}/wx
/sysopt.h
454 %{_includedir}/wx-%{ver2}/wx
/textbuf.h
455 %{_includedir}/wx-%{ver2}/wx
/textfile.h
456 %{_includedir}/wx-%{ver2}/wx
/thread.h
457 %{_includedir}/wx-%{ver2}/wx
/thrimpl.cpp
458 %{_includedir}/wx-%{ver2}/wx
/timer.h
459 %{_includedir}/wx-%{ver2}/wx
/tokenzr.h
460 %{_includedir}/wx-%{ver2}/wx
/txtstrm.h
461 %{_includedir}/wx-%{ver2}/wx
/types.h
462 %{_includedir}/wx-%{ver2}/wx
/uri.h
463 %{_includedir}/wx-%{ver2}/wx
/utils.h
464 %{_includedir}/wx-%{ver2}/wx
/variant.h
465 %{_includedir}/wx-%{ver2}/wx
/vector.h
466 %{_includedir}/wx-%{ver2}/wx
/version.h
467 %{_includedir}/wx-%{ver2}/wx
/volume.h
468 %{_includedir}/wx-%{ver2}/wx
/wfstream.h
469 %{_includedir}/wx-%{ver2}/wx
/wx.h
470 %{_includedir}/wx-%{ver2}/wx
/wxchar.h
471 %{_includedir}/wx-%{ver2}/wx
/wxprec.h
472 %{_includedir}/wx-%{ver2}/wx
/xti.h
473 %{_includedir}/wx-%{ver2}/wx
/xtistrm.h
474 %{_includedir}/wx-%{ver2}/wx
/zipstrm.h
475 %{_includedir}/wx-%{ver2}/wx
/zstream.h
476 %{_includedir}/wx-%{ver2}/wx
/fs_inet.h
477 %{_includedir}/wx-%{ver2}/wx
/gsocket.h
478 %{_includedir}/wx-%{ver2}/wx
/protocol
/file.h
479 %{_includedir}/wx-%{ver2}/wx
/protocol
/ftp.h
480 %{_includedir}/wx-%{ver2}/wx
/protocol
/http.h
481 %{_includedir}/wx-%{ver2}/wx
/protocol
/protocol.h
482 %{_includedir}/wx-%{ver2}/wx
/sckaddr.h
483 %{_includedir}/wx-%{ver2}/wx
/sckipc.h
484 %{_includedir}/wx-%{ver2}/wx
/sckstrm.h
485 %{_includedir}/wx-%{ver2}/wx
/socket.h
486 %{_includedir}/wx-%{ver2}/wx
/url.h
487 %{_includedir}/wx-%{ver2}/wx
/xml
/xml.h
488 %{_includedir}/wx-%{ver2}/wx
/xtixml.h
489 %{_includedir}/wx-%{ver2}/wx
/db.h
490 %{_includedir}/wx-%{ver2}/wx
/dbkeyg.h
491 %{_includedir}/wx-%{ver2}/wx
/dbtable.h
492 %{_includedir}/wx-%{ver2}/wx
/unix
/apptbase.h
493 %{_includedir}/wx-%{ver2}/wx
/unix
/apptrait.h
494 %{_includedir}/wx-%{ver2}/wx
/unix
/execute.h
495 %{_includedir}/wx-%{ver2}/wx
/unix
/gsockunx.h
496 %{_includedir}/wx-%{ver2}/wx
/unix
/mimetype.h
497 %{_includedir}/wx-%{ver2}/wx
/unix
/pipe.h
498 %{_includedir}/wx-%{ver2}/wx
/unix
/stackwalk.h
499 %{_includedir}/wx-%{ver2}/wx
/unix
/stdpaths.h
501 # --- wxBase headers list ends here ---
503 # temporarily remove base headers
504 mkdir $RPM_BUILD_ROOT
/_save_dir
505 cp
-r $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT
/_save_dir
506 for f
in `cat wxbase
-headers.files`
; do
507 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
509 # list of all core headers:
510 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
511 # move base headers (actually all headers) back again
512 cp
-f
-r $RPM_BUILD_ROOT
/_save_dir
/* $RPM_BUILD_ROOT
%{_includedir}
513 rm -rf $RPM_BUILD_ROOT
/_save_dir
516 (cd obj
-shared
/contrib
/src
; make DESTDIR
=$RPM_BUILD_ROOT
install)
517 (cd obj
-shared
/utils
/wxrc
; make DESTDIR
=$RPM_BUILD_ROOT
install)
520 rm -rf $RPM_BUILD_ROOT
529 # link wx-config when you install RPM.
531 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
533 # link wx-config with explicit name.
534 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
542 rm -f
%{_bindir}/wx
-config
544 rm -f
%{_bindir}/%{wxconfiglink}
546 %post -n
%{wxbasename}
549 %postun -n
%{wxbasename}
552 %post -n
%{wxbasename}-devel
553 # link wx-config with explicit name.
554 ln
-sf
%{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
557 %postun -n
%{wxbasename}-devel
560 %preun -n
%{wxbasename}-devel
561 rm -f
%{_bindir}/%{wxbaseconfiglink}
578 %postun contrib
-devel
582 %defattr(-,root
,root
)
583 %doc COPYING.LIB
*.txt
584 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.
*
585 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.
*
587 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.
*
589 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.
*
590 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.
*
591 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.
*
592 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.
*
595 %defattr(-,root
,root
)
596 %{_datadir}/locale
/*/*/*
598 %files devel
-f core
-headers.files
599 %defattr(-,root
,root
)
601 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
602 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
604 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
607 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
608 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
618 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
623 %{_libdir}/wx/config/%{wxconfig}
624 %{_libdir}/wx/include/%{wxconfig}/wx
/setup.h
625 %{_libdir}/wx/config/%{wxconfigstatic}
626 %{_libdir}/wx/include/%{wxconfigstatic}/wx
/setup.h
629 %files -n
%{wxbasename}
630 %defattr(-,root
,root
)
631 %{_libdir}/libwx_base*-%{ver2}.so.
*
633 %files -n
%{wxbasename}-devel
-f wxbase
-headers.paths
634 %defattr (-,root
,root
)
635 %dir %{_includedir}/wx-%{ver2}
636 %{_libdir}/libwx_base*-%{ver2}.so
637 %{_libdir}/libwx_base*-%{ver2}.a
639 %{_libdir}/libwxregexu-%{ver2}.a
642 %{_libdir}/wx/config/%{wxbaseconfig}
643 %{_libdir}/wx/include/%{wxbaseconfig}/wx
/setup.h
644 %{_libdir}/wx/config/%{wxbaseconfigstatic}
645 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx
/setup.h
646 %{_datadir}/aclocal
/*.m4
649 %defattr(-,root
,root
)
650 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.
*
653 %defattr(-,root
,root
)
654 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.
*
655 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.
*
656 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.
*
657 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.
*
658 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.
*
659 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.
*
660 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.
*
661 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.
*
662 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.
*
663 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.
*
666 %defattr(-,root
,root
)
667 %dir %{_includedir}/wx-%{ver2}/wx
/animate
668 %{_includedir}/wx-%{ver2}/wx
/animate
/*
669 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
671 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
672 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
673 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
675 %dir %{_includedir}/wx-%{ver2}/wx
/fl
676 %{_includedir}/wx-%{ver2}/wx
/fl
/*
677 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
679 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
680 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
681 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
682 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
684 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
685 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
686 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
688 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
689 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
690 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
692 %dir %{_includedir}/wx-%{ver2}/wx
/plot
693 %{_includedir}/wx-%{ver2}/wx
/plot
/*
694 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
696 %dir %{_includedir}/wx-%{ver2}/wx
/stc
697 %{_includedir}/wx-%{ver2}/wx
/stc
/*
698 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
700 %dir %{_includedir}/wx-%{ver2}/wx
/svg
701 %{_includedir}/wx-%{ver2}/wx
/svg
/*
702 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so