]> git.saurik.com Git - apt.git/blobdiff - debian/rules
merged lp:~mvo/apt/conflicts-on-virtuals to better deal with
[apt.git] / debian / rules
index 4f6d72e062fa935424357fd920c4bfa906d9ac1d..8bfcaf385cb5eb56402273d317dd327ceeb3f265 100755 (executable)
@@ -27,10 +27,14 @@ endif
 # See below
 -include build/environment.mak
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+  export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
 else
-  export CXXFLAGS = -O2 -g -Wall
+  ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    export CXXFLAGS = -O0 -g -Wall
+  else
+    export CXXFLAGS = -O2 -g -Wall
+  endif
 endif
 
 # Default rule
@@ -47,7 +51,7 @@ BASE=.
 ifdef BUILD
 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
 else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
 endif
 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
@@ -75,28 +79,27 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
-export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+include buildlib/libversion.mak
 
 # Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
 
 debian/shlibs.local: apt-pkg/makefile
-       # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+       # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
        # one for the rest of the packages. This ensures that each package gets
-       # the right overrides.. 
+       # the right overrides
        rm -rf $@ $@.apt $@.apt-utils
-       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+       echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
 
-       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
-       echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+       echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+       echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
 
-       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
-       echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+       echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+       echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
 
-build: build/build-stamp       
-build-doc: build/build-doc-stamp       
+build: build/build-stamp
+build-doc: build/build-doc-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -109,7 +112,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+       cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -124,14 +127,12 @@ build/build-doc-stamp: build/configure-stamp
 
 clean:
        dh_testdir
-#      dh_testroot
-       -$(MAKE) clean
-       -$(MAKE) distclean
 
+       [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
 
        # Add here commands to clean up after the build process.
-       dh_clean debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
+       dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
 
 binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
@@ -142,22 +143,20 @@ libapt-pkg-doc: build-doc debian/shlibs.local
        dh_installdirs -p$@
 #
 # libapt-pkg-doc install
-#      
-       dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
-                            $(BLD)/docs/files* $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt doc/style.txt
+#
+       dh_installdocs -p$@ $(BLD)/docs/design* \
+                           $(BLD)/docs/dpkg-tech* \
+                           $(BLD)/docs/files* \
+                           $(BLD)/docs/method* \
+                           doc/libapt-pkg2_to_3.txt \
+                           doc/style.txt \
+                           $(BLD)/doc/doxygen/html
        dh_installexamples -p$@
-#      dh_installmenu -p$@
-#      dh_installinit -p$@
-#      dh_installcron -p$@
-#      dh_installman -p$@
 
-#      dh_undocumented -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
@@ -171,8 +170,10 @@ apt-doc: build-doc
 # apt-doc install
 #
        # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+                           $(BLD)/docs/guide*.html \
+                           $(BLD)/docs/offline*.text \
+                           $(BLD)/docs/offline*.html
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -186,11 +187,12 @@ apt-doc: build-doc
 # Build architecture-dependent files here.
 
 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
-apt: build debian/shlibs.local
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -213,11 +215,10 @@ apt: build debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
-       sed 's/^_//' share/apt-auth-failure.note > debian/$@/usr/share/$@/apt-auth-failure.note
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
-       cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
-#      head -n 500 ChangeLog > debian/ChangeLog
+
+       # copy lintian override
+       cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
@@ -225,20 +226,20 @@ apt: build debian/shlibs.local
        rm -f po/*.pot
 
        # move the mirror failure script in place
-       mv debian/$@/usr/bin/apt-report-mirror-failure \
-          debian/$@/usr/lib/apt/apt-report-mirror-failure \
+       #mv debian/$@/usr/bin/apt-report-mirror-failure \
+       #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ 
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
+       dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -257,21 +258,17 @@ libapt-pkg-dev: build debian/shlibs.local
        cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
 
        dh_installdocs -p$@
-#      dh_installmenu -p$@
-#      dh_installinit -p$@
-#      dh_installcron -p$@
-#      dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -287,15 +284,15 @@ apt-utils: build debian/shlibs.local
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+       dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -307,10 +304,10 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_installdirs -p$@
 
        # install the method
-       mkdir -p debian/$@/usr/lib/apt/methods
+       mkdir --parents debian/$@/usr/lib/apt/methods
        cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
 
-       dh_installdocs -p$@
+       dh_installdocs -p$@ debian/apt-transport-https.README
        dh_installexamples -p$@
 
        # Install the man pages..
@@ -321,61 +318,18 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib 
+       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-source diff:
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-# Update from CVS
-l33ch: really-clean
-       cvs update
-       buildlib/mkChangeLog
-
-# Update from CVS and then configure for build
-super-l33ch: l33ch Makefile.in
-
 configure:
        $(MAKE) configure
 
-l33ch-stamp: super-l33ch
-       touch $@
-
 really-clean: clean
-       -find -name Makefile.in -print0 | xargs -0r rm -f
+       -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
        find -name ChangeLog | xargs rm -f
        rm -f l33ch-stamp
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
-
-
-# Done by the uploader.
-#cvs update.. 
-#edit debian/changelog
-# configure.in has the version automatically updated now.
-# edit configure.in
-# debian/rules cvs-build
-
-CVS_BUILDDIR=apt-$(APT_DEBVER)
-CVS_ROOT=$(shell cat CVS/Root)
-CVS_MODULE=$(shell cat CVS/Repository)
-cvs-build:
-       rm -rf debian/cvs-build
-       mkdir -p debian/cvs-build
-       (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
-       $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
-       (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
-
-cvs-mkul:
-       -mkdir -p ../upload-$(APT_DEBVER)
-       cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
-
-arch-build:
-       rm -rf debian/arch-build
-       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
-       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
-       $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)