]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
Bug#739988: Fix autopkgtest missing dependencies and locale
[apt.git] / debian / tests / run-tests
index 6ea5035688b194634abcea6ebca02f915518a907..6dc4eaa93a0de2ea066868f16ed65c44d9148b06 100644 (file)
@@ -2,6 +2,17 @@
 
 set -e
 
-make
-make test
-test/integration/run-tests
+unset LANGUAGE
+export LC_ALL=C
+
+# we need the buildin webserver for the tests
+if [ ! -e environment.mak ]; then
+    make startup
+fi
+make -C test/interactive-helper/
+
+# run against the installed apt
+APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
+APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
+./test/integration/run-tests