]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
warning: unused parameter ‘foo’ [-Wunused-parameter]
[apt.git] / debian / tests / run-tests
index 6ea5035688b194634abcea6ebca02f915518a907..41bafda9982520b41a366d76d07ace3739188182 100644 (file)
@@ -2,6 +2,15 @@
 
 set -e
 
-make
-make test
-test/integration/run-tests
+# we need the buildin webserver for the tests
+if [ ! -e environment.mak ]; then
+    make startup
+fi
+make -C test/interactive-helper/
+
+# run against the installed apt
+APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
+APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
+APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
+./test/integration/run-tests