# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.26 2001/02/23 04:29:59 tausq Exp $
+# $Id: rules,v 1.39 2002/11/09 06:34:13 doogie Exp $
-# LD_LIBRARY_PATH=pwd/debian/tmp/usr/lib dh_shlibdeps -papt
-# dpkg: /home/jgg/work/apt2/debian/tmp/usr/lib/libapt-pkg.so.2.9 not found.
+# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
+# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
# For the deb builder, you can run 'debian/rules cvs-build', which does all
# steps nescessary to produce a proper source tarball with the CVS/ removed.
# create ../upload-<VER>, with all the files needed to be uploaded placed
# in it.
+export DH_COMPAT=2
+
# See below
-include build/environment.mak
+-include build/environment.mak
# Default rule
build:
# Find the libapt-pkg major version for use in other control files
export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+
+# Determine which package we should provide in the control files
+LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+
debian/shlibs.local: apt-pkg/makefile
- # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+ # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
# the right overrides..
rm -rf $@ $@.apt $@.apt-utils
- echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
+ echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+
+ echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+ echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
- echo "libapt-pkg $(LIBAPTPKG_MAJOR) libapt-pkg$(LIBAPTPKG_MAJOR)" > $@.apt-utils
- echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+ echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+ echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
- echo "libapt-pkg $(LIBAPTPKG_MAJOR) libapt-pkg$(LIBAPTPKG_MAJOR)" > $@
- echo "libapt-inst $(LIBAPTINST_MAJOR) libapt-inst$(LIBAPTINST_MAJOR)" >> $@
-
build: build/build-stamp
# Note that this is unconditionally done first as part of loading environment.mak
# configure-stamp. Otherwise we can get stale or invalid, or missing config data.
build/environment.mak: build/configure-stamp
@true
-
+
configure: configure.in
build/configure-stamp: configure
dh_testdir
-mkdir build
+ cp COPYING debian/copyright
(cd build; ../configure)
touch $@
rm -f build-stamp debian/shlibs.local
rm -rf build
rm -f debian/shlibs.local.apt debian/shlibs.local.apt-utils
-
+
# Add here commands to clean up after the build process.
-$(MAKE) clean
-$(MAKE) distclean
- dh_clean
+ dh_clean debian/copyright
binary-indep: libapt-pkg-doc
# Build architecture-independent files here.
dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
$(BLD)/docs/files* $(BLD)/docs/method* \
doc/libapt-pkg2_to_3.txt doc/style.txt
-
+
-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
-
+
dh_installexamples -p$@
# dh_installmenu -p$@
# dh_installinit -p$@
dh_fixperms -p$@
# dh_suidregister -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=$(LIBAPTPKG_MAJOR)
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
#
# apt install
#
- cp $(BLD)/bin/apt-* debian/tmp/usr/bin/
-
+ cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+
# Remove the bits that are in apt-utils
- rm $(addprefix debian/tmp/usr/bin/apt-,$(APT_UTILS))
-
+ rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+
# install the shared libs
- find $(BLD)/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
- find $(BLD)/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
+ find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
- cp $(BLD)/bin/methods/* debian/tmp/usr/lib/apt/methods/
+ cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
- cp $(BLD)/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
+ cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
+ cp -r $(BLD)/locale debian/apt/usr/
# Copy the guides
dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
$(BLD)/docs/offline.text $(BLD)/docs/offline.html
-
+
# One or the other..
- -cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
- -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp
-
+ -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
+ -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
+
# head -n 500 ChangeLog > debian/ChangeLog
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1
+ dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_shlibdeps -papt -l`pwd`/debian/tmp/usr/lib -- -Ldebian/shlibs.local.apt
-# LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=$(LIBAPTPKG_MAJOR)
- dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V 'libapt-pkg$(LIBAPTPKG_MAJOR)' -papt
+ dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+ dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
dh_md5sums -p$@
dh_builddeb -p$@
#
# libapt-pkg-dev install
#
- cp -a $(BLD)/bin/libapt-pkg.so debian/libapt-pkg-dev/usr/lib/
- cp -a $(BLD)/bin/libapt-inst.so debian/libapt-pkg-dev/usr/lib/
- #ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+ cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
+ cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
+# ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
dh_installdocs -p$@
dh_fixperms -p$@
# dh_suidregister -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=$(LIBAPTPKG_MAJOR)
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
dh_installdirs -p$@
# install the shared libs
- find $(BLD)/bin/ -type f -name "libapt-inst.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
- find $(BLD)/bin/ -type l -name "libapt-inst.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+ find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
dh_installdocs -p$@
-
+
# Install the man pages..
mkdir -p debian/$@/usr/share/man/man1
- cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 debian/$@/usr/share/man/man1/
-
+ -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
+
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
- dh_gencontrol -p$@ -u -Vlibapt-inst:major=$(LIBAPTINST_MAJOR)
- dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V 'libapt-inst$(LIBAPTINST_MAJOR)' -p$@
+ LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+ dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+ dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
dh_md5sums -p$@
dh_builddeb -p$@
cvs-build:
rm -rf debian/cvs-build
cvs update
- #buildlib/mkChangeLog
$(MAKE) startup
$(MAKE) doc
tar c --exclude CVS --exclude cvs-build . |\
(mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-# The next line isn't needed, as debuild will make the .tar.gz for us.
-# (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
(cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
- #rm ChangeLog
cvs-mkul:
-mkdir -p ../upload-$(APT_DEBVER)