-apt (0.9.3) unstable; urgency=low
+apt (0.9.3) UNRELEASED; urgency=low
[ David Kalnischkies ]
* apt-pkg/contrib/strutl.cc:
- use the correct library name the symbols header
* apt-pkg/pkgcachegen.cc:
- check if NewDescription allocation has failed and error out accordingly
+ - check if we work on a valid description in IsDuplicateDescription as
+ we end up working on dangling pointers otherwise which segfaults on
+ s390x and ppc64 (Closes: #669427)
* apt-pkg/deb/deblistparser.cc:
- check length and containing chars for a given description md5sum
+ * ensure that apti18n.h is included last as advertised (Closes: #671623)
+ * apt-pkg/acquire-worker.cc:
+ - revert the use of FileFd::Write in OutFdReady as we don't want error
+ reports about EAGAIN here as we retry later. Thanks to YOSHINO Yoshihito
+ for the report. (Closes: #671721)
+ * apt-pkg/contrib/fileutl.cc:
+ - check that the fd which are closed are valid
+ - ensure that we do init d only once and especially not with its own
+ content as this causes some "interesting" hickups resulting in segfaults
+ as it seems (Closes: #554387, #670979)
+ - collect zombie (de)compressor processes on reopen
+ - ensure that in error conditions the Fail flag is set
+ - ensure that d is set before accessing it
+ * apt-pkg/aptconfiguration.cc:
+ - use NULL instead of "" for no (un)compress parameters
+ * apt-pkg/algorithms.cc:
+ - factor out of ListUpdate a AcquireUpdate to be able to provide your
+ own pkgAcquire fetcher to the wrapper
+ * apt-inst/deb/debfile.h:
+ - readd 'md5.h' to the uncleaned header includes to make qapt build
+ against us again unchanged to unblock transition (Closes: #669163)
- -- David Kalnischkies <kalnischkies@gmail.com> Wed, 02 May 2012 22:28:32 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Mon, 07 May 2012 21:12:23 +0200
apt (0.9.2) unstable; urgency=low