]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
update changelog
[apt.git] / debian / apt.postinst
index 9ff1e031c607cb56a5d02452b39d805608a51435..70de237d0a51c092788f5e239606fad3f2d96aeb 100644 (file)
@@ -15,12 +15,16 @@ set -e
 
 case "$1" in
     configure)
-       SECRING='/etc/apt/secring.gpg'
-       # test if secring is an empty normal file
-       if test -f $SECRING -a ! -s $SECRING; then
-               rm -f $SECRING
+       if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then
+           # we are using tmpfiles for both
+           rm -f /etc/apt/trustdb.gpg
+           # this removal was done unconditional since 0.8.15.3
+           SECRING='/etc/apt/secring.gpg'
+           # test if secring is an empty normal file
+           if test -f $SECRING -a ! -s $SECRING; then
+               rm -f $SECRING
+           fi
        fi
-       apt-key update
 
         # ensure tighter permissons on the logs, see LP: #975199
         if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then