]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
* apt-pkg/cdrom.cc:
[apt.git] / debian / apt.postinst
index 88fb932dfed5628494fd8efdb2b8b945755b12ff..4d87c4e256f8ab3ee936a6037a6f0b748ef53580 100644 (file)
@@ -15,13 +15,12 @@ set -e
 
 case "$1" in
     configure)
-
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/debian-archive.gpg /etc/apt/trusted.gpg
-        fi
-
+       SECRING='/etc/apt/secring.gpg'
+       # test if secring is an empty normal file
+       if test -f $SECRING -a ! -s $SECRING; then
+               rm -f $SECRING
+       fi
        apt-key update
-
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)