-
- if ! test -f /etc/apt/trusted.gpg; then
- cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
- fi
-
+ SECRING='/etc/apt/secring.gpg'
+ # test if secring is an empty normal file
+ if test -f $SECRING -a ! -s $SECRING; then
+ rm -f $SECRING
+ fi
+ apt-key update