]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
* apt-pkg/contrib/configuration.cc:
[apt.git] / debian / apt.postinst
index 773077aa56594d5232e1b98c5aabc1a6d9c6c81b..4d87c4e256f8ab3ee936a6037a6f0b748ef53580 100644 (file)
@@ -15,9 +15,12 @@ set -e
 
 case "$1" in
     configure)
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
-        fi
+       SECRING='/etc/apt/secring.gpg'
+       # test if secring is an empty normal file
+       if test -f $SECRING -a ! -s $SECRING; then
+               rm -f $SECRING
+       fi
+       apt-key update
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)