]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* cmdline/apt-cache.cc:
[apt.git] / debian / changelog
index b4aa5753b6fed195b60a1fda1620013154d67c85..054088ec26bc0a455e93f6ce49d913b812e06276 100644 (file)
@@ -1,3 +1,40 @@
+apt (0.7.26~exp6) UNRELEASED; urgency=low
+
+  [ David Kalnischkies ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - write Disappeared also to the history.log
+    - forward manual-installed bit on package disappearance
+  * apt-pkg/deb/debsystem.cc:
+    - add better config item for extended_states file
+  * apt-pkg/depcache.cc:
+    - do the autoremove mark process also for required packages to handle
+      these illegally depending on lower priority packages (Closes: #583517)
+    - try harder to find the other pseudo versions for autoremove multiarch
+  * apt-pkg/aptconfiguration.cc:
+    - remove duplicate architectures in getArchitectures()
+  * apt-pkg/indexrecords.{cc,h}:
+    - add a constant Exists check for MetaKeys
+  * apt-pkg/acquire-item.cc:
+    - do not try PDiff if it is not listed in the Meta file
+  * apt-pkg/cacheiterator.h:
+    - let pkgCache::Iterator inherent std::iterator
+  * apt-pkg/depcache.cc:
+    - correct "Dangerous iterator usage." pointed out by cppcheck
+  * ftparchive/writer.h:
+    - add a virtual destructor to FTWScanner class (for cppcheck)
+  * apt-pkg/packageset.h:
+    - add a simple wrapper around std::set for packages with it
+    - move regex magic from apt-get to new FromRegEx method
+    - move cmdline parsing from apt-cache to new FromCommandLine method
+  * apt-pkg/contrib/cmdline.cc:
+    - fix segfault in SaveInConfig caused by writing over char[] sizes
+  * apt-pkg/pkgcache.cc:
+    - get the best matching arch package from a group with FindPreferredPkg
+  * cmdline/apt-cache.cc:
+    - make the search multiarch compatible by using GrpIterator instead
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Mon, 31 May 2010 20:00:24 +0200
+
 apt (0.7.26~exp5) experimental; urgency=low
 
   [ David Kalnischkies ]
@@ -55,6 +92,11 @@ apt (0.7.26~exp5) experimental; urgency=low
   * apt-pkg/acquire-item.cc:
     - Fix pkgAcqFile::Custom600Headers() to always return something.
   
+
+  [ Christian Perrier ]
+  * Slovak translation update. Closes: #581159
+  * Italian translation update. Closes: #581742
+
  -- Michael Vogt <mvo@debian.org>  Tue, 25 May 2010 16:01:42 +0200
 
 apt (0.7.26~exp4) experimental; urgency=low