]> git.saurik.com Git - apt.git/blobdiff - debian/rules
replace "which" with "command -v" for portability
[apt.git] / debian / rules
index 60966b09f2e343792010ff785c5cccf6b9be5ac2..db59d28987caff13bf18f9aee309b0a2c68bd79b 100755 (executable)
@@ -24,7 +24,7 @@ confflags += --with-procs=$(PARALLEL)
 # See below
 -include build/environment.mak
 
-ifneq (,$(shell which dpkg-buildflags))
+ifneq (,$(shell command -v dpkg-buildflags))
   # make does not export to $(shell) so we need to workaround 
   # (http://savannah.gnu.org/bugs/?10593)
   dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
@@ -89,7 +89,7 @@ build/environment.mak: build/configure-stamp
 configure: configure.ac
 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
        dh_testdir
-       -mkdir build
+       mkdir -p build
        cp COPYING debian/copyright
        cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
        touch $@