]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
debian/rules: add hardening=+all
[apt.git] / debian / apt.postinst
old mode 100644 (file)
new mode 100755 (executable)
index fab0265..deb422a
@@ -15,6 +15,15 @@ set -e
 
 case "$1" in
     configure)
+       if dpkg --compare-versions "$2" lt 1.1~exp4; then
+           # apt-key before 0.9.10 could leave empty keyrings around
+           find /etc/apt/trusted.gpg.d/ -name '*.gpg' | while read keyring; do
+               if ! test -s "$keyring"; then
+                   rm -f "$keyring"
+               fi
+           done
+       fi
+
        if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then
            # we are using tmpfiles for both
            rm -f /etc/apt/trustdb.gpg
@@ -27,8 +36,8 @@ case "$1" in
        fi
 
         # add unprivileged user for the apt methods
-        adduser --force-badname --system --no-create-home \
-            --quiet _apt || true
+        adduser --force-badname --system -home /var/empty \
+            --no-create-home --quiet _apt || true
         chown -R _apt:root \
             /var/lib/apt/lists \
             /var/cache/apt/archives