]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Merge remote-tracking branch 'mvo/debian/sid' into debian/sid
[apt.git] / debian / rules
index eec0166078e23811e6bf38b5403faee520e4236a..f8b392986215519ac9e77504180d1df088de9776 100755 (executable)
@@ -189,6 +189,8 @@ apt: build-binary build-manpages debian/apt.install
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
        cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
        chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       # install vendor specific apt confs
+       find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir