+apt (0.7.21) UNRELEASED; urgency=low
+
+ [ Osamu Aoki ]
+ * Updated cron script to support backups by hardlinks and
+ verbose levels. All features turned off by default.
+ * Added more error handlings. Closes: #438803, #462734, #454989,
+ * Refactored condition structure to make download and upgrade performed
+ if only previous steps succeeded. Closes: #341970
+ * Documented all cron script related configuration items in
+ configure-index.
+
+ [ Michael Vogt ]
+ * apt-pkg/acquire.cc:
+ - make the max pipeline depth of the acquire queue configurable
+ via Acquire::Max-Pipeline-Depth
+ * apt-pkg/deb/dpkgpm.cc:
+ - add Dpkg::UseIoNice boolean option to run dpkg with ionice -c3
+ (off by default)
+ - send "dpkg-exec" message on the status fd when dpkg is run
+ * apt-pkg/algorithms.cc:
+ - consider recommends when making the scores for the problem
+ resolver
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 28 May 2009 17:51:42 +0200
+
+ [ Michael Vogt ]
+ * apt-pkg/indexcopy.cc:
+ - support having CDs with no Packages file (just a Packages.gz)
+ by not forcing a verification on non-existing files
+ (LP: #255545)
+ - remove the gettext from a string that consists entirely
+ of variables (LP: #56792)
+ * doc/makefile:
+ - add examples/apt-https-method-example.conf
+ * apt-pkg/cacheiterators.h:
+ - add missing checks for Owner == 0 in end()
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix potential hang when in a backgroud process group
+ * apt-pkg/indexrecords.cc:
+ - fix some i18n issues
+ * apt-pkg/contrib/strutl.h:
+ - add new strprintf() function to make i18n strings easier
+ * methods/gpgv.cc:
+ - fix compiler warning
+ * cmdline/apt-get.cc:
+ - fix "apt-get source pkg=ver" if binary name != source name
+ and show a message (LP: #202219)
+ - fix "apt-get source pkg" if there is a binary package and
+ a source package of the same name but from different
+ packages (LP: #330103)
+ * apt-pkg/deb/debsystem.cc:
+ - make strings i18n able
+ * apt-pkg/contrib/strutl.cc:
+ - fix TimeToStr i18n (LP: #289807)
+ * [ABI break] merge support for http redirects, thanks to
+ Jeff Licquia and Anthony Towns
+ * [ABI break] use int for the package IDs (thanks to Steve Cotton)
+ * apt-pkg/pkgcache.cc:
+ - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+ state (LP: #322955)
+ * methods/https.cc:
+ - add Acquire::https::AllowRedirect support
+ * methods/gpgv.cc:
+ - properly check for expired and revoked keys (closes: #433091)
+ * fix problematic use of tolower() when calculating the version
+ hash by using locale independant tolower_ascii() function.
+ Thanks to M. Vefa Bicakci (LP: #80248)
+ * build fixes for g++-4.4
+ * cmdline/apt-mark:
+ - add "showauto" option to show automatically installed packages
+
+ [ Dereck Wonnacott ]
+ * apt-ftparchive might write corrupt Release files (LP: #46439)
+ * Apply --important option to apt-cache depends (LP: #16947)
+ * Clarify the --help for 'purge' (LP: #243948)
+
+
+ [ Colin Watson ]
+ * cmdline/acqprogress.cc:
+ - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+ dlstatus messages on the status-fd (LP: #290234).
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
+
+apt (0.7.20) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * debian/changelog:
+ - Fixed place of 'merged install-recommends and install-task branches'
+ from 0.6.46.1 to 0.7.0. (Closes: #439866)
+ * buildlib/config.{sub,guess}:
+ - Renewed. This fixes lintian errors.
+ * doc/apt.conf.5.xml, debian/apt-transport-https:
+ - Documented briefly 'APT::https' group of options. (Closes: #507398)
+ - Applied patch from Daniel Burrows to document 'Debug' group of options.
+ (Closes: #457265)
+ - Mentioned 'APT::Periodic' and 'APT::Archives' groups of options.
+ (Closes: #438559)
+
+ [ Michael Vogt ]
+ * apt-pkg/depcache.cc:
+ - when checking for new important deps, skip critical ones
+ (LP: #236360)
+ * document --install-recommends and --no-install-recommends
+ (thanks to Dereck Wonnacott, LP: #126180)
+ * make "apt-get build-dep" installed packages marked automatic
+ by default. This can be changed by setting the value of
+ APT::Get::Build-Dep-Automatic to false (thanks to Aaron
+ Haviland, closes: #44874, LP: #248268)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sat, 06 Dec 2008 20:57:00 +0200
+
+apt (0.7.20~exp2) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * doc/examples/sources.list:
+ - Removed obsolete commented non-us deb-src entry, replaced it with
+ 'deb-src security.debian.org' one. (Closes: #411298)
+ * apt-pkg/contrib/mmap.cc:
+ - Added instruction how to work around MMap error in MMap error message.
+ (Closes: #385674, 436028)
+
+ [ Christian Perrier ]
+ * Translations:
+ - French corrected (remove awful use of first person)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 02 Dec 2008 20:30:14 +0100
+
apt (0.7.19) unstable; urgency=low
[ Eugene V. Lyubimkin ]
- Mentioned allowed characters in file names in /etc/apt/sources.list.d.
Thanks to Matthias Urlichs. (Closes: #426913)
* doc/apt-get.8.xml:
+ - Explicitly say that 'dist-upgrade' command may remove packages.
- Included '-v'/'--version' as a command to synopsis.
* cmdline/apt-cache.cc:
- Advanced built-in help. Patch by Andre Felipe Machado. (Closes: #286061)
is a request to install only one package and it is not installable.
(Closes: #419521)
- -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sat, 08 Nov 2008 12:40:19 +0200
+
+ [ Michael Vogt ]
+ - fix SIGHUP handling (closes: #463030)
+
+ [ Christian Perrier ]
+ * Translations:
+ - French updated
+ - Bulgarian updated. Closes: #505476
+ - Slovak updated. Closes: #505483
+ - Swedish updated. Closes: #505491
+ - Japanese updated. Closes: #505495
+ - Korean updated. Closes: #505506
+ - Catalan updated. Closes: #505513
+ - British English updated. Closes: #505539
+ - Italian updated. Closes: #505518, #505683
+ - Polish updated. Closes: #505569
+ - German updated. Closes: #505614
+ - Spanish updated. Closes: #505757
+ - Romanian updated. Closes: #505762
+ - Simplified Chinese updated. Closes: #505727
+ - Portuguese updated. Closes: #505902
+ - Czech updated. Closes: #505909
+ - Norwegian Bokmål updated. Closes: #505934
+ - Brazilian Portuguese updated. Closes: #505949
+ - Basque updated. Closes: #506085
+ - Russian updated. Closes: #506452
+ - Marathi updated.
+ - Ukrainian updated. Closes: #506545
+
+ -- Michael Vogt <mvo@debian.org> Mon, 24 Nov 2008 10:33:54 +0100
apt (0.7.18) unstable; urgency=low
[ Christian Perrier ]
* Translations:
- French updated
+ - Thai updated. Closes: #505067
[ Eugene V. Lyubimkin ]
* doc/examples/configure-index:
* support for unattended-upgrades (via unattended-upgrades
package)
* added apt-transport-https method
+ * merged "install-recommends" branch (ABI break):
+ - new "--install-recommends"
+ - install new recommends on "upgrade" if --install-recommends is
+ given
+ - new "--fix-policy" option to install all packages with unmet
+ important dependencies (usefull with --install-recommends to
+ see what not-installed recommends are on the system)
+ - fix of recommended packages display (only show CandidateVersion
+ fix or-group handling)
+ * merged "install-task" branch (use with "apt-get install taskname^")
-- Michael Vogt <mvo@debian.org> Fri, 12 Jan 2007 20:48:07 +0100
apt (0.6.46.1) unstable; urgency=low
- * merged "install-recommends" branch (ABI break):
- - new "--install-recommends"
- - install new recommends on "upgrade" if --install-recommends is
- given
- - new "--fix-policy" option to install all packages with unmet
- important dependencies (usefull with --install-recommends to
- see what not-installed recommends are on the system)
- - fix of recommended packages display (only show CandidateVersion
- fix or-group handling)
- * merged "install-task" branch (use with "apt-get install taskname^")
* methods/gzip.cc:
- deal with empty files
* Applied patch from Daniel Schepler to make apt bin-NMU able.