* Italian translation update. Closes: #581742
[ Martin Pitt ]
+ * debian/rules:
+ - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+ CXXFLAGS.
* apt-pkg/contrib/fileutl.{h,cc}:
- Add support for transparent reading of gzipped files.
- Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
+ - [Weak internal ABI BREAK] This changes the behaviour of FileFd for
+ reading gzipped files.
+ * configure.in:
+ - Check for zlib library and headers.
* apt-pkg/deb/debindexfile.cc:
- If we do not find uncompressed package/source/translation indexes, look
for gzip compressed ones.
+ * apt-pkg/acquire-item.cc:
+ - If the Acquire::GzipIndexes option is true and we download a gzipped
+ index file, keep it as it is (and rename to .gz) instead of
+ uncompressing it.
+ * doc/apt.conf.5.xml:
+ - Document the new Acquire::GzipIndexes option.
+ * doc/po/apt-doc.pot, doc/po/de.po:
+ - German translation of new Acquire::GzipIndexes option.
+ * Add test/test-indexes.sh:
+ - Test behaviour of index retrieval and usage, in particular with
+ uncompressed and gzip compressed indexes.
+ * apt-pkg/acquire-item.cc:
+ - Fix return value of pkgAcqFile::Custom600Headers() in the non-index
+ case, to avoid returning NULL and causing crashers in callers. This also
+ fixes a compiler warning.
-- Christian Perrier <bubulle@debian.org> Tue, 11 May 2010 19:52:00 +0200