]> git.saurik.com Git - apt.git/blobdiff - debian/rules
debian: Make better use of the tree installed by CMake
[apt.git] / debian / rules
index c1dba72afd66fa97ec789ba62f18f1697493c762..ab101c2e1ab3bdc33990052cdc42856cb4b807a2 100755 (executable)
@@ -8,6 +8,8 @@ export DEB_BUILD_MAINT_OPTIONS := hardening=+all
 # do not fail as we are just experimenting with symbol files for now
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
+export CTEST_OUTPUT_ON_FAILURE=1
+
 %:
        dh $@ --with systemd --parallel --buildsystem=cmake
 
@@ -17,7 +19,7 @@ override_dh_install-indep:
 
 override_dh_install-arch:
        dh_movefiles
-       dh_install --fail-missing
+       dh_install --list-missing
        install -m 644 debian/apt.conf.autoremove debian/apt/etc/apt/apt.conf.d/01autoremove
        install -m 755 debian/apt.auto-removal.sh debian/apt/etc/kernel/postinst.d/apt-auto-removal