]> git.saurik.com Git - apt.git/blobdiff - debian/rules
apt-cache: stats: Average is over used, not all, buckets
[apt.git] / debian / rules
index db59d28987caff13bf18f9aee309b0a2c68bd79b..ce7d19dec4529c1785cc79c0fd1d31f7d8cf91fd 100755 (executable)
@@ -24,7 +24,7 @@ confflags += --with-procs=$(PARALLEL)
 # See below
 -include build/environment.mak
 
-ifneq (,$(shell command -v dpkg-buildflags))
+ifneq (,$(shell which dpkg-buildflags))
   # make does not export to $(shell) so we need to workaround 
   # (http://savannah.gnu.org/bugs/?10593)
   dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
@@ -60,6 +60,11 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
+
 # APT Programs in apt-utils
 APT_UTILS=ftparchive sortpkgs extracttemplates