]> git.saurik.com Git - apt.git/blobdiff - debian/rules
deprecate confusing Pkg.CandVersion() method
[apt.git] / debian / rules
index db59d28987caff13bf18f9aee309b0a2c68bd79b..7b7df7ad962788289dd42286c3c3a1d747c6f265 100755 (executable)
@@ -24,7 +24,7 @@ confflags += --with-procs=$(PARALLEL)
 # See below
 -include build/environment.mak
 
-ifneq (,$(shell command -v dpkg-buildflags))
+ifneq (,$(shell which dpkg-buildflags))
   # make does not export to $(shell) so we need to workaround 
   # (http://savannah.gnu.org/bugs/?10593)
   dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
@@ -60,6 +60,11 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
+
 # APT Programs in apt-utils
 APT_UTILS=ftparchive sortpkgs extracttemplates
 
@@ -217,13 +222,17 @@ apt: build-binary build-manpages debian/apt.install
        #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
        # move the apt-helper in place
-       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper 
+       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+       # install apt.systemd.daily helper in the right place
+       install -m755 debian/apt.systemd.daily debian/$@/usr/lib/apt/
 
        dh_bugfiles -p$@
        dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
-       dh_installcron -p$@
+       dh_installcron -p$@ --name=apt-compat
+       dh_systemd_enable -p$@ apt-daily.timer
+       dh_systemd_start -p$@ apt-daily.timer
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_installlogrotate -p$@