]> git.saurik.com Git - apt.git/blobdiff - debian/rules
implement debian/rules build-{arch,indep} as required by policy 3.9.4
[apt.git] / debian / rules
index 9eda3a8fa0056f8cef5c827f7ea69a5b4ff5f0cc..4686f569de06b659a7adb5a4ca8673e0f5929f85 100755 (executable)
@@ -34,9 +34,6 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
-APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
-APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -53,19 +50,8 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
-# Rebuild configure.in to have the correct version from the change log
-ifneq ($(APT_DEBVER),$(APT_CONFVER))
-ifneq ($(APT_DEBVER),)
-.PHONY: configure.in
-configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
-endif
-else
-configure.in:
-endif
-
 # APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
+APT_UTILS=ftparchive sortpkgs extracttemplates
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -80,8 +66,9 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
 # do not fail as we are just experimenting with symbol files for now
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
-build: build/build-stamp
-build-doc: build/build-doc-stamp
+build-binary: build/build-binary-stamp
+build-debiandoc: build/build-debiandoc-stamp
+build-manpages: build/build-manpages-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -89,7 +76,7 @@ build-doc: build/build-doc-stamp
 build/environment.mak: build/configure-stamp
        @true
 
-configure: configure.in
+configure: configure.ac
 build/configure-stamp: configure
        dh_testdir
        -mkdir build
@@ -97,7 +84,7 @@ build/configure-stamp: configure
        cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
        touch $@
 
-build/build-stamp: build/configure-stamp
+build/build-binary-stamp: build/configure-stamp
        # Add here commands to compile the package.
        $(MAKE) binary
        # compat symlink for the locale split
@@ -111,13 +98,19 @@ else
 endif
        touch $@
 
-build/build-doc-stamp: build/configure-stamp
+build/build-debiandoc-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) debiandoc
+       touch $@
+
+build/build-manpages-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) doc
+       $(MAKE) manpages
        touch $@
 
 clean:
        dh_testdir
+       dh_clean
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
@@ -127,9 +120,8 @@ clean:
 debian/%.install: debian/%.install.in
        sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
-binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build-doc
+libapt-pkg-doc: build-debiandoc
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -155,7 +147,7 @@ libapt-pkg-doc: build-doc
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-doc: build-doc
+apt-doc: build-debiandoc
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -179,9 +171,8 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
-apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-doc
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build-binary build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -190,6 +181,8 @@ apt: build build-doc
 # apt install
 #
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+       cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
@@ -199,7 +192,7 @@ apt: build build-doc
        dh_install -p$@ --sourcedir=$(BLD)
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
 
        # https has its own package
        rm debian/$@/usr/lib/apt/methods/https
@@ -211,7 +204,7 @@ apt: build build-doc
        dh_bugfiles -p$@
        dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
@@ -225,7 +218,7 @@ apt: build build-doc
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg-dev: build debian/libapt-pkg-dev.install
+libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -245,7 +238,7 @@ libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_builddeb -p$@
 
 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build
+apt-utils: build-binary build-manpages
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -253,6 +246,7 @@ apt-utils: build
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+       cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
 
        dh_install -p$@ --sourcedir=$(BLD)
        dh_link -p$@
@@ -260,7 +254,7 @@ apt-utils: build
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -273,7 +267,7 @@ apt-utils: build
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
+$(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -292,7 +286,7 @@ $(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
+$(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -311,7 +305,7 @@ $(LIBAPT_INST): build debian/$(LIBAPT_INST).install
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-transport-https: build libapt-pkg-dev
+apt-transport-https: build-binary libapt-pkg-dev
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -337,10 +331,12 @@ apt-transport-https: build libapt-pkg-dev
 configure:
        $(MAKE) configure
 
-really-clean: clean
-       -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
-       find -name ChangeLog | xargs rm -f
-       rm -f l33ch-stamp
-
+# translate targets to targets required by debian-policy
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
+binary-indep: apt-doc libapt-pkg-doc
 binary: binary-indep binary-arch
+build-arch: build-binary
+build-indep: build-manpages build-debiandoc
+build: build-indep build-arch
+
 .PHONY: build clean binary-indep binary-arch binary