]> git.saurik.com Git - apt.git/blobdiff - debian/libapt-pkg5.0.symbols
Merge pull request julian-klode/apt#3 from adrian17/master
[apt.git] / debian / libapt-pkg5.0.symbols
index 740f19ed4314d6254aa038206c4c1f9a09e8a82a..47839217b4b6e24c3355013e12e648efd7044e5e 100644 (file)
@@ -298,7 +298,6 @@ libapt-pkg.so.5.0 libapt-pkg5.0 #MINVER#
  (c++)"Configuration::Configuration(Configuration::Item const*)@APTPKG_5.0" 0.8.0
  (c++)"Configuration::Configuration()@APTPKG_5.0" 0.8.0
  (c++)"Configuration::~Configuration()@APTPKG_5.0" 0.8.0
  (c++)"Configuration::Configuration(Configuration::Item const*)@APTPKG_5.0" 0.8.0
  (c++)"Configuration::Configuration()@APTPKG_5.0" 0.8.0
  (c++)"Configuration::~Configuration()@APTPKG_5.0" 0.8.0
- (c++)"WeakPointable::~WeakPointable()@APTPKG_5.0" 0.8.0
  (c++)"debListParser::ParseDepends(char const*, char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, unsigned int&, bool const&, bool const&)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::ConvertRelation(char const*, unsigned int&)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::GetPrio(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::ParseDepends(char const*, char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, unsigned int&, bool const&, bool const&)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::ConvertRelation(char const*, unsigned int&)@APTPKG_5.0" 0.8.0
  (c++)"debListParser::GetPrio(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)@APTPKG_5.0" 0.8.0
@@ -1533,6 +1532,16 @@ libapt-pkg.so.5.0 libapt-pkg5.0 #MINVER#
  (c++)"GetSrvRecords(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::vector<SrvRec, std::allocator<SrvRec> >&)@APTPKG_5.0" 1.1~exp15
  (c++)"PopFromSrvRecs(std::vector<SrvRec, std::allocator<SrvRec> >&)@APTPKG_5.0" 1.1~exp15
  (c++)"SrvRec::operator==(SrvRec const&) const@APTPKG_5.0" 1.1~exp15
  (c++)"GetSrvRecords(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::vector<SrvRec, std::allocator<SrvRec> >&)@APTPKG_5.0" 1.1~exp15
  (c++)"PopFromSrvRecs(std::vector<SrvRec, std::allocator<SrvRec> >&)@APTPKG_5.0" 1.1~exp15
  (c++)"SrvRec::operator==(SrvRec const&) const@APTPKG_5.0" 1.1~exp15
+ (c++)"debDebianSourceDirIndex::~debDebianSourceDirIndex()@APTPKG_5.0" 1.1.4
+ (c++)"debDebianSourceDirIndex::GetComponent[abi:cxx11]() const@APTPKG_5.0" 1.1.4
+ (c++)"debDscFileIndex::GetArchitecture[abi:cxx11]() const@APTPKG_5.0" 1.1.4
+ (c++)"debDscFileIndex::GetComponent[abi:cxx11]() const@APTPKG_5.0" 1.1.4
+ (c++)"debDscFileIndex::GetIndexFlags() const@APTPKG_5.0" 1.1.4
+ (c++)"FileFd::Flush()@APTPKG_5.0" 1.1.9
+ (c++)"isspace_ascii(int)@APTPKG_5.0" 1.1.9
+ (c++)"metaIndex::IsArchitectureAllSupportedFor(IndexTarget const&) const@APTPKG_5.0" 1.1.9
+ (c++)"pkgTagFile::Init(FileFd*, pkgTagFile::Flags, unsigned long long)@APTPKG_5.0" 1.2~exp1
+ (c++)"pkgTagFile::pkgTagFile(FileFd*, pkgTagFile::Flags, unsigned long long)@APTPKG_5.0" 1.2~exp1
 ### symbol versioning:
  APTPKG_5.0@APTPKG_5.0 1.1~exp9
 ### gcc artifacts
 ### symbol versioning:
  APTPKG_5.0@APTPKG_5.0 1.1~exp9
 ### gcc artifacts
@@ -1553,6 +1562,7 @@ libapt-pkg.so.5.0 libapt-pkg5.0 #MINVER#
  (c++|optional=std)"void std::vector<pkgCache::PrvIterator*, std::allocator<pkgCache::PrvIterator*> >::emplace_back<pkgCache::PrvIterator*>(pkgCache::PrvIterator*&&)@APTPKG_5.0" 1.1~exp15
  (c++|optional=std)"void std::vector<pkgCache::VerIterator, std::allocator<pkgCache::VerIterator> >::emplace_back<pkgCache::VerIterator>(pkgCache::VerIterator&&)@APTPKG_5.0" 1.1~exp15
  (c++|optional=std)"SrvRec* std::__move_merge<__gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, SrvRec*, __gnu_cxx::__ops::_Iter_less_iter>(__gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, __gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, __gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, __gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, SrvRec*, __gnu_cxx::__ops::_Iter_less_iter)@APTPKG_5.0" 1.1~exp15
  (c++|optional=std)"void std::vector<pkgCache::PrvIterator*, std::allocator<pkgCache::PrvIterator*> >::emplace_back<pkgCache::PrvIterator*>(pkgCache::PrvIterator*&&)@APTPKG_5.0" 1.1~exp15
  (c++|optional=std)"void std::vector<pkgCache::VerIterator, std::allocator<pkgCache::VerIterator> >::emplace_back<pkgCache::VerIterator>(pkgCache::VerIterator&&)@APTPKG_5.0" 1.1~exp15
  (c++|optional=std)"SrvRec* std::__move_merge<__gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, SrvRec*, __gnu_cxx::__ops::_Iter_less_iter>(__gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, __gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, __gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, __gnu_cxx::__normal_iterator<SrvRec*, std::vector<SrvRec, std::allocator<SrvRec> > >, SrvRec*, __gnu_cxx::__ops::_Iter_less_iter)@APTPKG_5.0" 1.1~exp15
+ (c++|optional=std)"void std::vector<std::pair<char*, unsigned long>, std::allocator<std::pair<char*, unsigned long> > >::emplace_back<std::pair<char*, unsigned long> >(std::pair<char*, unsigned long>&&)@APTPKG_5.0" 1.1
 ### try to ignore std:: template instances
  (c++|regex|optional=std)"^std::vector<.+ >::(vector|push_back|erase|_[^ ]+)\(.+\)( const|)@APTPKG_5.0$" 0.8.0
  (c++|regex|optional=std)"^(void |)std::[^ ]+<.+ >::(_|~).+\(.*\)@APTPKG_5.0$" 0.8.0
 ### try to ignore std:: template instances
  (c++|regex|optional=std)"^std::vector<.+ >::(vector|push_back|erase|_[^ ]+)\(.+\)( const|)@APTPKG_5.0$" 0.8.0
  (c++|regex|optional=std)"^(void |)std::[^ ]+<.+ >::(_|~).+\(.*\)@APTPKG_5.0$" 0.8.0
@@ -1560,3 +1570,17 @@ libapt-pkg.so.5.0 libapt-pkg5.0 #MINVER#
  (c++|regex|optional=std)"^(void |DiffInfo\* |)std::_.*@APTPKG_5.0$" 0.8.0
  (c++|regex|optional=std)"^__gnu_cxx::__[^ ]+<.*@APTPKG_5.0$" 0.8.0
  (c++|optional=std)"std::ctype<char>::do_widen(char) const@APTPKG_5.0" 1.0.3
  (c++|regex|optional=std)"^(void |DiffInfo\* |)std::_.*@APTPKG_5.0$" 0.8.0
  (c++|regex|optional=std)"^__gnu_cxx::__[^ ]+<.*@APTPKG_5.0$" 0.8.0
  (c++|optional=std)"std::ctype<char>::do_widen(char) const@APTPKG_5.0" 1.0.3
+ (c++)"APT::Configuration::Compressor::Compressor(APT::Configuration::Compressor&&)@APTPKG_5.0" 1.2
+ (c++)"APT::Configuration::Compressor::operator=(APT::Configuration::Compressor&&)@APTPKG_5.0" 1.2
+ (c++)"debStringPackageIndex::~debStringPackageIndex()@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::debStringPackageIndex(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::Exists() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetArchitecture[abi:cxx11]() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetComponent[abi:cxx11]() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetIndexFlags() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::GetType() const@APTPKG_5.0" 1.2.2
+ (c++)"debStringPackageIndex::HasPackages() const@APTPKG_5.0" 1.2.2
+ (c++)"pkgCacheFile::AddIndexFile(pkgIndexFile*)@APTPKG_5.0" 1.2.2
+ (c++)"typeinfo for debStringPackageIndex@APTPKG_5.0" 1.2.2
+ (c++)"typeinfo name for debStringPackageIndex@APTPKG_5.0" 1.2.2
+ (c++)"vtable for debStringPackageIndex@APTPKG_5.0" 1.2.2