-apt (0.7.26~exp10) UNRELEASED; urgency=low
+apt (0.8.0~pre1) UNRELASED; urgency=low
+
+ [ Programs translations ]
+ * Swedish translation update. Closes: #592366
+
+ [ Michael Vogt ]
+ * merge of the debian-expermental-ma branch
+ * refresh po/pot files in doc/ and po/
+ * apt-pkg/pkgcache.cc:
+ - re-evaluate the architectures cache when the cache is (re)opened
+
+ [ Colin Watson ]
+ * apt-pkg/cdrom.cc:
+ - fix off-by-one error in DropBinaryArch
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/fileutl.cc:
+ - Add WriteAtomic mode.
+ - Revert WriteEmpty to old behavior (LP: #613211)
+ * apt-pkg, methods:
+ - Convert users of WriteEmpty to WriteAtomic.
+ * apt-pkg/depcache.cc:
+ - Only try upgrade for Breaks if there is a newer version, otherwise
+ handle it as Conflicts (by removing it) (helps for #591882).
+ * debian/control:
+ - Add dependency on gnupg to apt, apt-key uses it.
+
+ [ David Kalnischkies ]
+ * apt-pkg/algorithms.cc:
+ - let the problem resolver install packages to fix or-groups
+ as a needed remove nuked another or-member (helps for #591882)
+ - change the debug outputs to display also arch of the
+ package and version dependencies information
+ * cmdline/apt-get.cc:
+ - let APT::Get::Arch-Only in build-dep default to false again
+ (Closes: #592628) Thanks Mohamed Amine IL Idrissi for report!
+ - purge packages in 'rc' state, thanks Rogier! (Closes: #150831)
+ * apt-pkg/pkgcache.cc:
+ - fix LongDesc handling in LANG=C environment
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Fri, 13 Aug 2010 16:40:57 +0200
+
+apt (0.7.26~exp12) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * debian/control:
+ - add dependency on zlib-dev for libapt-pkg-dev
+
+ [ David Kalnischkies ]
+ * apt-pkg/cacheset.cc:
+ - [ABI BREAK] add an ErrorType option to CacheSetHelper
+ * cmdline/apt-cache.cc:
+ - use Notice instead of Error in the CacheSetHelper messages
+ for compat reasons. Otherwise tools like sbuild blow up
+ - return success in show if a virtual package was given
+ * debian/control:
+ - remove libcurl3-gnutls-dev alternative as the package is gone
+ - increase needed version of libcurl4-gnutls-dev to >= 7.19.0
+ as we use CURLOPT_{ISSUERCERT,CRLFILE} (Closes: #589642)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 30 Jul 2010 11:55:48 +0200
+
+apt (0.7.26~exp11) experimental; urgency=low
+
+ [ Julian Andres Klode ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - Write architecture information to history file.
+ - Add to history whether a change was automatic or not.
+ * apt-pkg/contrib/fileutl.cc:
+ - Add FileFd::OpenDescriptor() (needed for python-apt's #383617).
+ * cmdline/apt-get.cc:
+ - Support large filesystems by using statvfs64() instead of statvfs()
+ and statfs64() instead of statfs() (Closes: #590513).
+ * apt-pkg/cdrom.cc:
+ - Use link() instead of rename() for creating the CD database backup;
+ otherwise there would be a short time without any database.
+
+ [ David Kalnischkies ]
+ * apt-pkg/depcache.cc:
+ - handle "circular" conflicts for "all" packages correctly
+ * cmdline/apt-cache.cc:
+ - be able to omit dependency types in (r)depends (Closes: #319006)
+ - show in (r)depends the canidate per default instead of newest
+ - share the (r)depends code instead of codecopy
+ * apt-pkg/cacheset.cc:
+ - move them back to the library as they look stable now
+ - add a 'newest' pseudo target release as in pkg/newest
+ * apt-pkg/pkgcache.cc:
+ - prefer non-virtual packages in FindPreferredPkg (Closes: #590041)
+ * test/integration/*:
+ - add with bug#590041 testcase a small test "framework"
+ * apt-pkg/orderlist.cc:
+ - try to install another or-group member in DepRemove before
+ breaking the or group (Closes: #590438)
+ - configure also the replacement before remove by adding Immediate flag
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/error.{cc,h}
+ - docstring cleanup
+ - add inline DumpError() to avoid subtle API break
+
+ -- Michael Vogt <mvo@debian.org> Thu, 29 Jul 2010 16:40:58 +0200
+
+apt (0.7.26~exp10) experimental; urgency=low
[ David Kalnischkies ]
* apt-pkg/contrib/error.{cc,h}:
Thanks Eric Valette! (Closes: #588610)
* apt-pkg/deb/debmetaindex.cc:
- do not query each architecture for flat file archives
+ - fix typo preventing display of architecture in Info()
+ * methods/bzip2.cc:
+ - add a copycat of the old gzip.cc as we need it for bzip2 and lzma
[ Martin Pitt ]
* debian/rules:
Rewrite it to use FileFd directly, which makes the code a lot simpler, and
also using less memory and overhead.
- -- David Kalnischkies <kalnischkies@gmail.com> Sat, 10 Jul 2010 13:44:32 +0200
+ -- Michael Vogt <mvo@debian.org> Mon, 12 Jul 2010 11:41:01 +0200
apt (0.7.26~exp9) experimental; urgency=low
[ Christian Perrier ]
* Slovak translation update. Closes: #581159
* Italian translation update. Closes: #581742
+ * Swedish translation update. Closes: #592366
-- Michael Vogt <mvo@debian.org> Tue, 25 May 2010 16:01:42 +0200