]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/orderlist.cc:
[apt.git] / debian / changelog
index b506fa43380b6b7ba8e5c12ced1ea962fa9cc9be..49f8bce4659ce03d4065fc8370b7750b6fb806ff 100644 (file)
@@ -1,4 +1,40 @@
-apt (0.7.26~exp10) UNRELEASED; urgency=low
+apt (0.7.26~exp11) experimental; urgency=low
+
+  [ Julian Andres Klode ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - Write architecture information to history file.
+    - Add to history whether a change was automatic or not.
+  * apt-pkg/contrib/fileutl.cc:
+    - Add FileFd::OpenDescriptor() (needed for python-apt's #383617).
+  * cmdline/apt-get.cc:
+    - Support large filesystems by using statvfs64() instead of statvfs()
+      and statfs64() instead of statfs() (Closes: #590513).
+  * apt-pkg/cdrom.cc:
+    - Use link() instead of rename() for creating the CD database backup;
+      otherwise there would be a short time without any database.
+
+  [ David Kalnischkies ]
+  * apt-pkg/depcache.cc:
+    - handle "circular" conflicts for "all" packages correctly
+  * cmdline/apt-cache.cc:
+    - be able to omit dependency types in (r)depends (Closes: #319006)
+    - show in (r)depends the canidate per default instead of newest
+    - share the (r)depends code instead of codecopy
+  * apt-pkg/cacheset.cc:
+    - move them back to the library as they look stable now
+    - add a 'newest' pseudo target release as in pkg/newest
+  * apt-pkg/pkgcache.cc:
+    - prefer non-virtual packages in FindPreferredPkg (Closes: #590041)
+  * test/integration/*:
+    - add with bug#590041 testcase a small test "framework"
+  * apt-pkg/orderlist.cc:
+    - try to install another or-group member in DepRemove before
+      breaking the or group (Closes: #590438)
+    - configure also the replacement before remove by adding Immediate flag
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Mon, 26 Jul 2010 12:40:44 +0200
+
+apt (0.7.26~exp10) experimental; urgency=low
 
   [ David Kalnischkies ]
   * apt-pkg/contrib/error.{cc,h}:
@@ -6,6 +42,9 @@ apt (0.7.26~exp10) UNRELEASED; urgency=low
       Thanks Eric Valette! (Closes: #588610)
   * apt-pkg/deb/debmetaindex.cc:
     - do not query each architecture for flat file archives
+    - fix typo preventing display of architecture in Info()
+  * methods/bzip2.cc:
+    - add a copycat of the old gzip.cc as we need it for bzip2 and lzma
 
   [ Martin Pitt ]
   * debian/rules:
@@ -42,7 +81,7 @@ apt (0.7.26~exp10) UNRELEASED; urgency=low
     Rewrite it to use FileFd directly, which makes the code a lot simpler, and
     also using less memory and overhead.
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Sat, 10 Jul 2010 13:44:32 +0200
+ -- Michael Vogt <mvo@debian.org>  Mon, 12 Jul 2010 11:41:01 +0200
 
 apt (0.7.26~exp9) experimental; urgency=low