-apt (0.6.46.4) unstable; urgency=low
+apt (0.7.7) UNRELEASED; urgency=low
+ * apt-inst/contrib/extracttar.cc:
+ - fix fd leak for zero size files (thanks to Bill Broadley for
+ reporting this bug)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 02 Aug 2007 11:55:54 +0200
+
+apt (0.7.6) unstable; urgency=low
+
+ * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
+ directory downloading on non-linux architectures (closes: #435597)
+
+ -- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
+
+apt (0.7.5) unstable; urgency=low
+
+ [ Otavio Salvador ]
+ * Applied patch from Guillem Jover <guillem@debian.org> to use
+ dpkg-architecture to get the host architecture (closes: #407187)
+ * Applied patch from Guillem Jover <guillem@debian.org> to add
+ support to add lzma support (closes: #408201)
+
+ [ Michael Vogt ]
+ * apt-pkg/depcache.cc:
+ - support a list of sections for:
+ APT::Install-Recommends-Sections
+ APT::Never-MarkAuto-Sections
+ * methods/makefile:
+ - install lzma symlink method (for full lzma support)
+ * debian/control:
+ - suggest "lzma"
+
+ -- Otavio Salvador <otavio@ossystems.com.br> Wed, 25 Jul 2007 20:16:46 -0300
+
+apt (0.7.4) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * cmdline/apt-get.cc:
+ - fix in the task-install code regexp (thanks to Adam Conrad and
+ Colin Watson)
+ - support task removal too: apt-get remove taskname^
+ (thanks to Matt Zimmerman reporting this problem)
+
+ [ Otavio Salvador ]
+ * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
+ * Fix compilation warnings:
+ - apt-pkg/contrib/configuration.cc: wrong argument type;
+ - apt-pkg/deb/dpkgpm.cc: wrong signess;
+ - apt-pkg-acquire-item.cc: wrong signess and orderned initializers;
+ - methods/https.cc:
+ - type conversion;
+ - unused variable;
+ - changed SetupProxy() method to void;
+ * Simplified HttpMethod::Fetch on http.cc removing Tail variable;
+ * Fix pipeline handling on http.cc (closes: #413324)
+ * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+ <schepler@math.unipd.it> by the patch (closes: #359634)
+ * Fix example for Install-{Recommends,Suggests} options on
+ configure-index example file. Thanks to Peter Eisentraut
+ <peter_e@gmx.net> by the patch (closes: #432223)
+
+ [ Christian Perrier ]
+ * Basque translation update. Closes: ##423766
+ * Unfuzzy formerly complete translations
+ * French translation update
+ * Re-generate PO(T) files
+ * Spanish translation update
+ * Swedish translation update
+
+ -- Otavio Salvador <otavio@debian.org> Tue, 24 Jul 2007 09:55:50 -0300
+
+apt (0.7.3) unstable; urgency=low
+
+ * fixed compile errors with g++ 4.3 (thanks to
+ Daniel Burrows, closes: #429378)
+ * fixes in the auto-mark code (thanks to Daniel
+ Burrows)
+ * fix FTFBFS by changing build-depends to
+ libcurl4-gnutls-dev (closes: #428363)
+ * cmdline/apt-get.cc:
+ - fix InstallTask code when a pkgRecord ends
+ with a single '\n' (thanks to Soren Hansen for reporting)
+ * merged from Christian Perrier:
+ * vi.po: completed to 532t, again. Closes: #429899
+ * gl.po: completed to 532t. Closes: #429506
+ * vi.po: completed to 532t. Closes: #428672
+ * Update all PO and the POT. Gives 514t14f4u for formerly
+ complete translations
+ * fr.po: completed to 532t
+ * ku.po, uk.po, LINGUAS: reintegrate those translations
+ which disappeared from the BZR repositories
+
+ -- Michael Vogt <mvo@debian.org> Sun, 01 Jul 2007 12:31:29 +0200
+
+apt (0.7.2-0.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Build-depend on libcurl4-gnutls-dev instead of the obsolete
+ libcurl3-gnutls-dev. Closes: #428363.
+
+ -- Steve Langasek <vorlon@debian.org> Thu, 28 Jun 2007 18:46:53 -0700
+
+apt (0.7.2) unstable; urgency=low
+
+ * merged the debian/experimental changes back
+ into the debian/sid branch
+ * merged from Christian Perrier:
+ * mr.po: New Marathi translation Closes: #416806
+ * zh_CN.po: Updated by Eric Pareja Closes: #416822
+ * tl.po: Updated by Eric Pareja Closes: #416638
+ * gl.po: Updated by Jacobo Tarrio
+ Closes: #412828
+ * da.po: Updated by Claus Hindsgaul
+ Closes: #409483
+ * fr.po: Remove a non-breakable space for usability
+ issues. Closes: #408877
+ * ru.po: Updated Russian translation. Closes: #405476
+ * *.po: Unfuzzy after upstream typo corrections
+ * buildlib/archtable:
+ - added support for sh3/sh4 (closes: #424870)
+ - added support for m32r (closes: #394096)
+ * buildlib/systemtable:
+ - added support for lpia
+ * configure.in:
+ - check systemtable for architecture mapping too
+ * fix error in AutocleanInterval, closes: #319339
+ (thanks to Israel G. Lugo for the patch)
+ * add "purge" commandline argument, closes: #133421)
+ (thanks to Julien Danjou for the patch)
+ * add "purge" commandline argument, closes: #133421)
+ (thanks to Julien Danjou for the patch)
+ * fix FTBFS with gcc 4.3, closes: #417090
+ (thanks to Martin Michlmayr for the patch)
+ * add --dsc-only option, thanks to K. Richard Pixley
+ * Removed the more leftover #pragma interface/implementation
+ closes: #306937 (thanks to Andreas Henriksson for the patch)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 06 Jun 2007 23:19:50 +0200
+
+apt (0.7.1) experimental; urgency=low
+
+ * ABI library name change because its build against
+ new glibc
+ * implement SourceVer() in pkgRecords
+ (thanks to Daniel Burrows for the patch!)
+ * apt-pkg/algorithm.cc:
+ - use clog for all debugging
+ - only increase the score of installed applications if they
+ are not obsolete
+ - fix resolver bug on removal triggered by weak-dependencies
+ with or-groups
+ * methods/http.cc:
+ - send apt version in User-Agent
+ * apt-pkg/deb/debrecords.cc:
+ - fix SHA1Hash() return value
+ * apt-pkg/cdrom.cc:
+ - only unmount if APT::CDROM::NoMount is false
+ * methods/cdrom.cc:
+ - only umount if it was mounted by the method before
+ * po/gl.po:
+ - fix error translation that causes trouble to lsb_release
+ * apt-pkg/acquire-item.cc:
+ - if decompression of a index fails, delete the index
+ * apt-pkg/acquire.{cc,h}:
+ - deal better with duplicated sources.list entries (avoid
+ double queuing of URLs) - this fixes hangs in bzip/gzip
+ * merged from Christian Perrier:
+ * mr.po: New Marathi translation Closes: #416806
+ * zh_CN.po: Updated by Eric Pareja Closes: #416822
+ * tl.po: Updated by Eric Pareja Closes: #416638
+ * gl.po: Updated by Jacobo Tarrio
+ Closes: #412828
+ * da.po: Updated by Claus Hindsgaul
+ Closes: #409483
+ * fr.po: Remove a non-breakable space for usability
+ issues. Closes: #408877
+ * ru.po: Updated Russian translation. Closes: #405476
+ * *.po: Unfuzzy after upstream typo corrections
+ * vi.po: Updated to 515t. Closes: #426976
+ * eu.po: Updated to 515t. Closes: #423766
+ * pt.po: 515t. Closes: #423111
+ * fr.po: Updated by Christian Perrier
+ * Update all PO and the POT. Gives 513t2f for formerly
+ complete translations
+ * apt-pkg/policy.cc:
+ - allow multiple packages (thanks to David Foerster)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 2 May 2007 13:43:44 +0200
+
+apt (0.7.0) experimental; urgency=low
+
+ * Package that contains tall the new features
+ * Removed all #pragma interface/implementation
+ * Branch that contains tall the new features:
+ * translated package descriptions
+ * task install support
+ * automatic dependency removal (thanks to Daniel Burrows)
+ * merged support for the new dpkg "Breaks" field
+ (thanks to Ian Jackson)
+ * handle network failures more gracefully on "update"
+ * support for unattended-upgrades (via unattended-upgrades
+ package)
+ * added apt-transport-https method
+
+ -- Michael Vogt <mvo@debian.org> Fri, 12 Jan 2007 20:48:07 +0100
+
+apt (0.6.46.4-0.1) unstable; urgency=emergency
+
+ * NMU
+ * Fix broken use of awk in apt-key that caused removal of the wrong keys
+ from the keyring. Closes: #412572
+
+ -- Joey Hess <joeyh@debian.org> Mon, 26 Feb 2007 16:00:22 -0500
+
+apt (0.6.46.4) unstable; urgency=high
+
+ * ack NMU (closes: #401017)
* added apt-secure.8 to "See also" section
* apt-pkg/deb/dpkgpm.cc:
- added "Dpkg::StopOnError" variable that controls if apt
- uk.po: New Ukrainian translation: 483t28f3u
- el.po: Update to 503t9f2u
- de.po: Updates and corrections.
+ * apt-pkg/contrib/progress.cc:
+ - OpProgress::CheckChange optimized, thanks to Paul Brook
+ (closes: #398381)
+ * apt-pkg/contrib/sha256.cc:
+ - fix building with noopt
- --
+ -- Michael Vogt <mvo@debian.org> Thu, 7 Dec 2006 10:49:50 +0100
+
+apt (0.6.46.3-0.2) unstable; urgency=high
+
+ * Non-maintainer upload with permission of Michael Vogt.
+ * Fix FTBFS on most arches (regression from the fix of #400874)
+
+ -- Andreas Barth <aba@not.so.argh.org> Tue, 5 Dec 2006 15:51:22 +0000
+
+apt (0.6.46.3-0.1) unstable; urgency=high
+
+ * Non-maintainer upload with permission of Michael Vogt.
+ * Fix segfault at apt-get source. Closes: #400874
+ * Add apt-key update in postinst, so that debian-archive-keyring doesn't
+ need to depend on apt >= 0.6. Closes: #401114
+ * Don't double-queue pdiff files. Closes: #401017
+
+ -- Andreas Barth <aba@not.so.argh.org> Tue, 5 Dec 2006 10:34:56 +0000
apt (0.6.46.3) unstable; urgency=low
messages
* Merged from Christian Perrier bzr branch:
- - ca.po: Updated to 514t
- - be.po: Updated to 514t
- - it.po: Updated to 514t
- - hu.po: Updated to 514t
- - zh_TW.po: Updated to 514t
- - ar.po: Updated to 293t221u.
- - ru.po: Updated to 514t. Closes: #392466
- - nb.po: Updated to 514t. Closes: #392466
- - pt.po: Updated to 514t. Closes: #393199
- - fr.po: One spelling error corrected: s/accèder/accéder
- - km.po: Updated to 514t.
- - ko.po: Updated to 514t.
- - bg.po: Updated to 514t.
- - de.po: Updated to 514t.
- - en_GB.po: Updated to 514t.
-
- -- Michael Vogt <mvo@debian.org> Thu, 2 Nov 2006 11:37:58 +0100
+ - ca.po: Updated to 514t
+ - be.po: Updated to 514t
+ - it.po: Updated to 514t
+ - hu.po: Updated to 514t
+ - zh_TW.po: Updated to 514t
+ - ar.po: Updated to 293t221u.
+ - ru.po: Updated to 514t. Closes: #392466
+ - nb.po: Updated to 514t. Closes: #392466
+ - pt.po: Updated to 514t. Closes: #393199
+ - fr.po: One spelling error corrected: s/accèder/accéder
+ - km.po: Updated to 514t.
+ - ko.po: Updated to 514t.
+ - bg.po: Updated to 514t.
+ - de.po: Updated to 514t.
+ - en_GB.po: Updated to 514t.
+
+ -- Michael Vogt <mvo@debian.org> Thu, 2 Nov 2006 11:37:58 +0100
apt (0.6.46.2) unstable; urgency=low
+ * debian/control:
+ - depend on debian-archive-keyring to offer clean upgrade path
+ (closes: #386800)
* Merged from Christian Perrier bzr branch:
- es.po: Updated to 514t. Closes: #391661
- da.po: Updated to 514t. Closes: #391424
- cs.po: Updated. Closes: #391064
- es.po: Updated to 514t. Closes: #391661
- da.po: Updated to 514t. Closes: #391424
-
+
-- Michael Vogt <mvo@debian.org> Wed, 11 Oct 2006 09:03:15 +0200
apt (0.6.46.1) unstable; urgency=low
+ * merged "install-recommends" branch (ABI break):
+ - new "--install-recommends"
+ - install new recommends on "upgrade" if --install-recommends is
+ given
+ - new "--fix-policy" option to install all packages with unmet
+ important dependencies (usefull with --install-recommends to
+ see what not-installed recommends are on the system)
+ - fix of recommended packages display (only show CandidateVersion
+ fix or-group handling)
+ * merged "install-task" branch (use with "apt-get install taskname^")
* methods/gzip.cc:
- deal with empty files
- * Applied patch from Daniel Schepler to make apt bin-NMU able.
+ * Applied patch from Daniel Schepler to make apt bin-NMU able.
(closes: bug#359634)
* rebuild against current g++ because of:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29289
* dz.po: New Dzongkha translation: 512t
* ro.po: Updated to 512t
* eu.po: Updated
+ * eu.po: Updated
+ * fix apt-get dist-upgrade
+ * fix warning if no /var/lib/apt/extended_states is present
+ * don't download Translations for deb-src sources.list lines
+ * apt-pkg/tagfile.cc:
+ - support not-mmapable files again
- -- Michael Vogt <mvo@debian.org> Thu, 27 Jul 2006 00:52:05 +0200
-
-apt (0.6.44.2ubuntu4) edgy; urgency=low
-
- * Make apt-get dselect-upgrade happy again
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 21 Jul 2006 11:03:02 +0200
-
-apt (0.6.44.2ubuntu3) edgy; urgency=low
-
- * Close extended_states file after writing it.
-
- -- Colin Watson <cjwatson@ubuntu.com> Tue, 18 Jul 2006 00:12:13 +0100
+ -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 25 Jul 2006 11:55:22 +0200
-apt (0.6.44.2ubuntu2) edgy; urgency=low
+apt (0.6.44.2exp1) experimental; urgency=low
- * create a empty extended_states file if none exists already
+ * added support for i18n of the package descriptions
+ * added support for aptitude like auto-install tracking (a HUGE
+ HUGE thanks to Daniel Burrows who made this possible)
+ * synced with the http://people.debian.org/~mvo/bzr/apt/debian-sid branch
+ * build from http://people.debian.org/~mvo/bzr/apt/debian-experimental
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 4 Jul 2006 09:23:03 +0200
+ -- Michael Vogt <mvo@debian.org> Mon, 3 Jul 2006 21:50:31 +0200
-apt (0.6.44.2ubuntu1) edgy; urgency=low
+apt (0.6.44.2) unstable; urgency=low
- * merged with debian/unstable
- * merged the "auto-mark" branch to support aptitude like
- marking of automatically installed dependencies and added
- "apt-get remove --auto-remove" to remove unused auto-installed
- packages again
- * changed library version from 3.11 to 3.50 to make it clearly
- different from the debian version (we are ABI incompatible because
- of the auto-mark patch)
+ * apt-pkg/depcache.cc:
+ - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
+ * apt-pkg/acquire-item.cc:
+ - fix missing chmod() in the new aquire code
+ (thanks to Bastian Blank, Closes: #367425)
+ * merged from
+ http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+ * sk.po: Completed to 512t
+ * eu.po: Completed to 512t
+ * fr.po: Completed to 512t
+ * sv.po: Completed to 512t
+ * Update all PO and the POT. Gives 506t6f for formerly
+ complete translations
- -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 3 Jul 2006 18:30:46 +0200
-
-apt (0.6.44.2) unstable; urgency=low
-
- * apt-pkg/depcache.cc:
- - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
- * apt-pkg/acquire-item.cc:
- - fix missing chmod() in the new aquire code
- (thanks to Bastian Blank, Closes: #367425)
- * merged from
- http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
- * sk.po: Completed to 512t
- * eu.po: Completed to 512t
- * fr.po: Completed to 512t
- * sv.po: Completed to 512t
- * Update all PO and the POT. Gives 506t6f for formerly
- complete translations
-
- -- Michael Vogt <mvo@debian.org> Wed, 14 Jun 2006 12:00:57 +0200
+ -- Michael Vogt <mvo@debian.org> Wed, 14 Jun 2006 12:00:57 +0200
apt (0.6.44.1-0.1) unstable; urgency=low
apt (0.6.44.1) unstable; urgency=low
+ * apt-pkg/acquire-item.cc:
+ - fix reversed logic of the "Acquire::PDiffs" option
* merged from
http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
- po/LINGUAS: added "bg" Closes: #360262
- po/gl.po: Galician translation update. Closes: #366849
- po/hu.po: Hungarian translation update. Closes: #365448
- po/cs.po: Czech translation updated. Closes: #367244
+ * apt-pkg/contrib/sha256.cc:
+ - applied patch to fix unaligned access problem. Closes: #367417
+ (thanks to David Mosberger)
-- Michael Vogt <mvo@debian.org> Tue, 16 May 2006 21:51:16 +0200
apt (0.6.44) unstable; urgency=low
* apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
+ * apt-pkg/contrib/sha256.{cc,h},hashes.{cc,h}: support for sha256
+ (thanks to Anthony Towns)
+ * ftparchive/cachedb.{cc,h},writer.{cc,h}: optimizations
+ (thanks to Anthony Towns)
+ * apt pdiff support from experimental merged
+ * apt-pkg/deb/dpkgpm.cc: wording fixes (thanks to Matt Zimmerman)
* apt-pkg/deb/dpkgpm.cc:
- wording fixes (thanks to Matt Zimmerman)
- - fix error in dpkg interaction (closes: #364513,
- thanks to Martin Dickopp)
+ - fix error in dpkg interaction (closes: #364513, thanks to Martin Dickopp)
* apt-pkg/tagfile.{cc,h}:
- use MMap to read the entries (thanks to Zephaniah E. Hull for the
patch) Closes: #350025
-- Michael Vogt <mvo@debian.org> Mon, 8 May 2006 22:28:53 +0200
-apt (0.6.43.3ubuntu3) dapper; urgency=low
-
- * methods/http.cc:
- - fix the user-agent string
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 26 May 2006 18:09:32 +0200
-
-apt (0.6.43.3ubuntu2) dapper; urgency=low
-
- * apt-pkg/deb/dpkgpm.cc: wording fixes (thanks to Matt Zimmerman)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 18 Apr 2006 13:24:40 +0200
-
-apt (0.6.43.3ubuntu1) dapper; urgency=low
-
- * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large in
- the status-fd (ubuntu #28954)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 28 Mar 2006 20:34:46 +0200
-
apt (0.6.43.3) unstable; urgency=low
* Merge bubulle@debian.org--2005/apt--main--0 up to patch-186:
* pl.po: Completed to 512t. Closes: #349514
* sk.po: Completed to 512t. Closes: #349474
* gl.po: Completed to 512 strings Closes: #349407
- * vi.po: Completed to 512 strings
* sv.po: Completed to 512 strings Closes: #349210
* ru.po: Completed to 512 strings Closes: #349154
* da.po: Completed to 512 strings Closes: #349084
* fr.po: Completed to 512 strings
- * LINGUAS: Add Welsh
- * *.po: Updated from sources (512 strings)
* vi.po: Completed to 511 strings Closes: #348968
- * apt-pkg/deb/deblistparser.cc:
- - don't explode on a DepCompareOp in a Provides line, but warn about
- it and ignore it otherwise (thanks to James Troup for reporting it)
- * cmdline/apt-get.cc:
- - don't lock the lists directory in DoInstall, breaks --print-uri
- (thanks to James Troup for reporting it)
- * debian/apt.dirs: create /etc/apt/sources.list.d
- * make apt-cache madison work without deb-src entries (#352583)
- * cmdline/apt-get.cc: only run the list-cleaner if a update was
- successfull
- * apt-get update errors are only warnings nowdays
- * be more careful with the signature file on network failures
-
- -- Michael Vogt <mvo@debian.org> Wed, 22 Feb 2006 10:13:04 +0100
-
-apt (0.6.43.2ubuntu1) dapper; urgency=low
-
- * Merge bubulle@debian.org--2005/apt--main--0 up to patch-182:
- * ca.po: Completed to 512t. Closes: #351592
- * eu.po: Completed to 512t. Closes: #350483
- * ja.po: Completed to 512t. Closes: #349806
- * pl.po: Completed to 512t. Closes: #349514
- * sk.po: Completed to 512t. Closes: #349474
- * gl.po: Completed to 512 strings Closes: #349407
- * vi.po: Completed to 512 strings
- * sv.po: Completed to 512 strings Closes: #349210
- * ru.po: Completed to 512 strings Closes: #349154
- * da.po: Completed to 512 strings Closes: #349084
- * fr.po: Completed to 512 strings
+ * zh_CN.po: Completed to 512t. Closes: #353936
+ * it.po: Completed to 512t. Closes: #352803
+ * pt_BR.po: Completed to 512t. Closes: #352419
* LINGUAS: Add Welsh
* *.po: Updated from sources (512 strings)
- * vi.po: Completed to 511 strings Closes: #348968
* apt-pkg/deb/deblistparser.cc:
- don't explode on a DepCompareOp in a Provides line, but warn about
it and ignore it otherwise (thanks to James Troup for reporting it)
* make apt-cache madison work without deb-src entries (#352583)
* cmdline/apt-get.cc: only run the list-cleaner if a update was
successfull
- * apt-get update errors are only warnings nowdays
- * be more careful with the signature file on network failures
- -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 20 Feb 2006 22:27:48 +0100
+ -- Michael Vogt <mvo@debian.org> Wed, 22 Feb 2006 10:13:04 +0100
apt (0.6.43.2) unstable; urgency=low
-- Michael Vogt <mvo@debian.org> Thu, 19 Jan 2006 00:06:33 +0100
-apt (0.6.43.1ubuntu1) dapper; urgency=low
-
- * Merge bubulle@debian.org--2005/apt--main--0 up to patch-159:
- - en_GB.po, de.po: fix spaces errors in "Ign " translations
- Closes: #347258
- - makefile: make update-po a pre-requisite of clean target so
- that POT and PO files are always up-to-date
- - sv.po: Completed to 511t. Closes: #346450
- - sk.po: Completed to 511t. Closes: #346369
- - fr.po: Completed to 511t
- - *.po: Updated from sources (511 strings)
- * add patch to fix http download corruption problem (thanks to
- Petr Vandrovec, closes: #280844, #290694)
- * added APT::Periodic::Unattended-Upgrade (requires the package
- "unattended-upgrade")
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 10 Jan 2006 17:09:31 +0100
-
apt (0.6.43.1) unstable; urgency=low
-
+
* Merge bubulle@debian.org--2005/apt--main--0 up to patch-148:
* fr.po: Completed to 510 strings
* it.po: Completed to 510t
-- Michael Vogt <mvo@debian.org> Fri, 6 Jan 2006 01:17:08 +0100
-apt (0.6.43ubuntu2) dapper; urgency=low
-
- * merged some missing bits that wheren't merged by baz in the previous
- upload (*grumble*)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 8 Dec 2005 18:35:58 +0100
-
-apt (0.6.43ubuntu1) dapper; urgency=low
-
- * merged with debian
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 25 Nov 2005 11:36:29 +0100
-
apt (0.6.43) unstable; urgency=medium
* Merge bubulle@debian.org--2005/apt--main--0 up to patch-132:
-- Michael Vogt <mvo@debian.org> Tue, 29 Nov 2005 00:17:07 +0100
-apt (0.6.42.3ubuntu2) dapper; urgency=low
-
- * Merge bubulle@debian.org--2005/apt--main--0 up to patch-131:
- * zh_CN.po: Completed to 507 strings(Closes: #338267)
- * gl.po: Completed to 510 strings (Closes: #338356)
- * added support for "/etc/apt/sources.list.d" directory
- (closes: #66325)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 14 Nov 2005 15:30:12 +0100
-
-apt (0.6.42.3ubuntu1) dapper; urgency=low
-
- * synced with debian
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 10 Nov 2005 05:05:56 +0100
-
apt (0.6.42.3) unstable; urgency=low
* Merge bubulle@debian.org--2005/apt--main--0 up to patch-129:
- unmount the cdrom when apt failed to locate any package files
* allow cdrom failures and fallback to other sources in that case
(closes: #44135)
- * better error text when dpkg-source fails
+ * better error text when dpkg-source fails
* Merge bubulle@debian.org--2005/apt--main--0 up to patch-115:
- patch-99: Added Galician translation
- patch-100: Completed Danish translation (Closes: #325686)
- patch-104: French translation completed
- patch-109: Italian translation completed
- - patch-112: Swedish translation update
+ - patch-112: Swedish translation update
- patch-115: Basque translation completed (Closes: #333299)
* applied french man-page update (thanks to Philippe Batailler)
(closes: #316638, #327456)
* apt-pkg/contrib/md5.cc:
- fix a alignment problem on sparc64 that gives random bus errors
(thanks to Fabbione for providing a test-case)
- * init the default ScreenWidth to 79 columns by default
+ * init the default ScreenWidth to 79 columns by default
(Closes: #324921)
- * cmdline/apt-cdrom.cc:
+ * cmdline/apt-cdrom.cc:
- fix some missing gettext() calls (closes: #334539)
* doc/apt-cache.8.xml: fix typo (closes: #334714)
* improved the support for "error" and "conffile" reporting from
dpkg, added the format to README.progress-reporting
* added README.progress-reporting to the apt-doc package
- * improved the network timeout handling, if a index file from a
- sources.list times out or EAI_AGAIN is returned from getaddrinfo,
+ * improved the network timeout handling, if a index file from a
+ sources.list times out or EAI_AGAIN is returned from getaddrinfo,
don't try to get the other files from that entry
* Support architecture-specific extra overrides
(closes: #225947). Thanks to Anthony Towns for idea and
* Javier Fernandez-Sanguino Pen~a:
- Added a first version of an apt-secure.8 manpage, and modified
apt-key and apt.end accordingly. Also added the 'update'
- argument to apt-key which was previously not documented
+ argument to apt-key which was previously not documented
(Closes: #322120)
* Andreas Pakulat:
- - added example apt-ftparchive.conf file to doc/examples
+ - added example apt-ftparchive.conf file to doc/examples
(closes: #322483)
* Fix a incorrect example in the man-page (closes: #282918)
* Fix a bug for very long lines in the apt-cdrom code (closes: #280356)
* Change pkgPolicy::Pin from private to protected to let subclasses
access it too (closes: #321799)
* add default constructor for PrvIterator (closes: #322267)
- * Reread status configuration on debSystem::Initialize()
+ * Reread status configuration on debSystem::Initialize()
(needed for apt-proxy, thanks to Otavio for this patch)
-
- -- Michael Vogt <mvo@debian.org> Mon, 5 Sep 2005 22:59:03 +0200
-apt (0.6.40.1ubuntu8) breezy; urgency=low
-
- * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-62:
- - fix for a bad memory/file leak in the mmap code (ubuntu #15603)
- * po/de.po, po/fr.po:
- - updated the translations
- * po/makefile:
- - create a single pot file in each domain dir to make rosetta happy
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 28 Sep 2005 10:16:06 +0200
-
-apt (0.6.40.1ubuntu7) breezy; urgency=low
-
- * updated the pot/po files , no code changes
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 27 Sep 2005 18:38:16 +0200
-
-apt (0.6.40.1ubuntu6) breezy; urgency=low
-
- * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-56:
- - make it possible for apt to handle a failed MediaChange event and
- fall back to other sources (ubuntu #13713)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 13 Sep 2005 22:09:50 +0200
-
-apt (0.6.40.1ubuntu5) breezy; urgency=low
-
- * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-{50,51}.
- This adds media-change reporting to the apt status-fd (ubuntu #15213)
- * Cherry picked michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-55:
- apt-pkg/cdrom.cc:
- - unmount the cdrom when apt failed to locate any package files
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 12 Sep 2005 15:44:26 +0200
-
-apt (0.6.40.1ubuntu4) breezy; urgency=low
-
- * debian/apt.cron.daily:
- - fix a embarrassing typo
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 7 Sep 2005 10:10:37 +0200
-
-apt (0.6.40.1ubuntu3) breezy; urgency=low
-
- * debian/apt.cron.daily:
- - use the ctime as well when figuring what packages need to
- be removed. This fixes the problem that packages copied with
- "cp -a" (e.g. from the installer) have old mtimes (ubuntu #14504)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 6 Sep 2005 18:30:46 +0200
-
-apt (0.6.40.1ubuntu2) breezy; urgency=low
-
- * improved the support for "error" and "conffile" reporting from
- dpkg, added the format to README.progress-reporting
- * added README.progress-reporting to the apt-doc package
- * Do md5sum checking for file and cdrom method (closes: #319142)
- * Change pkgPolicy::Pin from private to protected to let subclasses
- access it too (closes: #321799)
- * methods/connect.cc:
- - send failure reason for EAI_AGAIN (TmpResolveFailure) to acuire-item
- * apt-pkg/acquire-item.cc:
- - fail early if a FailReason is TmpResolveFailure (avoids hangs during
- the install when no network is available)
- * merged michael.vogt@ubuntu.com--2005/apt--trust-cdrom--0
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 23 Aug 2005 19:44:55 +0200
-
-apt (0.6.40.1ubuntu1) breezy; urgency=low
-
- * Synchronize with Debian
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 5 Aug 2005 14:20:56 +0200
+ -- Michael Vogt <mvo@debian.org> Mon, 5 Sep 2005 22:59:03 +0200
apt (0.6.40.1) unstable; urgency=low
-- Michael Vogt <mvo@debian.org> Fri, 5 Aug 2005 13:24:58 +0200
-apt (0.6.40ubuntu1) breezy; urgency=low
-
- * Synchronize with Debian
-
- -- Matt Zimmerman <mdz@ubuntu.com> Thu, 4 Aug 2005 15:53:22 -0700
-
apt (0.6.40) unstable; urgency=low
* Patch from Jordi Mallach to mark some additional strings for translation
-- Matt Zimmerman <mdz@debian.org> Thu, 28 Jul 2005 11:57:32 -0700
-apt (0.6.39ubuntu4) breezy; urgency=low
-
- * Fix keyring paths in apt-key, apt.postinst (I swear I remember doing this
- before...)
-
- -- Matt Zimmerman <mdz@ubuntu.com> Wed, 29 Jun 2005 08:39:17 -0700
-
-apt (0.6.39ubuntu3) breezy; urgency=low
-
- * Fix keyring locations for Ubuntu in apt-key too.
-
- -- Colin Watson <cjwatson@ubuntu.com> Wed, 29 Jun 2005 14:45:36 +0100
-
-apt (0.6.39ubuntu2) breezy; urgency=low
-
- * Install ubuntu-archive.gpg rather than debian-archive.gpg as
- /etc/apt/trusted.gpg.
-
- -- Colin Watson <cjwatson@ubuntu.com> Wed, 29 Jun 2005 11:53:34 +0100
-
-apt (0.6.39ubuntu1) breezy; urgency=low
-
- * Michael Vogt
- - Change debian/bugscript to use #!/bin/bash (Closes: #313402)
- - Fix a incorrect example in the man-page (closes: #282918)
- - Support architecture-specific extra overrides
- (closes: #225947). Thanks to Anthony Towns for idea and
- the patch, thanks to Colin Watson for testing it.
- - better report network timeouts from the methods to the acuire code,
- only timeout once per sources.list line
-
- -- Matt Zimmerman <mdz@ubuntu.com> Tue, 28 Jun 2005 11:52:24 -0700
-
apt (0.6.39) unstable; urgency=low
* Welsh translation update: daf@muse.19inch.net--2005/apt--main--0--patch-6
* Update priority of apt-utils to important, to match the override file
* Install only one keyring on each branch (Closes: #316119)
- -- Matt Zimmerman <mdz@debian.org> Tue, 28 Jun 2005 11:35:21 -0700
-
-apt (0.6.38ubuntu1) breezy; urgency=low
-
- * First release from Ubuntu branch
- * Merge with --main--0, switch back to Ubuntu keyring
-
- -- Matt Zimmerman <mdz@ubuntu.com> Sat, 25 Jun 2005 16:52:41 -0700
+ -- Matt Zimmerman <mdz@debian.org> Tue, 28 Jun 2005 11:51:09 -0700
apt (0.6.38) unstable; urgency=low
* Initial Release.
-- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
-