+apt (0.7.15~exp3) experimental; urgency=low
+
+ [Daniel Burrows]
+ * apt-pkg/deb/dpkgpm.cc:
+ - Store the trigger state descriptions in a way that does not break
+ the ABI. The approach taken makes the search for a string O(n) rather
+ than O(lg(n)), but since n == 4, I do not consider this a major
+ concern. If it becomes a concern, we can sort the static array and
+ use std::equal_range(). (Closes: #499322)
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.cc, apt-pkg/deb/dpkgpm.cc:
+ - move the state file writting into the Go() implementation
+ of dpkgpm (closes: #498799)
+ * apt-pkg/algorithms.cc:
+ - fix simulation performance drop (thanks to Ferenc Wagner
+ for reporting the issue)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 01 Oct 2008 18:09:49 +0200
+
apt (0.7.15~exp2) experimental; urgency=low
[ Michael Vogt ]