-apt (0.7.15) UNRELEASED; urgency=low
+apt (0.7.17) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * apt-pkg/acquire-item.cc:
+ - Added fallback to uncompressed 'Packages' if neither 'bz2' nor 'gz'
+ available. (Closes: #409284)
+ * apt-pkg/algorithm.cc:
+ - Strip username and password from source URL in error message.
+ (Closes: #425150)
+ * debian/rules:
+ - Fixed lintian warnings "debian/rules ignores make errors".
+ * debian/control:
+ - Substituted outdated "Source-Version" fields with "binary:Version".
+ - Added 'python-apt' to Suggests, as apt-mark need it for work.
+ - Drop Debian revision from 'doc-base' build dependency, this fixes
+ appropriate lintian warning.
+ * debian/libapt-pkg-doc.doc-base.*:
+ - Changed section: from old 'Devel' to 'Debian'. This fixes appropriate
+ lintian warnings.
+ * debian/{postrm,prerm,preinst}:
+ - Added 'set -e', fixes lintian warnings
+ 'maintainer-script-ignores-error'.
+ * dselect/makefile:
+ - Removed unneeded 'LOCAL' entry. This allows cleaning rule to run smoothly.
+ * share/lintian-overrides:
+ - Added with override of 'apt must depend on python'. Script 'apt-mark'
+ needs apt-python for working and checks this on fly. We don't want
+ python in most cases.
+ * cmdline/apt-key:
+ - Added 'unset GREP_OPTIONS' to the script. This prevents 'apt-key update'
+ failure when GREP_OPTIONS contains options that modify grep output.
+ (Closes: #428752)
+ * debian/control:
+ - 'Vcs-Bzr' field is official, used it.
+ - Lowercased short package descriptions.
+ - Bumped 'Standards-Version' to 3.8.0, no changes needed.
+ * cmdline/apt-cache.cc:
+ - Advanced built-in help. Patch by Andre Felipe Machado. (Closes: #286061)
+ * doc/:
+ - Substituded 'apt-archive' with 'apt-ftparchive' in docs.
+ Patch based on work of Andre Felipe Machado. (Closes: #350865)
+ - Mentioned '/<release>' and '=<version>' for 'apt-get install' and
+ '=<version>' for 'apt-get source'. Patch based on work of Andre Felipe
+ Machado. (Closes: #399673)
+ - Mentioned more short options in the apt-get manpage. Documented 'xvcg'
+ option in the apt-cache manpage. The part of patch by Andre Felipe
+ Machado. (Closes: #176106)
+ - Documented that 'apt-get install' command should be used for upgrading
+ some of installed packages. Based on patch by Nori Heikkinen and
+ Andre Felipe Machado. (Closes: #267087)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Fri, 24 Oct 2008 23:45:17 +0300
+
+apt (0.7.16) unstable; urgency=low
+
+ [ Luca Bruno ]
+ * doc/apt-cache.8.xml:
+ - search command uses POSIX regex, and searches for virtual packages too
+ (closes: #277536)
+ * doc/offline.sgml: clarify remote and target hosts
+ (thanks to Nikolaus Schulz, closes: #175940)
+ * Fix several typos in docs, translations and debian/changelog
+ (thanks to timeless, Nicolas Bonifas and Josh Triplett,
+ closes: #368665, #298821, #411532, #431636, #461458)
+ * Document apt-key finger and adv commands
+ (thanks to Stefan Schmidt, closes: #350575)
+ * Better documentation for apt-get --option
+ (thanks to Tomas Pospisek, closes: #386579)
+ * Retitle the apt-mark.8 manpage (thanks to Justin Pryzby, closes: #471276)
+ * Better documentation on using both APT::Default-Release and
+ /etc/apt/preferences (thanks to Ingo Saitz, closes: #145575)
+
+ [ Michael Vogt ]
+ * doc/apt-cache.8.xml:
+ - add missing citerefentry
+
+ -- Michael Vogt <mvo@debian.org> Fri, 10 Oct 2008 23:44:50 +0200
+
+apt (0.7.15) unstable; urgency=low
+
+ * Upload to unstable
+
+ -- Michael Vogt <mvo@debian.org> Sun, 05 Oct 2008 13:23:47 +0200
+
+apt (0.7.15~exp3) experimental; urgency=low
+
+ [Daniel Burrows]
+ * apt-pkg/deb/dpkgpm.cc:
+ - Store the trigger state descriptions in a way that does not break
+ the ABI. The approach taken makes the search for a string O(n) rather
+ than O(lg(n)), but since n == 4, I do not consider this a major
+ concern. If it becomes a concern, we can sort the static array and
+ use std::equal_range(). (Closes: #499322)
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.cc, apt-pkg/deb/dpkgpm.cc:
+ - move the state file writting into the Go() implementation
+ of dpkgpm (closes: #498799)
+ * apt-pkg/algorithms.cc:
+ - fix simulation performance drop (thanks to Ferenc Wagner
+ for reporting the issue)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 01 Oct 2008 18:09:49 +0200
+
+apt (0.7.15~exp2) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/pkgcachegen.cc:
+ - do not add multiple identical descriptions for the same
+ language (closes: #400768)
+
+ [ Program translations ]
+ * Catalan updated. Closes: #499462
+
+ -- Michael Vogt <mvo@debian.org> Tue, 23 Sep 2008 07:29:59 +0200
+
+apt (0.7.15~exp1) experimental; urgency=low
[ Christian Perrier ]
* Fix typo in cron.daily script. Closes: #486179
[ Program translations ]
- * Romanian updated. Closes: #488361
* Traditional Chinese updated. Closes: #488526
- * German corrected. Closes: #490532
+ * German corrected and completed. Closes: #490532, #480002, #498018
* French completed
* Bulgarian updated. Closes: #492473
* Slovak updated. Closes: #492475
* Greek updated.
* Brazilian Portuguese updated.
* Basque updated. Closes: #496754
- * Romanian updated. Closes: #492773
+ * Romanian updated. Closes: #492773, #488361
+ * Portuguese updated. Closes: #491790
+ * Simplified Chinese updated. Closes: #489344
+ * Norwegian Bokmål updated. Closes: #480022
+ * Czech updated. Closes: #479628, #497277
+ * Korean updated. Closes: #464515
+ * Spanish updated. Closes: #457706
* Lithuanian added. Closes: #493328
+ * Swedish updated. Closes: #497496
+ * Vietnamese updated. Closes: #497893
+ * Portuguese updated. Closes: #498411
+ * Greek updated. Closes: #498687
+ * Polish updated.
[ Michael Vogt ]
* merge patch that enforces stricter https server certificate
* add DPkg::NoTriggers option so that applications that call
apt/aptitude (like the installer) defer trigger processing
(thanks to Joey Hess)
+ * doc/makefile:
+ - add examples/apt-https-method-example.conf
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 25 Jul 2008 20:31:05 +0200
+ -- Michael Vogt <mvo@debian.org> Tue, 16 Sep 2008 21:27:03 +0200
apt (0.7.14) unstable; urgency=low
* Korean updated. Closes: #479426
* Basque updated. Closes: #479452
* Vietnamese updated. Closes: #479748
- * Russian updated. Closes: #479777
+ * Russian updated. Closes: #479777, #499029
* Galician updated. Closes: #479792
* Portuguese updated. Closes: #479847
* Swedish updated. Closes: #479871
Daniel Burrows, closes: #429378)
* fixes in the auto-mark code (thanks to Daniel
Burrows)
- * fix FTFBFS by changing build-depends to
+ * fix FTBFS by changing build-depends to
libcurl4-gnutls-dev (closes: #428363)
* cmdline/apt-get.cc:
- fix InstallTask code when a pkgRecord ends
apt (0.7.1) experimental; urgency=low
- * ABI library name change because its build against
+ * ABI library name change because it's built against
new glibc
* implement SourceVer() in pkgRecords
(thanks to Daniel Burrows for the patch!)
apt (0.7.0) experimental; urgency=low
- * Package that contains tall the new features
+ * Package that contains all the new features
* Removed all #pragma interface/implementation
- * Branch that contains tall the new features:
+ * Branch that contains all the new features:
* translated package descriptions
* task install support
* automatic dependency removal (thanks to Daniel Burrows)