- do not enter an endless loop for (essential) pre-dependency loops
* apt-pkg/contrib/sha2_internal.cc:
- use a pointer-union to peace gcc strict-aliasing warning
-
- -- David Kalnischkies <kalnischkies@gmail.com> Mon, 31 Oct 2011 14:34:48 -0500
+ * apt-pkg/deb/deblistparser.cc:
+ - M-A: foreign packages provide for other archs, too
+ * apt-pkg/cacheset.cc:
+ - make the cachesets real containers which can embedding any container
+ to be able to use the same interface regardless of set or list usage
+ - provide a {Package,Version}List similar to {Package,Version}Set
+ * cmdline/apt-{get,cache,mark}.cc:
+ - use Lists instead of Sets if input order should be preserved for
+ commands accepting lists of packages, e.g. policy (Closes: #625960)
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Fri, 11 Nov 2011 15:55:13 +0100
apt (0.8.16~exp7) experimental; urgency=low