]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
algorithms: Replace qsort() by thread-safe std::sort()
[apt.git] / debian / changelog
index b8954102ef2ab966929fd934c015ae4f22cfafb6..fd82f68c392f5563e375f1dbc7a0312731fd01f2 100644 (file)
@@ -1,3 +1,395 @@
+apt (1.1~exp14) experimental; urgency=medium
+
+  [ Julian Andres Klode ]
+  * Revert "Fix select timeout to be 50msec instead of 0.5msec" for acquire
+  * .travis.yml: Add pinned vivid for gettext and clean up a bit
+  * Allow -i and -u as aliases for installed and upgradable in list
+
+ -- Michael Vogt <mvo@debian.org>  Tue, 20 Oct 2015 18:25:04 +0200
+
+apt (1.1~exp13) experimental; urgency=medium
+
+  [ Michael Vogt ]
+  * Use xgettext --no-location in make update-pot
+  * Fix select timeout to be 50msec instead of 0.5msec (Closes: #799857)
+
+  [ David Kalnischkies ]
+  * M-A: allowed pkgs of unconfigured archs do not statisfy :any
+  * implement dpkgs vision of interpreting pkg:<arch> dependencies
+  * add Source-Version field for EDSP
+  * fix insecure use of /tmp in EDSP solver 'dump' (Closes: 795600)
+  * select kernels to protect from autoremove based on Debian version
+    (Closes: 787827)
+  * implement autobit and pinning in EDSP solver 'apt'
+  * do not discard new manual-bits while applying EDSP solutions
+  * include debug information in the autoremove-kernels file
+  * avoid using global PendingError to avoid failing too often too soon
+  * implement apt-get source msg 'Please use: $vcs' for git
+  * do not ignore differently versioned self-provides
+  * do not generate bogus hashes if hash is disabled in apt-ftparchive
+  * use APT::FTPArchive hash settings as default for APT::FPArchive::$filetype
+  * add --sha512 option + documentation for apt-ftparchive
+  * deal with spaces in path, command and filepaths in apt-key
+  * add by-hash sources.list option and document all of by-hash
+  * fallback to well-known URI if by-hash fails (Closes: 798919)
+
+ -- Michael Vogt <mvo@debian.org>  Mon, 05 Oct 2015 18:27:22 +0200
+
+apt (1.1~exp12) experimental; urgency=medium
+
+  [ David Kalnischkies ]
+  * sources.list and indextargets option for pdiffs
+  * auto-prefix $(SITE) for indextargets Description field
+  * implement PDiff patching for compressed files
+  * implement indextargets option 'DefaultEnabled'
+  * try xz instead of bz2 first for compressed files
+  * implement $(NATIVE_ARCHITECTURE) substvar for indextargets
+  * detect and deal with indextarget duplicates
+  * ignore for _apt inaccessible TMPDIR in pkgAcqChangelog (Closes: 797270)
+  * if file is inaccessible for _apt, disable privilege drop in acquire
+  * remove Christian Perrier from Uploaders as requested.
+    Thanks to Christian for all the l10n, code & social contributions!
+    (Closes: #783337)
+  * use unusable-for-security hashes for integrity checks
+  * use clock() as source for SRV randomness
+
+  [ Miroslav Kure ]
+  * Czech program translation update (Closes: 797329)
+
+  [ Michael Vogt ]
+  * Consider md5sum no longer a usable hash
+  * Add support for writing by-hash dirs in apt-ftparchive
+
+  [ Julian Andres Klode ]
+  * apt-pkg/tagfile.h: Include stdint.h, fixes rdep build failures
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 11 Sep 2015 23:31:34 +0200
+
+apt (1.1~exp11) experimental; urgency=medium
+
+  [ Julian Andres Klode ]
+  * pkgcachegen: Account for remapping when parsing depends from NewPackage.
+    Thanks to Jakub Wilk for the bug report and the backtraces (Closes: #796999)
+  * debian/rules: Only do parallel build if specified in DEB_BUILD_OPTIONS.
+    Thanks to Jakub Wilk for the suggestion
+  * cacheset: Prefer the depcache over the policy again
+  * install: Set a local deb as the candidate for that package
+  * Always close compressed files in FileFd
+  * Use compressor support from FileFd for ExtractTar instead of programs
+  * Do not parse Status fields from remote sources
+
+  [ David Kalnischkies ]
+  * just-in-time removal of broken essential packages (Closes: 796070)
+  * correct 'apt update' download summary line
+  * ignore AllowMem parameter in cache generation (Closes: 796459)
+  * add a libapt-pkg recommends apt
+  * fix various typos reported by codespell
+  * use always priv-dropping for changelog download as root
+  * allow explicit dis/enable of IndexTargets in sources options
+
+  [ Anders Jonsson ]
+  * Swedish program translation update (Closes: 796059)
+
+ -- Julian Andres Klode <jak@debian.org>  Thu, 27 Aug 2015 17:55:12 +0200
+
+apt (1.1~exp10) experimental; urgency=medium
+
+  [ Michael Vogt ]
+  * add support for SRV record lookup before connect
+  * Provide "apt-get full-upgrade" to match "apt full-upgrade"
+  * Add support for "apt-cache showsrc --only-source srcpkgname"
+    Thanks to Steve Slangasek for the suggestion (Closes: 695633)
+
+  [ Julian Andres Klode ]
+  * Support tabs in sources.list files (Closes: #796067)
+  * Re-indent GetCandidateVerNew() and make ConsiderFiles argument explicit
+  * postinst: Correctly pass --home instead of -home, and fixup old user.
+    Thanks to Niels Thykier for reporting this on IRC
+
+ -- Michael Vogt <mvo@debian.org>  Mon, 24 Aug 2015 10:12:15 +0200
+
+apt (1.1~exp9) experimental; urgency=medium
+
+  [ Michael Vogt ]
+  * Add "ca-certificates" recommends to apt-transport-https
+  * test/integration/test-apt-download-progress:
+    - fix test failure on fast hardware
+  * Rename "Size" in ServerState to TotalFileSize
+  * Make apt compile with clang++ again
+  * Cleanup includes (Thanks iwyu)
+
+  [ David Kalnischkies ]
+  * re-enable patchsize limit option for pdiffs
+  * better non-virtual metaIndex.LocalFileName() implementation
+  * mark internal interfaces as hidden
+  * restore ABI of pkgTagSection
+  * streamline display of --help in all tools
+  * allow uninstalled packages to be put on hold
+  * use 'best' hash for source authentication (LP: #1098738)
+  * re-enable support for -s (and co) in apt-get source (Closes: 742578)
+  * create directory for extended_states if needed
+  * create our cache and lib directory always with mode 755
+  * fix file ownership tests to work on kfreebsd
+  * use dpkg --merge-avail only if needed in apt-mark
+  * properly handle already reinstall pkgs in ordering (Closes: 770291)
+  * correct architecture detection for 'rc' packages for purge (Closes: 770898)
+  * derive more of https from http method
+  * properly implement pkgRecord::Parser for *.deb files
+  * improve https method queue progress reporting.
+    Thanks to Robert Edmonds and Anders Kaseorg for initial patchs
+    (Closes: 777565, 781509)
+  * calculate only expected hashes in methods
+  * calculate hashes while downloading in https
+  * ensure lists/ files have correct permissions after apt-cdrom add
+  * unsigned Release files can expire, too
+  * a hit on Release files means the indexes will be hits too
+  * remove "first package seen is native package" assumption.
+    Thanks to Axel Beckert for testing (Closes: 782777)
+  * improve partial/ cleanup in abort and failure cases
+  * a pin of 1000 always means downgrade allowed
+  * remove unused and strange default-value for pins
+  * show non-matching m-a:same versions in debug message
+  * fix 'Source' to 'Package' rename in apt-ftparchive
+  * sync TFRewrite*Order arrays with dpkg and dak
+  * stop depending on copy-on-write for std::string
+  * implement a more c++-style TFRewrite alternative
+  * rewrite all TFRewrite instances to use the new pkgTagSection::Write
+  * detect 416 complete file in partial by expected hash
+  * implement VerifyFile as all-hashes check
+  * detect Releasefile IMS hits even if the server doesn't
+  * treat older Release files than we already have as an IMSHit
+  * don't try other compressions on hashsum mismatch
+  * rework hashsum verification in the acquire system
+  * check patch hashes in rred worker instead of in the handler
+  * add more parsing error checking for rred
+  * support hashes for compressed pdiff files
+  * do not request files if we expect an IMS hit
+  * configurable acquire targets to download additional files
+  * show URI.Path in all acquire item descriptions
+  * implement 'apt-get files' to access index targets
+  * store Release files data in the Cache
+  * implement default apt-get file --release-info mode (Closes: 752702)
+  * populate the Architecture field for PackageFiles (Closes: 687255)
+  * hide Translation-* in 'apt-cache policy' output
+  * provide a public interface for acquiring changelogs
+    (Closes: 687147, 739854, 784027, 787190)
+  * ensure valid or remove destination file in file method
+  * deal better with acquiring the same URI multiple times
+  * call URIStart in cdrom and file method
+  * show item ID in Hit, Ign and Err lines as well
+  * condense parallel requests with the same hashes to one
+  * support lang= and target= sources.list options
+  * bring back deb822 sources.list entries as .sources
+  * detect and error out on conflicting Trusted settings
+  * merge indexRecords into metaIndex
+  * add sources.list Check-Valid-Until and Valid-Until-{Max,Min} options
+  * implement Signed-By option for sources.list
+  * remove the longtime deprecated vendor{,list} stuff
+  * allow individual targets to be kept compressed
+  * support gpg 2.1.x in apt-key (Closes: 781042)
+  * merge keyrings with cat instead of gpg in apt-key.
+    Thanks to Daniel Kahn Gillmor for the suggestion
+  * handle site-changing redirects as mirror changes
+  * disable locking even for root in --simulate
+  * rename 'apt-get files' to 'apt-get indextargets'
+  * enforce GCC5 C++11 ABI and usage
+  * show or-groups in not-installed recommends and suggests lists
+  * hide implicit deps in apt-cache again by default
+  * just-in-time creation for (explicit) negative deps
+  * add volatile sources support in libapt-pkg
+  * parse packages from all architectures into the cache
+  * enhance "hit paywall" error message to mention the probable cause
+  * drop extra newline in 'Failed to fetch' and 'GPG error' message
+  * mark again deps of pkgs in APT::Never-MarkAuto-Sections as manual.
+    Thanks to Raphaël Hertzog and Adam Conrad for detailed reports and
+    initial patches (Closes: 793360) (LP: #1479207)
+  * change to libapt-pkg abi 5.0 with versioned symbols
+  * move APT::Never-MarkAuto-Sections handling to MarkDelete
+  * move manual-bit from 'oldlibs' pkg to its dependencies
+  * remove Dir:: scope limit of RootDir in the documentation (Closes: 659387)
+  * add {contrib,non-free}/{metapackages,oldlibs} to section specialhandling
+    (Closes: 788320)
+
+  [ Frans Spiesschaert ]
+  * Dutch program translation update (Closes: 771039)
+
+  [ Julien Patriarca ]
+  * French program translation update (Closes: 766755)
+
+  [ Zhou Mo ]
+  * Chinese (simplified) program translation update (Closes: 766170)
+  * Chinese (simplified) program translation update (Closes: 771982)
+
+  [ Miroslav Kure ]
+  * Czech program translation update (Closes: 764055)
+
+  [ Mert Dirik ]
+  * Turkish program translation update (Closes: 763379)
+  * Turkish translation update for apt (Closes: #789491)
+
+  [ Kenshi Muto ]
+  * Japanese program translation update (Closes: 763033)
+  * Japanese program translation update (Closes: 772678)
+
+  [ James McCoy ]
+  * support long keyids in "apt-key del" instead of ignoring them
+    (Closes: 754436)
+  * tighten filtering of kernel images in apt.auto-removal (Closes: 772732)
+  * Use terminfo's typical save_cursor/restore_cursor sequences
+    (Closes: #772521)
+
+  [ Manuel "Venturi" Porras Peralta ]
+  * Spanish program translation update (Closes: 771815)
+
+  [ Jean-Pierre Giraud ]
+  * French manpages translation update (Closes: 771967)
+
+  [ Theppitak Karoonboonyanan ]
+  * Thai program translation update (Closes: 772913)
+
+  [ Tomasz Buchert ]
+  * Fix crash in the apt-transport-https when Owner is NULL (Closes: #778375)
+
+  [ Helmut Grohne ]
+  * parse arch-qualified Provides correctly (Closes: 777071)
+
+  [ Beatrice Torracca ]
+  * Italian manpage translation update (Closes: 776702)
+
+  [ Jérémy Bobbio ]
+  * stop displaying time of build in online help (Closes: 774342)
+
+  [ Robert Edmonds ]
+  * HttpsMethod::Fetch(): Zero the FetchResult object when leaving due to 404
+
+  [ Milo Casagrande ]
+  * Italian program translation update (Closes: 782122)
+
+  [ Julian Andres Klode ]
+  * pkgPolicy: Introduce storage and helpers for per-version pins
+  * versionmatch: Extract version match checking out of Find()
+  * policy: Assign per-version pins
+  * apt-cache: Change version pin output to use per-version pins
+  * fileutl_test.cc: Check for /etc/passwd instead of /bin/sh
+  * policy: Return highest file pin if version pin == 0 in GetPriority()
+  * Determine the candidate based on per-version pins, instead of old code
+    (Closes: #770017, #622237, #620249, #685215)
+  * policy: Fix the new policy implementation to handle downgrades correctly
+  * Fix test case breakage from the new policy implementation
+  * policy: Fix the handling of config-files states
+  * Replace INT_MIN with std::numeric_limits<int>::min
+  * Simply ignore cruft in the status files, do not treat it as prio 0
+  * Fix an obscure warning from GCC
+  * apt-get: Do not include apt-pkg/indexrecords.h
+  * Drop C++11 elements from headers
+  * Re-introduce None as a deprecated alias for No
+  * Make QItem a subclass of DescItem
+  * ExecFork: Use /proc/self/fd to determine which files to close
+    (Closes: #764204)
+  * Merge changelog entries from sid-gcc5
+  * Bump apt-inst SONAME to 2.0 to adjust for the ABI break in apt-pkg
+  * Annotate more methods with APT_OVERRIDE.
+    Thanks to g++ -Wsuggest-override
+  * debian/gbp.conf: Set multimaint-merge = True
+  * debian/control: Rename libapt-pkg4.15 -> libapt-pkg5.0
+  * apt.cron.daily: Reference 10periodic instead of 02periodic (LP: #1332106)
+  * Makefile: Add a make fast command for development
+  * Add a parameter ConsiderFiles to GetPriority(VerIterator)
+  * apt-cache: Modify policy output to use per-version pins
+  * Only make Upgradable() return true for packages with a candidate
+    (LP: #896689)
+  * apt-cache: Improve translateability of the "with priority" thing
+  * policy: Be more strict about parsing pin files, and document prio 0
+    (Closes: #429912)
+  * apt_preferences(5): Re-document how priorities are calculated
+    (Closes: #554773)
+  * Drop the Section field from pkgCache::Package again
+  * Fix integration tests for the removal of the Package pin output
+  * Remove an invalid fi from a testcase
+  * C++11: Switch from auto_ptr to unique_ptr
+  * Mark SPtr as deprecated, and convert users to std::unique_ptr
+  * Deprecate SPtrArray<T> and convert everyone to unique_ptr<T[]>
+  * Use setresuid() and setresgid() where available
+  * Accept --upgradeable as synonym for --upgradable (Closes: #787846)
+  * po/fr.po: Remove the unbreakable space before ! in the confirm string
+    (Closes: #727680)
+  * Replace --force-yes by various options starting with --allow
+  * Add integration test for Pin-Priority range checks
+  * Replace UINT_MAX with std::numeric_limits<unsigned int>::max()
+  * Mention that source order only matter per version (Closes: #617445)
+  * Say "in combination with the other options" if an option is not understood
+    (Closes: #762758)
+  * apt-cache: Show an error if stats gets any arguments (Closes: #153161)
+  * apt-cache(8): Mention that --names-only search provides (Closes: #618017)
+  * apt_preferences(5): Correct default pin assignment documentation
+    (Closes: #623706)
+  * apt_preferences(5): Mention overlapping of pin matches
+  * Make auto-remove and auto-clean aliases for the versions without -
+    (Closes: #274159)
+  * apt: Add autoremove and auto-remove commands
+  * changelog: Replace spelling reenable by re-enable everywhere.
+    Thanks to Lintian
+  * debian/control: Replace debian by Debian.
+    Thanks to Lintian
+  * debian/control: Drop the versioned python-apt conflict.
+    Thanks to Lintian
+  * debian/control: Remove XS- from Testsuite and bump Standards-Version.
+    Thanks to Lintian
+  * Set Acquire::Changelogs::URI::Origin::Tanglu for Tanglu changelogs
+  * Also add 'in combination with the other options.' to another error
+  * apt-cache(8): Drop the #versions >= #package names comparison
+    (Closes: #691281)
+  * apt-get: allow non-root --print-uris build-dep (Closes: #283400)
+  * doc/files.dbk: Improve documentation for {src,}pkgcache.bin
+    (Closes: #465551)
+  * update: Check if the cache could be opened, don't just assume it
+    (Closes: #756162)
+  * cachefile.cc: Do not ignore return value of pkgDepCache::Init()
+  * Add GetPriority(VerIterator) to pkgDepCache::Policy
+  * Document the general effect of the comma operator (Closes: #574939)
+  * When looking if Provides match, OR them with the normal patches
+    (Closes: #760868)
+  * install: If package already is the newest version, display version
+    (Closes: #315149)
+  * Make pkgCache::Priority() static, it does not need the instance
+    (Closes: #448627)
+  * Replace "extra" in "the following extra packages [...]" by "additional"
+    (Closes: #82430)
+  * Do not crash in 'apt show' for non-installed packages
+  * debian/NEWS: Mention new pinning algorithm added in 2.0~exp1
+
+  [ Yuri Kozlov ]
+  * Russian program translation update (Closes: 789709)
+
+  [ Guillem Jover ]
+  * po-fixups: fill Project-Id-Version and Encoding correctly (Closes: 612996)
+  * Do not set unhonored DPKG_NO_TSTP variable for dpkg (Closes: #765366)
+
+  [ Daniel Hartwig ]
+  * support setting a port for rsh:// in sources.list (Closes: 624727)
+  * replace direct calls to egrep with grep -E.
+    Thanks to David Weinehall for initial patch (Closes: 255577)
+
+  [ Luca Bruno ]
+  * Replace all "press enter" occurrences with "press [Enter]"
+    Thanks to Andre Felipe Machado for initial patch (Closes: 414848)
+
+  [ Jonathan Nieder ]
+  * document VERSION 2 (and 3) pre-install-pkgs hook interface (Closes: 627188)
+
+  [ Tomas Pospisek ]
+  * document APT::Periodic::RandomSleep.
+    Thanks to Chris Bainbridge and Kees Cook for initial text (Closes: 776380)
+
+  [ Johannes Schauer ]
+  * use a=experimental instead n=experimental in pin documentation
+    (Closes: 783343)
+
+  [ Kusanagi Kouichi ]
+  * Show full package records in apt-cache search -f (Closes: #660851)
+
+ -- Michael Vogt <mvo@debian.org>  Tue, 18 Aug 2015 11:15:52 +0200
+
 apt (1.1~exp8) experimental; urgency=medium
 
   [ Michael Vogt ]
@@ -10,7 +402,7 @@ apt (1.1~exp8) experimental; urgency=medium
   * Bump ABI to 4.15
 
   [ David Kalnischkies ]
-  * reenable support for -s (and co) in apt-get source (Closes: 742578)
+  * re-enable support for -s (and co) in apt-get source (Closes: 742578)
   * run acquire transactions only once
   * aborted reverify restores file owner and permission
   * test if TMPDIR is accessible before using (Closes: 765951)
@@ -52,7 +444,7 @@ apt (1.1~exp5) experimental; urgency=medium
   * Document Acquire{MaxReleaseFileSize,AllowInsecureRepositories,
     AllowDowngradeToInsecureRepositories} and
     --no-allow-insecure-repositories
-  * Fix backward compatiblity of the new pkgAcquireMethod::DropPrivsOrDie()
+  * Fix backward compatibility of the new pkgAcquireMethod::DropPrivsOrDie()
   * Change default of Acquire::AllowInsecureRepositories to "true"
     so that this change is less disruptive, this will be switched
     to "false" again after jessie
@@ -189,7 +581,7 @@ apt (1.1~exp1) experimental; urgency=low
   * use 'best' hash for source authentication (LP: 1098738)
   * use HashStringList in the acquire system
   * deal with hashes in ftparchive more dynamic as well
-  * reenable pipelining via hashsum reordering support
+  * re-enable pipelining via hashsum reordering support
   * parse and retrieve multiple Descriptions in one record
   * improve pkgTagSection scanning and parsing
   * invalid cache if architecture set doesn't match (Closes: 745036)
@@ -208,7 +600,7 @@ apt (1.1~exp1) experimental; urgency=low
   * add Debug::Acquire::Progress debug option
   * [ABI-Break] lp:~mvo/apt/source-hashes:
     - use sha{512,256,1} for deb-src when available LP: #1098738
-  * [ABI-Break] stop exporting the accidently exported parsenetrc() symbol
+  * [ABI-Break] stop exporting the accidentally exported parsenetrc() symbol
   * [ABI-Break] remove the PACKAGE_MATCHER_ABI_COMPAT defines
   * [ABI BREAK] apt-pkg/pkgcache.h:
     - adjust pkgCache::State::VerPriority enum, to match reality
@@ -234,6 +626,91 @@ apt (1.1~exp1) experimental; urgency=low
 
  -- Michael Vogt <mvo@debian.org>  Thu, 19 Jun 2014 12:01:48 +0200
 
+apt (1.0.10.1) unstable; urgency=medium
+
+  * hide first pdiff merge failure debug message (Closes: 793444)
+  * mark again deps of pkgs in APT::Never-MarkAuto-Sections as manual.
+    Thanks to Raphaël Hertzog and Adam Conrad for detailed reports and
+    initial patches (Closes: 793360) (LP: #1479207)
+  * explicitly build-dep on g++ (>= 4:5.2) for gcc5 transition
+
+ -- David Kalnischkies <david@kalnischkies.de>  Mon, 03 Aug 2015 07:29:40 +0200
+
+apt (1.0.10) unstable; urgency=medium
+
+  [ Zhou Mo ]
+  * po: update zh_CN translation slightly
+  * po: Update Simplified Chinese programs translation
+
+  [ Mert Dirik ]
+  * Turkish translation update for apt (Closes: #789491)
+
+  [ Yuri Kozlov ]
+  * Russian program translation update (Closes: 789709)
+
+  [ Milo Casagrande ]
+  * Italian program translation update (Closes: 782122)
+
+  [ Beatrice Torracca ]
+  * Italian manpage translation update (Closes: 776702)
+
+  [ Julian Andres Klode ]
+  * ExecFork: Use /proc/self/fd to determine which files to close
+    (Closes: #764204)
+
+  [ Michael Vogt ]
+  * Prepare new 1.0.10 release with gcc5 abi transition
+
+  [ David Kalnischkies ]
+  * stop depending on copy-on-write for std::string
+  * bump next-abi check above gcc5-abi bump
+  * update symbols file to use gcc5 abi mangling
+
+ -- David Kalnischkies <david@kalnischkies.de>  Sat, 25 Jul 2015 12:11:08 +0200
+
+apt (1.0.9.10) unstable; urgency=medium
+
+  [ Michael Vogt ]
+  * Fix crash in pkgDPkgPM::WriteApportReport(() (LP: #1436626)
+  * Move sysconf(_SC_OPEN_MAX); out of the for() loop to avoid unneeded
+    syscalls
+  * Fix endless loop in apt-get update that can cause disk fillup
+    (LP: #1445239)
+
+  [ Helmut Grohne ]
+  * parse arch-qualified Provides correctly (Closes: 777071)
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 22 May 2015 17:38:31 +0200
+
+apt (1.0.9.9) unstable; urgency=medium
+
+  [ David Kalnischkies ]
+  * parse specific-arch dependencies correctly on single-arch systems
+    (Closes: 777760)
+  * remove "first package seen is native package" assumption.
+    Thanks to Axel Beckert for testing (Closes: 782777)
+
+ -- David Kalnischkies <david@kalnischkies.de>  Tue, 28 Apr 2015 16:11:27 +0200
+
+apt (1.0.9.8) unstable; urgency=medium
+
+  [ David Kalnischkies ]
+  * fix another d(e)select-upgrade typo (LP: #1399037)
+  * properly handle expected filesize in https.
+    Thanks to Robert Edmonds and Anders Kaseorg for initial patchs
+    (Closes: 777565, 781509) (LP: #807303)
+  * avoid depends on std::string implementation for pkgAcquire::Item::Mode
+    (Closes: 781858)
+  * demote VectorizeString gcc attribute from const to pure
+  * keyids in "apt-key del" should be case-insensitive (Closes: 781696)
+  * parse specific-arch dependencies correctly on single-arch systems
+    (Closes: 777760)
+
+  [ Michael Vogt ]
+  * fix crash in order writing in pkgDPkgPM::WriteApportReport() (LP: #1436626)
+
+ -- David Kalnischkies <david@kalnischkies.de>  Mon, 13 Apr 2015 07:14:36 +0200
+
 apt (1.0.9.7) unstable; urgency=medium
 
   [ Tomasz Buchert ]
@@ -558,7 +1035,7 @@ apt (1.0.4) unstable; urgency=low
   * Never parse Version/Architecture tags in a Translation-$lang file
   * Show upgradable packages after apt update (Closes: 748389)
   * Fix various errors found by clang -fsanitize=address
-  * Fix various errors foudn by clang scan-build
+  * Fix various errors found by clang scan-build
   * Show unauthenticated warning for source packages as well (Closes: #749795)
   * Add compat mode for old (32bit FileSize) CacheDB (LP: #1274466)
   * cmdline/apt-helper.cc: use less generic description/short-description 
@@ -932,7 +1409,7 @@ apt (0.9.14.3~exp2) experimental; urgency=medium
   * correct IndexDiff vs DiffIndex in Debug output
 
   [ David Kalnischkies ]
-  * reenable unlimited pdiff files download
+  * re-enable unlimited pdiff files download
   * integrate Anthonys rred with POC for client-side merge
 
   [ Michael Vogt ]
@@ -1271,7 +1748,7 @@ apt (0.9.10) unstable; urgency=low
   * add missing Turkish (tr) to po/LINGUAS
   * correct management-typo in description found by lintian
   * implement debian/rules build-{arch,indep} as required by policy 3.9.4
-  * reenable automatic parallel build of APT
+  * re-enable automatic parallel build of APT
   * exclude config.{sub,guess} from source package
   * update the symbol files to reflect current state
   * unset LANGUAGE for showing [Y/n] answer hints
@@ -1383,7 +1860,7 @@ apt (0.9.9) unstable; urgency=low
   * rewrite pkgOrderList::DepRemove to stop incorrect immediate setting
     (Closes: 645713)
   * prefer Essentials over Removals in ordering score
-  * fix priority sorting by prefering higher in MarkInstall
+  * fix priority sorting by preferring higher in MarkInstall
   * try all providers in order if uninstallable in MarkInstall
   * do unpacks before configures in SmartConfigure (Closes: #707578)
   * fix support for multiple patterns in apt-cache search (Closes: #691453)
@@ -1468,17 +1945,17 @@ apt (0.9.8) unstable; urgency=low
     - handle language tags for descriptions are unique strings to be shared
     - factor version string creation out of NewDepends, so we can easily reuse
       version strings e.g. for implicit multi-arch dependencies
-    - equal comparisions are used mostly in same-source relations,
+    - equal comparisons are used mostly in same-source relations,
       so use this to try to reuse some version strings
     - sort group and package names in the hashtable on insert
     - share version strings between same versions (of different architectures)
-      to save some space and allow quick comparisions later on
+      to save some space and allow quick comparisons later on
   * apt-pkg/pkgcache.cc:
     - assume sorted hashtable entries for groups/packages
   * apt-pkg/cacheiterators.h:
     - provide DepIterator::IsSatisfied as a nicer shorthand for DepCheck
   * apt-pkg/deb/debversion.cc:
-    - add a string-equal shortcut for equal version comparisions
+    - add a string-equal shortcut for equal version comparisons
 
   [ Marc Deslauriers ]
   * make apt-ftparchive generate missing deb-src hashes (LP: #1078697)
@@ -1541,7 +2018,7 @@ apt (0.9.7.9~exp2) experimental; urgency=low
     - keep the last good InRelease file around just as we do it with
       Release.gpg in case the new one we download isn't good for us
   * apt-pkg/deb/debmetaindex.cc:
-    - reenable InRelease by default
+    - re-enable InRelease by default
   * ftparchive/writer.cc,
     apt-pkg/deb/debindexfile.cc,
     apt-pkg/deb/deblistparser.cc:
@@ -1918,7 +2395,7 @@ apt (0.9.7) unstable; urgency=low
     - add PackageContainerInterface::FromGroup to support
       architecture specifications with wildcards on the commandline
   * apt-pkg/pkgcache.cc:
-    - do a string comparision for architecture checking in IsMultiArchImplicit
+    - do a string comparison for architecture checking in IsMultiArchImplicit
       as 'unique' strings in the pkgcache aren't unique (Closes: #677454)
   * buildlib/configure.mak:
     - print a message detailing how to get config.guess and config.sub
@@ -2017,7 +2494,7 @@ apt (0.9.5.1) unstable; urgency=low
     - dup() given compressed fd in OpenDescriptor if AutoClose
       is disabled as otherwise gzclose() and co will close it
   * doc/*.xml:
-    - mark even more stuff as untranslateable and improve the
+    - mark even more stuff as untranslatable and improve the
       markup here and there (no real text change)
     - use docbook DTD 4.5 instead of 4.2 to have valid docs
 
@@ -2111,7 +2588,7 @@ apt (0.9.4) unstable; urgency=low
   [ Raphael Geissert ]
   * apt-pkg/acquire*.cc:
     - handle redirections in the worker with the right method instead of
-      in the method the redirection occured in (Closes: #668111)
+      in the method the redirection occurred in (Closes: #668111)
   * methods/http.cc:
     - forbid redirects to change protocol
   * methods/mirror.cc:
@@ -3408,7 +3885,7 @@ apt (0.8.13) unstable; urgency=low
   * mirror method:
     - when downloading data, show the mirror being used
     - randomize mirror list after download in a host specific way
-      to ensure that the load is evenly spreaded accross the mirrors
+      to ensure that the load is evenly spread across the mirrors
     - fix some missing "Fail-Ignore"
 
  -- Michael Vogt <mvo@debian.org>  Wed, 16 Mar 2011 08:04:42 +0100
@@ -4956,7 +5433,7 @@ apt (0.7.24) unstable; urgency=low
     - when tcgetattr() returns non-zero skip all pty magic 
       (thanks to Simon Richter, closes: #509866)
   * apt-inst/contrib/arfile.cc:
-    - show propper error message for Invalid archive members
+    - show proper error message for Invalid archive members
 
   [ David Kalnischkies ]
   * doc/Doxyfile.in:
@@ -5230,7 +5707,7 @@ apt (0.7.22) unstable; urgency=low
   * Apply patch from Sami Liedes <sliedes@cc.hut.fi> to reduce the
     number of times we call progress bar updating and debugging
     configuration settings.
-  * Apply patch from Sami Liedes <sliedes@cc.hut.fi> to avoid unecessary
+  * Apply patch from Sami Liedes <sliedes@cc.hut.fi> to avoid unnecessary
     temporary allocations.
 
  -- Michael Vogt <mvo@debian.org>  Wed, 29 Jul 2009 19:16:22 +0200
@@ -5426,7 +5903,7 @@ apt (0.7.17) unstable; urgency=low
     - Bumped 'Standards-Version' to 3.8.0, no changes needed.
     - Actualized 'Uploaders' field.
   * doc/:
-    - Substituded 'apt-archive' with 'apt-ftparchive' in docs.
+    - Substituted 'apt-archive' with 'apt-ftparchive' in docs.
       Patch based on work of Andre Felipe Machado. (Closes: #350865)
     - Mentioned '/<release>' and '=<version>' for 'apt-get install' and
       '=<version>' for 'apt-get source' in apt-get manpage. Patch based on
@@ -5884,7 +6361,7 @@ apt (0.7.9) unstable; urgency=low
     - Swedish updated.
 
   [ Otavio Salvador ]
-  * Fix configure script to check for CURL library and headers presense.
+  * Fix configure script to check for CURL library and headers presence.
   * Applied patch from Brian M. Carlson <sandals@crustytoothpaste.ath.cx>
     to add backward support for arches that lacks pselect support,
     closes: #448406.
@@ -6196,7 +6673,7 @@ apt (0.7.0) experimental; urgency=low
     - install new recommends on "upgrade" if --install-recommends is 
       given
     - new "--fix-policy" option to install all packages with unmet
-      important dependencies (usefull with --install-recommends to
+      important dependencies (useful with --install-recommends to
       see what not-installed recommends are on the system)
     - fix of recommended packages display (only show CandidateVersion
       fix or-group handling)
@@ -6405,7 +6882,7 @@ apt (0.6.44.2) unstable; urgency=low
   * apt-pkg/depcache.cc:
     - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
   * apt-pkg/acquire-item.cc:
-    - fix missing chmod() in the new aquire code 
+    - fix missing chmod() in the new acquire code
       (thanks to Bastian Blank, Closes: #367425)
   * merged from 
     http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
@@ -6460,13 +6937,13 @@ apt (0.6.44) unstable; urgency=low
   * Merge from http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
        * bg.po: Added, complete to 512t. Closes: #360262
   * doc/apt-ftparchive.1.xml:
-    - fix documentation for "SrcPackages" -> "Sources" 
+    - fix documentation for "SrcPackages" -> "Sources"
       (thanks to Bart Martens for the patch, closes: #307756)
   * debian/libapt-pkg-doc.doc-base.cache:
     - remove broken charackter from description (closes: #361129)
-  * apt-inst/deb/dpkgdb.cc, methods/gpgv.cc: 
+  * apt-inst/deb/dpkgdb.cc, methods/gpgv.cc:
     - i18n fixes (closes: #349298)
-  * debian/postinst: dont fail on not available
+  * debian/postinst: don't fail on not available
     /usr/share/doc/apt/examples/sources.list (closes: #361130)
   * methods/ftp.cc:
     - unlink empty file in partial if the download failed because
@@ -6475,7 +6952,7 @@ apt (0.6.44) unstable; urgency=low
     - treats a version string with explicit zero epoch equal
       than the same without epoch (Policy 5.6.12, closes: #363358)
       Thanks to Lionel Elie Mamane for the patch
-  
+
  -- Michael Vogt <mvo@debian.org>  Mon,  8 May 2006 22:28:53 +0200
 
 apt (0.6.43.3) unstable; urgency=low
@@ -6501,12 +6978,12 @@ apt (0.6.43.3) unstable; urgency=low
     - don't explode on a DepCompareOp in a Provides line, but warn about
       it and ignore it otherwise (thanks to James Troup for reporting it)
   * cmdline/apt-get.cc:
-    - don't lock the lists directory in DoInstall, breaks --print-uri 
+    - don't lock the lists directory in DoInstall, breaks --print-uri
       (thanks to James Troup for reporting it)
-  * debian/apt.dirs: create /etc/apt/sources.list.d 
+  * debian/apt.dirs: create /etc/apt/sources.list.d
   * make apt-cache madison work without deb-src entries (#352583)
-  * cmdline/apt-get.cc: only run the list-cleaner if a update was 
-    successfull
+  * cmdline/apt-get.cc: only run the list-cleaner if a update was
+    successful
 
  -- Michael Vogt <mvo@debian.org>  Wed, 22 Feb 2006 10:13:04 +0100
 
@@ -6613,7 +7090,7 @@ apt (0.6.42.1) unstable; urgency=low
     - revert patch from last version, it causes trouble on alpha 
       and ia64 (closes: #335102, #335103)
   * cmdline/apt-get.cc:
-    - be extra carefull in FindSrc (closes: #335213)
+    - be extra careful in FindSrc (closes: #335213)
 
  -- Michael Vogt <mvo@debian.org>  Sat, 22 Oct 2005 23:44:35 +0200
 
@@ -6813,7 +7290,7 @@ apt (0.6.33) hoary; urgency=low
     - patch-3: (doc) new config variables added configure-index
     - patch-4: pkgAcquire::Run() pulse intervall can be configured
     - patch-5: fix for apt-get update removing Release.gpg files (#6865)
-    - patch-6: change the path scoring in apt-cdrom, prefer pathes without
+    - patch-6: change the path scoring in apt-cdrom, prefer paths without
       symlinks
 
  -- Matt Zimmerman <mdz@ubuntu.com>  Sat, 26 Feb 2005 15:21:17 -0800
@@ -6835,7 +7312,7 @@ apt (0.6.31) hoary; urgency=low
     - Fix build/install of Polish offline documentation, based on patch from
       Christian Perrier (Closes: #270404)
   * Michael Vogt
-    - apt-cdrom.cc seperated into frontend (cmdline/apt-cdrom.cc and library
+    - apt-cdrom.cc separated into frontend (cmdline/apt-cdrom.cc and library
       apt-pkg/cdrom.{cc,h}) (Ubuntu #5668)
 
  -- Matt Zimmerman <mdz@ubuntu.com>  Fri,  4 Feb 2005 10:23:01 -0800
@@ -6870,7 +7347,7 @@ apt (0.6.27ubuntu4) hoary; urgency=low
     (see ubuntu #4769 for the rational)
   * added apt-key update method (uses ubuntu-keyring)
   * documented the "--allow-unauthenticated" switch
-  * added DEB_BUILD_PROG_OPTS to debian/rules (additonal options can be 
+  * added DEB_BUILD_PROG_OPTS to debian/rules (additional options can be
     passed to DEB_BUILD_PROG like "-S")
 
  -- Michael Vogt <mvo@debian.org>  Thu, 23 Dec 2004 11:12:51 +0100
@@ -6884,7 +7361,7 @@ apt (0.6.27ubuntu3) hoary; urgency=low
 
 apt (0.6.27ubuntu2) hoary; urgency=low
 
-  * fixed a bug in the rule file that happend during the big 0.5->0.6 merge
+  * fixed a bug in the rule file that happened during the big 0.5->0.6 merge
 
  -- Michael Vogt <mvo@debian.org>  Tue, 14 Dec 2004 12:14:25 +0100
 
@@ -7887,7 +8364,7 @@ apt (0.5.5) unstable; urgency=low
   * Update es.po.  Closes: #183111.
   * Add pt_BR translation of apt_preferences(5).  Also, build fr manpages.
     Closes: #183904.
-  * Add a vcg command to apt-cache, similiar to dotty.  Closes: #150512.
+  * Add a vcg command to apt-cache, similar to dotty.  Closes: #150512.
   * Add option to apt-get to show versions of packages being
     upgraded/installed.
   * Be quiet in apt.post{inst,rm}.  Closes: #70685.
@@ -7935,7 +8412,7 @@ apt (0.5.4) unstable; urgency=low
   * Whatever. Closes: #89762
   * libstdc++ and HURD. Closes: #92025
   * More apt-utils verbage. Closes: #86954
-  * Fliped comparision operator. Closes: #94618
+  * Fliped comparison operator. Closes: #94618
   * Used the right copyright file. Closes: #65691
   * Randolph's G++3 patches.
   * Fixed no_proxy tokanizing. Closes: #100046
@@ -8104,7 +8581,7 @@ apt (0.3.19) frozen unstable; urgency=low
   * Fixed hardcoded path. Closes: #59743
   * Fixed Jay's relative path bug
   * Allowed source only CDs. Closes: #58952
-  * Space check is supressed if --print-uris is given. Closes: #58965
+  * Space check is suppressed if --print-uris is given. Closes: #58965
   * Clarified the documenation examples for non-us. Closes: #58646
   * Typo in the package description. Closes: #60230
   * Man Page typo. Closes: #60347
@@ -8312,7 +8789,7 @@ apt (0.3.6) unstable; urgency=low
   * apt-get source support. Closes: #23934, #27190
   * Renames .debs that fail MD5 checking, provides automatic corruption
     recovery. Closes: #35931
-  * Fixed autoconf verison. Closes: #37305
+  * Fixed autoconf version. Closes: #37305
   * Random Segfaulting. Closes: #37312, #37530
   * Fixed apt-cache man page. Closes: #36904
   * Added a newline to apt-cache showpkg. Closes: #36903
@@ -8373,10 +8850,10 @@ apt (0.1.9) frozen unstable; urgency=low
   * apt-get dist-upgrade problems fixed
   * tiny patch for http method to fix an endless loop
   * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
-    libtool and add proper shared lib dependancies
+    libtool and add proper shared lib dependencies
   * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
     in case an old libpkg is installed while building APT to prevent
-    spurious dependancies
+    spurious dependencies
 
  -- Ben Gertzfield <che@debian.org>  Thu,  5 Nov 1998 17:43:25 -0800
 
@@ -8406,7 +8883,7 @@ apt (0.1.5) unstable; urgency=low
 apt (0.1.3) unstable; urgency=low
 
   * New upstreamish version.
-  * ftp method rewritten in C. Removes dependancies on all perl/perl
+  * ftp method rewritten in C. Removes dependencies on all perl/perl
     related modules. This fixes many of the ftp method bugs.
 
  -- Ben Gertzfield <che@debian.org>  Thu, 16 Jul 1998 22:19:00 -0700
@@ -8497,7 +8974,7 @@ apt (0.0.12) experimental; urgency=low
 
 apt (0.0.11) experimental; urgency=low
 
-  * Change dependancies to pre-depends since breaking your packaging tools
+  * Change dependencies to pre-depends since breaking your packaging tools
     in the middle of an installation isn't very good.
   * Bug fixes to ftp method and general apt-get code
 
@@ -8570,7 +9047,7 @@ apt (0.0.4) experimental; urgency=low
 
   * New usage guide.
   * Various documentation updates and cleanup.
-  * Added '-f' option to apt-get attempt to fix broken dependancies.
+  * Added '-f' option to apt-get attempt to fix broken dependencies.
 
  -- Scott K. Ellis <scott@debian.org>  Sat,  4 Apr 1998 14:36:00 -0500
 
@@ -8580,7 +9057,7 @@ apt (0.0.3) experimental; urgency=low
   * Updates to how apt-get handles bad states in installed packages.
   * Updated rules to make sure build works from a freshly checked out source
     archive.  Building from CVS needs libtool/automake/autoconf, builds from
-    the distributed source package should have no such dependancy.
+    the distributed source package should have no such dependency.
 
  -- Scott K. Ellis <scott@debian.org>  Fri,  3 Apr 1998 11:49:47 -0500