-apt (0.7.17) UNRELEASED; urgency=low
+apt (0.7.22) UNRELEASED; urgency=low
- [ Osamu Aoki ]
- * Updated cron script to support backups by hardlinks and
- verbose levels. All features turned off by default.
- * Added more error handlings. Closes: #438803, #462734, #454989,
- * Refactored condition structure to make download and upgrade performed
- if only previous steps succeeded. Closes: #341970
- * Documented all cron script related configuration items in
- configure-index.
+ The 'not dead yet' release
+
+ [ Christian Perrier ]
+ * Documentation translations:
+ - Fix a typo in apt-get(8) French translation. Closes: #525043
+ Thanks to Guillaume Delacour for spotting it.
+ - Updated apt.conf(5) manpgae French translation.
+ Thanks to Aurélien Couderc.
+ * Translations:
+ - fr.po
+ - sk.po. Closes: #525857
+ - ru.po. Closes: #526816
+ - eu.po. Closes: #528985
+ - zh_CN.po. Closes: #531390
+ - fr.po
+ - it.po. Closes: #531758
+ - ca.po. Closes: #531921
+ - de.po. Closes: #536430
+ * Added translations
+ - ast.po (Asturian by Marcos Alvareez Costales).
+ Closes: #529007, #529730, #535328
+
+ [ David Kalnischkies ]
+ * [ABI break] support '#' in apt.conf and /etc/apt/preferences
+ (closes: #189866)
+ * [ABI break] Allow pinning by codename (closes: #97564)
+ * support running "--simulate" as user
+ * add depth information to the debug output and show what depends
+ type triggers a autoinst (closes: #458389)
+ * add Debug::pkgDepCache::Marker with more detailed debug output
+ (closes: #87520)
+ * add Debug::pkgProblemResolver::ShowScores and make the scores
+ adjustable
+ * do not write state file in simulate mode (closes: #433007)
+ * add hook for MarkInstall and MarkDelete (closes: #470035)
+ * fix typo in apt-pkg/acquire.cc which prevents Dl-Limit to work
+ correctly when downloading from multiple sites (Closes: #534752)
+ * add the various foldmarkers in apt-pkg & cmdline (no code change)
+ * versions with a pin of -1 shouldn't be a candidate (Closes: #355237)
+ * prefer mmap as memory allocator in MMap instead of a static char
+ array which can (at least in theory) grow dynamic
+ * eliminate (hopefully all) segfaults in pkgcachegen.cc and mmap.cc
+ which can arise if cache doesn't fit into the mmap (Closes: #535218)
+ * display warnings instead of errors if the parts dirs doesn't exist
[ Michael Vogt ]
- * apt-pkg/depcache.cc:
- - when checking for new important deps, skip critical ones
- (LP: #236360)
- * document --install-recommends and --no-install-recommends
- (thanks to Dereck Wonnacott, LP: #126180)
- * make "apt-get build-dep" installed packages marked automatic
- by default. This can be changed by setting the value of
- APT::Get::Build-Dep-Automatic to false (thanks to Aaron
- Haviland, closes: #44874, LP: #248268)
+ * honor the dpkg hold state in new Marker hooks (closes: #64141)
+ * debian/apt.cron.daily:
+ - if the timestamp is too far in the future, delete it
+ * apt-pkg/acquire.cc:
+ - make the max pipeline depth of the acquire queue configurable
+ via Acquire::Max-Pipeline-Depth
+ * apt-pkg/deb/dpkgpm.cc:
+ - add Dpkg::UseIoNice boolean option to run dpkg with ionice -c3
+ (off by default)
+ - send "dpkg-exec" message on the status fd when dpkg is run
+ - provide DPkg::Chroot-Directory config option (useful for testing)
+ - fix potential hang when in a backgroud process group
+ * apt-pkg/algorithms.cc:
+ - consider recommends when making the scores for the problem
+ resolver
+ * apt-pkg/acquire-worker.cc:
+ - show error details of failed methods
+ * apt-pkg/contrib/fileutl.cc:
+ - if a process aborts with signal, show signal number
+ * methods/http.cc:
+ - ignore SIGPIPE, we deal with EPIPE from write in
+ HttpMethod::ServerDie() (LP: #385144)
* apt-pkg/indexcopy.cc:
- support having CDs with no Packages file (just a Packages.gz)
by not forcing a verification on non-existing files
(LP: #255545)
- * cmdline/apt-cache.cc:
- remove the gettext from a string that consists entirely
of variables (LP: #56792)
- - fix "apt-get source pkg=ver" if binary name != source name
- (LP: #202219)
- * doc/makefile:
- - add examples/apt-https-method-example.conf
* apt-pkg/cacheiterators.h:
- add missing checks for Owner == 0 in end()
- * apt-pkg/deb/dpkgpm.cc:
- - fix potential hang when in a backgroud process group
- - fix SIGHUP handling (closes: #463030)
* apt-pkg/indexrecords.cc:
- fix some i18n issues
* apt-pkg/contrib/strutl.h:
- add new strprintf() function to make i18n strings easier
+ - fix compiler warning
+ * apt-pkg/deb/debsystem.cc:
+ - make strings i18n able
+ * fix problematic use of tolower() when calculating the version
+ hash by using locale independant tolower_ascii() function.
+ Thanks to M. Vefa Bicakci (LP: #80248)
+ * build fixes for g++-4.4
+ * cmdline/apt-mark:
+ - add "showauto" option to show automatically installed packages
+ * document --install-recommends and --no-install-recommends
+ (thanks to Dereck Wonnacott, LP: #126180)
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/configuration.cc: Fix a small memory leak in
+ ReadConfigFile.
+ * Introduce support for the Enhances field. (Closes: #137583)
+ * Support /etc/apt/preferences.d, by adding ReadPinDir() (Closes: #535512)
+ * configure-index: document Dir::Etc::SourceParts and some other options
+ (Closes: #459605)
+ * Remove Eugene V. Lyubimkin from uploaders as requested.
+ * apt-pkg/contrib/hashes.cc, apt-pkg/contrib/md5.cc:
+ - Support reading until EOF if Size=0 to match behaviour of
+ SHA1Summation and SHA256Summation
+
+ [ Osamu Aoki ]
+ * Updated cron script to support backups by hardlinks and
+ verbose levels. All features turned off by default.
+ * Added more error handlings. Closes: #438803, #462734, #454989,
+ * Refactored condition structure to make download and upgrade performed
+ if only previous steps succeeded. Closes: #341970
+ * Documented all cron script related configuration items in
+ configure-index.
+
[ Dereck Wonnacott ]
* apt-ftparchive might write corrupt Release files (LP: #46439)
* Apply --important option to apt-cache depends (LP: #16947)
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
+ -- Julian Andres Klode <jak@debian.org> Fri, 03 Jul 2009 08:27:35 +0200
+
+apt (0.7.21) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Translations:
+ - bg.po. Closes: #513211
+ - zh_TW.po. Closes: #513311
+ - nb.po. Closes: #513843
+ - fr.po. Closes: #520430
+ - sv.po. Closes: #518070
+ - sk.po. Closes: #520403
+ - it.po. Closes: #522222
+ - sk.po. Closes: #520403
+
+ [ Jamie Strandboge ]
+ * apt.cron.daily: catch invalid dates due to DST time changes
+ in the stamp files
+
+ [ Michael Vogt ]
+ * methods/gpgv.cc:
+ - properly check for expired and revoked keys (closes: #433091)
+ * apt-pkg/contrib/strutl.cc:
+ - fix TimeToStr i18n (LP: #289807)
+ * [ABI break] merge support for http redirects, thanks to
+ Jeff Licquia and Anthony Towns
+ * [ABI break] use int for the package IDs (thanks to Steve Cotton)
+ * apt-pkg/pkgcache.cc:
+ - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+ state (LP: #322955)
+ * methods/https.cc:
+ - add Acquire::https::AllowRedirect support
+ * Clarify the --help for 'purge' (LP: #243948)
+ * cmdline/apt-get.cc
+ - fix "apt-get source pkg" if there is a binary package and
+ a source package of the same name but from different
+ packages (LP: #330103)
+
+ [ Colin Watson ]
+ * cmdline/acqprogress.cc:
+ - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+ dlstatus messages on the status-fd (LP: #290234).
+
+ -- Michael Vogt <mvo@debian.org> Tue, 14 Apr 2009 14:12:51 +0200
+
+apt (0.7.20.2) unstable; urgency=medium
+
+ [ Eugene V. Lyubimkin ]
+ * Urgency set to medium due to RC bug fix.
+ * doc/apt.ent, apt-get.8.xml:
+ - Fix invalid XML entities. (Closes: #514402)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sat, 07 Feb 2009 16:48:21 +0200
+
+apt (0.7.20.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/pkgcachegen.cc:
+ - fix apt-cache search for localized description
+ (closes: #512110)
+
+ [ Christian Perrier ]
+ * Translations:
+ - fr.po: fix spelling error to "défectueux". Thanks to Thomas Péteul.
+
+ -- Michael Vogt <mvo@debian.org> Tue, 20 Jan 2009 09:35:05 +0100
+
+apt (0.7.20) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * debian/changelog:
+ - Fixed place of 'merged install-recommends and install-task branches'
+ from 0.6.46.1 to 0.7.0. (Closes: #439866)
+ * buildlib/config.{sub,guess}:
+ - Renewed. This fixes lintian errors.
+ * doc/apt.conf.5.xml, debian/apt-transport-https:
+ - Documented briefly 'APT::https' group of options. (Closes: #507398)
+ - Applied patch from Daniel Burrows to document 'Debug' group of options.
+ (Closes: #457265)
+ - Mentioned 'APT::Periodic' and 'APT::Archives' groups of options.
+ (Closes: #438559)
+ - Mentioned '/* ... */' comments. (Closes: #507601)
+ * doc/examples/sources.list:
+ - Removed obsolete commented non-us deb-src entry, replaced it with
+ 'deb-src security.debian.org' one. (Closes: #411298)
+ * apt-pkg/contrib/mmap.cc:
+ - Added instruction how to work around MMap error in MMap error message.
+ (Closes: #385674, 436028)
+ * COPYING:
+ - Actualized. Removed obsolete Qt section, added GPLv2 clause.
+ (Closes: #440049, #509337)
+
+ [ Michael Vogt ]
+ * add option to "apt-get build-dep" to mark the needed
+ build-dep packages as automatic installed.
+ This is controlled via the value of
+ APT::Get::Build-Dep-Automatic and is set "false" by default.
+ Thanks to Aaron Haviland, closes: #448743
+ * apt-inst/contrib/arfile.cc:
+ - support members ending with '/' as well (thanks to Michal Cihr,
+ closes: #500988)
+
+ [ Christian Perrier ]
+ * Translations:
+ - Finnish updated. Closes: #508449
+ - Galician updated. Closes: #509151
+ - Catalan updated. Closes: #509375
+ - Vietnamese updated. Closes: #509422
+ - Traditional Chinese added. Closes: #510664
+ - French corrected (remove awful use of first person)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 05 Jan 2009 08:59:20 +0100
+
+apt (0.7.19) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * doc/sources.list.5.xml:
+ - Mentioned allowed characters in file names in /etc/apt/sources.list.d.
+ Thanks to Matthias Urlichs. (Closes: #426913)
+ * doc/apt-get.8.xml:
+ - Explicitly say that 'dist-upgrade' command may remove packages.
+ - Included '-v'/'--version' as a command to synopsis.
+ * cmdline/apt-cache.cc:
+ - Advanced built-in help. Patch by Andre Felipe Machado. (Closes: #286061)
+ - Fixed typo 'GraphVis' -> 'GraphViz'. (Closes: #349038)
+ - Removed asking to file a release-critical bug against a package if there
+ is a request to install only one package and it is not installable.
+ (Closes: #419521)
+
+ [ Michael Vogt ]
+ - fix SIGHUP handling (closes: #463030)
+
+ [ Christian Perrier ]
+ * Translations:
+ - French updated
+ - Bulgarian updated. Closes: #505476
+ - Slovak updated. Closes: #505483
+ - Swedish updated. Closes: #505491
+ - Japanese updated. Closes: #505495
+ - Korean updated. Closes: #505506
+ - Catalan updated. Closes: #505513
+ - British English updated. Closes: #505539
+ - Italian updated. Closes: #505518, #505683
+ - Polish updated. Closes: #505569
+ - German updated. Closes: #505614
+ - Spanish updated. Closes: #505757
+ - Romanian updated. Closes: #505762
+ - Simplified Chinese updated. Closes: #505727
+ - Portuguese updated. Closes: #505902
+ - Czech updated. Closes: #505909
+ - Norwegian Bokmål updated. Closes: #505934
+ - Brazilian Portuguese updated. Closes: #505949
+ - Basque updated. Closes: #506085
+ - Russian updated. Closes: #506452
+ - Marathi updated.
+ - Ukrainian updated. Closes: #506545
+
+ -- Michael Vogt <mvo@debian.org> Mon, 24 Nov 2008 10:33:54 +0100
+
+apt (0.7.18) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Translations:
+ - French updated
+ - Thai updated. Closes: #505067
+
+ [ Eugene V. Lyubimkin ]
+ * doc/examples/configure-index:
+ - Removed obsoleted header line. (Closes: #417638)
+ - Changed 'linux-kernel' to 'linux-image'.
+ * doc/sources.list.5.xml:
+ - Fixed typo and grammar in 'sources.list.d' section. Thanks to
+ Timothy G Abbott <tabbott@MIT.EDU>. (Closes: #478098)
+ * doc/apt-get.8.xml:
+ - Advanced descriptions for 'remove' and 'purge' options.
+ (Closes: #274283)
+ * debian/rules:
+ - Target 'apt' need to depend on 'build-doc'. Thanks for Peter Green.
+ Fixes FTBFS. (Closes: #504181)
+
+ [ Michael Vogt ]
+ * fix depend on libdb4.4 (closes: #501253)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 07 Nov 2008 22:13:39 +0100
+
+apt (0.7.17) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * debian/control:
+ - 'Vcs-Bzr' field is official, used it.
+ - Bumped 'Standards-Version' to 3.8.0, no changes needed.
+ - Actualized 'Uploaders' field.
+ * doc/:
+ - Substituded 'apt-archive' with 'apt-ftparchive' in docs.
+ Patch based on work of Andre Felipe Machado. (Closes: #350865)
+ - Mentioned '/<release>' and '=<version>' for 'apt-get install' and
+ '=<version>' for 'apt-get source' in apt-get manpage. Patch based on
+ work of Andre Felipe Machado. (Closes: #399673)
+ - Mentioned more short options in the apt-get manpage. Documented 'xvcg'
+ option in the apt-cache manpage. The part of patch by Andre Felipe
+ Machado. (Closes: #176106, #355945)
+ - Documented that 'apt-get install' command should be used for upgrading
+ some of installed packages. Based on patch by Nori Heikkinen and
+ Andre Felipe Machado. (Closes: #267087)
+ - Mentioned 'apt_preferences(5)' in apt manpage. (Closes: #274295)
+ - Documented 'APT::Default-Release' in apt.conf manpage. (Closes: #430399)
+ - APT::Install-Recommends is now true by default, mentioned this in
+ configure-index example. (Closes: #463268)
+ - Added 'APT::Get::AllowUnauthenticated' to configure-index example.
+ (Closes: #320225)
+ - Documented '--no-install-recommends' option in apt-get manpage.
+ (Closes: #462962)
+ - Documented 'Acquire::PDiffs' in apt.conf manpage. (Closes: #376029)
+ - Added 'copy', 'rsh', 'ssh' to the list of recognized URI schemes in
+ sources.list manpage, as they are already described under in the manpage.
+ - Removed notice that ssh/rsh access cannot use password authentication
+ from sources.list manpage. Thanks to Steffen Joeris. (Closes: #434894)
+ - Added '(x)' to some referrings to manpages in apt-get manpage. Patch by
+ Andre Felipe Machado. (Closes: #309893)
+ - Added 'dist-upgrade' apt-get synopsis in apt-get manpage.
+ (Closes: #323866)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 05 Nov 2008 13:14:56 +0100
+
+apt (0.7.17~exp4) experimental; urgency=low
+
+ * debian/rules:
+ - Fixed lintian warnings "debian/rules ignores make errors".
+ * debian/control:
+ - Substituted outdated "Source-Version" fields with "binary:Version".
+ - Added 'python-apt' to Suggests, as apt-mark need it for work.
+ - Drop Debian revision from 'doc-base' build dependency, this fixes
+ appropriate lintian warning.
+ * debian/libapt-pkg-doc.doc-base.*:
+ - Changed section: from old 'Devel' to 'Debian'. This fixes appropriate
+ lintian warnings.
+ * debian/{postrm,prerm,preinst}:
+ - Added 'set -e', fixes lintian warnings
+ 'maintainer-script-ignores-error'.
+ * dselect/makefile:
+ - Removed unneeded 'LOCAL' entry. This allows cleaning rule to run smoothly.
+ * share/lintian-overrides:
+ - Added with override of 'apt must depend on python'. Script 'apt-mark'
+ needs apt-python for working and checks this on fly. We don't want
+ python in most cases.
+ * cmdline/apt-key:
+ - Added 'unset GREP_OPTIONS' to the script. This prevents 'apt-key update'
+ failure when GREP_OPTIONS contains options that modify grep output.
+ (Closes: #428752)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Fri, 31 Oct 2008 23:45:17 +0300
+
+apt (0.7.17~exp3) experimental; urgency=low
+
+ * apt-pkg/acquire-item.cc:
+ - fix a merge mistake that prevents the fallback to the
+ uncompressed 'Packages' to work correctly (closes: #409284)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 29 Oct 2008 09:36:24 +0100
apt (0.7.17~exp2) experimental; urgency=low
* apt-pkg/algorithm.cc:
- Strip username and password from source URL in error message.
(Closes: #425150)
+
+ [ Michael Vogt ]
+ * fix various -Wall warnings
- -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Fri, 24 Oct 2008 23:45:17 +0300
-
+ -- Michael Vogt <mvo@debian.org> Tue, 28 Oct 2008 18:06:38 +0100
apt (0.7.17~exp1) experimental; urgency=low
* support for unattended-upgrades (via unattended-upgrades
package)
* added apt-transport-https method
+ * merged "install-recommends" branch (ABI break):
+ - new "--install-recommends"
+ - install new recommends on "upgrade" if --install-recommends is
+ given
+ - new "--fix-policy" option to install all packages with unmet
+ important dependencies (usefull with --install-recommends to
+ see what not-installed recommends are on the system)
+ - fix of recommended packages display (only show CandidateVersion
+ fix or-group handling)
+ * merged "install-task" branch (use with "apt-get install taskname^")
-- Michael Vogt <mvo@debian.org> Fri, 12 Jan 2007 20:48:07 +0100
apt (0.6.46.1) unstable; urgency=low
- * merged "install-recommends" branch (ABI break):
- - new "--install-recommends"
- - install new recommends on "upgrade" if --install-recommends is
- given
- - new "--fix-policy" option to install all packages with unmet
- important dependencies (usefull with --install-recommends to
- see what not-installed recommends are on the system)
- - fix of recommended packages display (only show CandidateVersion
- fix or-group handling)
- * merged "install-task" branch (use with "apt-get install taskname^")
* methods/gzip.cc:
- deal with empty files
* Applied patch from Daniel Schepler to make apt bin-NMU able.