]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* cmdline/apt-get.cc:
[apt.git] / debian / rules
index 71d6d549ee58c75fc2633b78db14f3aaac7efb37..333d4ad5b802fe935a26e768d2c3b36ccaf7592f 100755 (executable)
@@ -36,7 +36,8 @@ endif
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEBUILD_DPKG_BUILDPACKAGE_OPTS)
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
@@ -171,7 +172,7 @@ apt-doc: build-doc
 #
        # Copy the guides
        dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -213,6 +214,11 @@ apt: build debian/shlibs.local
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
+       # make rosetta happy and remove pot files in po/ (but leave stuff
+       # in po/domains/* untouched) and cp *.po into each domain dir
+       rm -f build/po/*.pot
+       rm -f po/*.pot
+
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ 
        dh_installcron -p$@
@@ -269,6 +275,7 @@ apt-utils: build debian/shlibs.local
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
+       dh_installexamples -p$@
 
        # Install the man pages..
        dh_installman -p$@
@@ -334,6 +341,6 @@ cvs-mkul:
 arch-build:
        rm -rf debian/arch-build
        mkdir -p debian/arch-build/apt-$(APT_DEBVER)
-       baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)