]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* methods/gpgv.cc:
[apt.git] / debian / changelog
index b88df66a92aa535593e1dd1e98f9b6e93b2830fd..e2a0365ac6bfcef75ec41c342e15cf5769b24b31 100644 (file)
@@ -1,9 +1,89 @@
-apt (0.7.17~exp1) UNRELEASED; urgency=low
+apt (0.7.17) UNRELEASED; urgency=low
+
+  [ Osamu Aoki ]
+  * Updated cron script to support backups by hardlinks and 
+    verbose levels.  All features turned off by default. 
+  * Added more error handlings.  Closes: #438803, #462734, #454989, 
+  * Refactored condition structure to make download and upgrade performed 
+    if only previous steps succeeded. Closes: #341970
+  * Documented all cron script related configuration items in 
+    configure-index.
+
+  [ Michael Vogt ]
+  * apt-pkg/depcache.cc:
+    - when checking for new important deps, skip critical ones
+      (LP: #236360)
+  * document --install-recommends and --no-install-recommends
+    (thanks to Dereck Wonnacott, LP: #126180)
+  * make "apt-get build-dep" installed packages marked automatic
+    by default. This can be changed by setting the value of
+    APT::Get::Build-Dep-Automatic to false (thanks to Aaron 
+    Haviland, closes: #44874, LP: #248268)
+  * apt-pkg/indexcopy.cc:
+    - support having CDs with no Packages file (just a Packages.gz)
+      by not forcing a verification on non-existing files
+     (LP: #255545)
+  * cmdline/apt-cache.cc:
+    - remove the gettext from a string that consists entirely 
+      of variables (LP: #56792)
+  * doc/makefile:
+    - add examples/apt-https-method-example.conf
+  * apt-pkg/cacheiterators.h:
+    - add missing checks for Owner == 0 in end()
+  * apt-pkg/deb/dpkgpm.cc:
+    - fix potential hang when in a backgroud process group
+    - fix SIGHUP handling (closes: #463030)
+  * apt-pkg/indexrecords.cc:
+    - fix some i18n issues
+  * apt-pkg/contrib/strutl.h:
+    - add new strprintf() function to make i18n strings easier
+  * methods/gpgv.cc:
+    - fix compiler warning
+  * cmdline/apt-get.cc:
+    - fix "apt-get source pkg=ver" if binary name != source name
+      and show a message (LP: #202219)
+  * apt-pkg/deb/debsystem.cc:
+    - make strings i18n able 
+
+  [ Dereck Wonnacott ]
+  * apt-ftparchive might write corrupt Release files (LP: #46439)
+  * Apply --important option to apt-cache depends (LP: #16947) 
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 12 Sep 2008 11:34:24 +0200
+
+apt (0.7.17~exp2) experimental; urgency=low
+
+  [ Eugene V. Lyubimkin ]
+  * apt-pkg/acquire-item.cc:
+    - Added fallback to uncompressed 'Packages' if neither 'bz2' nor 'gz'
+      available. (Closes: #409284)
+  * apt-pkg/algorithm.cc:
+    - Strip username and password from source URL in error message.
+      (Closes: #425150)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com>  Fri, 24 Oct 2008 23:45:17 +0300
+
+
+apt (0.7.17~exp1) experimental; urgency=low
 
   [ Luca Bruno ]
+  * Fix typos:
+    - apt-pkg/depcache.cc
   * Fix compilation warnings:
     - apt-pkg/acquire.cc
     - apt-pkg/versionmatch.cc
+  * Compilation fixes and portability improvement for compiling APT against non-GNU libc
+    (thanks to Martin Koeppe, closes: #392063):
+    - buildlib/apti18n.h.in:
+      + textdomain() and bindtextdomain() must not be visible when --disable-nls
+    - buildlib/inttypes.h.in: undefine standard int*_t types
+    - Append INTLLIBS to SLIBS:
+      + cmdline/makefile
+      + ftparchive/makefile
+      + methods/makefile
+  * doc/apt.conf.5.xml:
+    - clarify whether configuration items of apt.conf are case-sensitive
+      (thanks to Vincent McIntyre, closes: #345901)
 
  -- Luca Bruno <lethalman88@gmail.com>  Sat, 11 Oct 2008 09:17:46 +0200