]> git.saurik.com Git - apt.git/blobdiff - debian/rules
cleanup the debian/rules file a bit
[apt.git] / debian / rules
index cb46227793a3109f0876bbf7503890c7a82a30d7..ea8f0daa001ca923276ebae84f87d02773f45599 100755 (executable)
@@ -2,17 +2,6 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
-
-# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
-# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
-
-# For the deb builder, you can run 'debian/rules cvs-build', which does all
-# steps nescessary to produce a proper source tarball with the CVS/ removed.
-# It builds in debian/cvs-build/apt-<VER>/, and places files in
-# debian/cvs-build/.  Optionally, you can run 'debian/rules cvs-mkul' to
-# create ../upload-<VER>, with all the files needed to be uploaded placed
-# in it.
 
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -27,10 +16,14 @@ endif
 # See below
 -include build/environment.mak
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+  export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
 else
-  export CXXFLAGS = -O2 -g -Wall
+  ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    export CXXFLAGS = -O0 -g -Wall
+  else
+    export CXXFLAGS = -O2 -g -Wall
+  endif
 endif
 
 # Default rule
@@ -108,7 +101,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+       cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -135,7 +128,7 @@ binary-indep: apt-doc libapt-pkg-doc
 libapt-pkg-doc: build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 #
 # libapt-pkg-doc install
@@ -161,7 +154,7 @@ libapt-pkg-doc: build-doc debian/shlibs.local
 apt-doc: build-doc
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
 #
 # apt-doc install
 #
@@ -187,7 +180,7 @@ apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secur
 apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 #
 # apt install
@@ -221,6 +214,10 @@ apt: build build-doc debian/shlibs.local
        rm -f build/po/*.pot
        rm -f po/*.pot
 
+       # move the mirror failure script in place
+       #mv debian/$@/usr/bin/apt-report-mirror-failure \
+       #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
@@ -231,7 +228,7 @@ apt: build build-doc debian/shlibs.local
        dh_fixperms -p$@
        dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -239,7 +236,7 @@ apt: build build-doc debian/shlibs.local
 libapt-pkg-dev: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 #
 # libapt-pkg-dev install
@@ -264,7 +261,7 @@ apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 
        # install the shared libs
@@ -284,7 +281,7 @@ apt-utils: build debian/shlibs.local
        dh_fixperms -p$@
        dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -292,7 +289,7 @@ apt-utils: build debian/shlibs.local
 apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 
        # install the method
@@ -310,7 +307,7 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib 
+       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@