]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
typo: run s#frontend#front-end# on all of src:apt
[apt.git] / debian / apt.postinst
index bcc18b4e5306b03443089b1a2ed3f04ebc6ec7fb..1f98fcece4bad4d0b82e9edc7d7b78dc9c6c243b 100755 (executable)
@@ -40,13 +40,13 @@ case "$1" in
        fi
 
        # add unprivileged user for the apt methods
-       adduser --force-badname --system -home /var/empty \
+       adduser --force-badname --system --home /nonexistent  \
            --no-create-home --quiet _apt || true
 
-        # ensure the passwords can still be read by the methods
-        if [ -e /etc/apt/auth.conf ]; then
-            chown _apt:root /etc/apt/auth.conf
-        fi
+       # Fixup any mistake in the home directory of the _apt user
+       if dpkg --compare-versions "$2" lt-nl 1.1~exp10~; then
+           usermod --home /nonexistent _apt
+       fi
 
        # deal with upgrades from experimental
        if dpkg --compare-versions "$2" 'eq' '1.1~exp3'; then