]> git.saurik.com Git - apt.git/blobdiff - debian/apt.postinst
Ensure /etc/apt/auth.conf has _apt:root owner
[apt.git] / debian / apt.postinst
index bcc18b4e5306b03443089b1a2ed3f04ebc6ec7fb..b0a5da7d85d7cb5c5ba46c65a15b63fc83be6f0c 100755 (executable)
@@ -43,11 +43,6 @@ case "$1" in
        adduser --force-badname --system -home /var/empty \
            --no-create-home --quiet _apt || true
 
-        # ensure the passwords can still be read by the methods
-        if [ -e /etc/apt/auth.conf ]; then
-            chown _apt:root /etc/apt/auth.conf
-        fi
-
        # deal with upgrades from experimental
        if dpkg --compare-versions "$2" 'eq' '1.1~exp3'; then
            # libapt will setup partial/ at runtime