set -e
-# auto-package-test is very unhappy if stuff it writen to stderr
-exec 2> apt-stderr.log
+unset LANGUAGE
+export LC_ALL=C
# we need the buildin webserver for the tests
if [ ! -e environment.mak ]; then
- ./configure
+ make startup
fi
make -C test/interactive-helper/
# run against the installed apt
APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
./test/integration/run-tests