]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
initial version of apt-helper
[apt.git] / debian / tests / run-tests
index 233c5a386b1f80790dd87810a38f85b9ffa16ddf..e03db9b0c7bdd0a786469995f42c1f08838b4d56 100644 (file)
@@ -2,17 +2,18 @@
 
 set -e
 
-# auto-package-test is very unhappy if stuff it writen to stderr
-exec 2> apt-stderr.log
+unset LANGUAGE
+export LC_ALL=C
 
 # we need the buildin webserver for the tests
 if [ ! -e environment.mak ]; then
-    ./configure
+    make startup
 fi
 make -C test/interactive-helper/
 
 # run against the installed apt
 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
 APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
 APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
 ./test/integration/run-tests