]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Fix compressed index retrieval for current timestamps
[apt.git] / debian / rules
index f69c0cffb7999b9dfcc5cb4dd5a20f3f51a5aa03..450f3e0f6e09061fe99e9c8399d857047be130af 100755 (executable)
@@ -78,8 +78,8 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 include buildlib/libversion.mak
 
 # Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
 
 debian/shlibs.local: apt-pkg/makefile
        # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
@@ -108,7 +108,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+       cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -144,7 +144,8 @@ libapt-pkg-doc: build-doc debian/shlibs.local
 #      
        dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
                             $(BLD)/docs/files* $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt doc/style.txt
+                           doc/libapt-pkg2_to_3.txt doc/style.txt \
+                           $(BLD)/doc/doxygen/html/*
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
@@ -190,7 +191,7 @@ apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -213,7 +214,6 @@ apt: build build-doc debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/debian-archive.gpg debian/$@/usr/share/$@
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog