# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.66 2004/05/08 19:52:33 mdz Exp $
+# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
# Default rule
build:
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
# Rebuild configure.in to have the correct version from the change log
ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
.PHONY: configure.in
configure.in:
sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
else
configure.in:
endif
rm -rf build
# Add here commands to clean up after the build process.
- dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
+ dh_clean debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
#
# Copy the guides
dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
- $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+ $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
dh_installchangelogs -p$@
dh_compress -p$@
dh_fixperms -p$@
# Build architecture-dependent files here.
-binary-arch: apt libapt-pkg-dev apt-utils
+binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
apt: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
- dh_installdirs -p$@ /usr/share/bug/$@
+ dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
#
# apt install
#
- cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+ cp $(BLD)/bin/apt-* debian/$@/usr/bin/
# Remove the bits that are in apt-utils
- rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+ rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
# install the shared libs
- find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
- find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+ find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
- cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
+ cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
+ # https has its own package
+ rm debian/$@/usr/lib/apt/methods/https
- cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
- cp -r $(BLD)/locale debian/apt/usr/share/
+ cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
+ cp -r $(BLD)/locale debian/$@/usr/share/
- cp debian/bugscript debian/apt/usr/share/bug/apt/script
+ cp debian/bugscript debian/$@/usr/share/bug/apt/script
+ cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
+ cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+ sed 's/^_//' share/apt-auth-failure.note > debian/$@/usr/share/$@/apt-auth-failure.note
+ cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+ cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
# head -n 500 ChangeLog > debian/ChangeLog
+ # make rosetta happy and remove pot files in po/ (but leave stuff
+ # in po/domains/* untouched) and cp *.po into each domain dir
+ rm -f build/po/*.pot
+ rm -f po/*.pot
+
+ # move the mirror failure script in place
+ mv debian/$@/usr/bin/apt-report-mirror-failure \
+ debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
dh_installexamples -p$@ $(BLD)/docs/examples/*
dh_installman -p$@
-
+ dh_installcron -p$@
dh_installdocs -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_fixperms -p$@
dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
dh_installdocs -p$@
+ dh_installexamples -p$@
# Install the man pages..
dh_installman -p$@
dh_md5sums -p$@
dh_builddeb -p$@
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_clean -p$@ -k
+ dh_installdirs -p$@
+
+ # install the method
+ mkdir -p debian/$@/usr/lib/apt/methods
+ cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+
+ dh_installdocs -p$@
+ dh_installexamples -p$@
+
+ # Install the man pages..
+ dh_installman -p$@
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
CVS_MODULE=$(shell cat CVS/Repository)
cvs-build:
rm -rf debian/cvs-build
- cvs update -d
mkdir -p debian/cvs-build
(cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
$(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
cvs-mkul:
-mkdir -p ../upload-$(APT_DEBVER)
cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+ rm -rf debian/arch-build
+ mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+ tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
+ $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+ (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)