# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.11 1999/03/21 12:43:43 doogie Exp $
+# $Id: rules,v 1.56 2003/12/21 00:07:35 mdz Exp $
-DEB_BUILD_PROG:=debuild
+# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
+# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
+
+# For the deb builder, you can run 'debian/rules cvs-build', which does all
+# steps nescessary to produce a proper source tarball with the CVS/ removed.
+# It builds in debian/cvs-build/apt-<VER>/, and places files in
+# debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
+# create ../upload-<VER>, with all the files needed to be uploaded placed
+# in it.
+
+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+ confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+ confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
+# See below
+-include build/environment.mak
+
+# Default rule
+build:
+
+DEB_BUILD_PROG:=debuild -us -uc
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+# Determine the build directory to use
+BASE=.
+ifdef BUILD
+BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
+else
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+endif
+BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
+BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
+override BLD := $(BUILDX)
+
+ifeq ($(words $(BLD)),0)
+override BLD := ./build
+endif
+
+# Rebuild configure.in to have the correct version from the change log
ifneq ($(APT_DEBVER),$(APT_CONFVER))
.PHONY: configure.in
configure.in:
configure.in:
endif
+# APT Programs in apt-utils
+APT_UTILS=ftparchive sortpkgs extracttemplates
+
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# Find the libapt-pkg major version for use in other control files
-export LIBAPT_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
-debian/shlibs.local:
- rm $@
- echo "libapt-pkg $(LIBAPT_MAJOR) libapt-pkg$(LIBAPT_MAJOR)" >> $@
+export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
+export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+
+# Determine which package we should provide in the control files
+LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+
+debian/shlibs.local: apt-pkg/makefile
+ # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+ # one for the rest of the packages. This ensures that each package gets
+ # the right overrides..
+ rm -rf $@ $@.apt $@.apt-utils
+ echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+
+ echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+ echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+
+ echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+ echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+
+build: build/build-stamp
+build-doc: build/build-doc-stamp
+
+# Note that this is unconditionally done first as part of loading environment.mak
+# The true is needed to force make to reload environment.mak after running
+# configure-stamp. Otherwise we can get stale or invalid, or missing config data.
+build/environment.mak: build/configure-stamp
+ @true
-build: build-stamp
-build-stamp: configure
+configure: configure.in
+build/configure-stamp: configure
dh_testdir
-mkdir build
- (cd build; ../configure)
-# cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
-# cd build && make all-hdr
-# cd build && make -s
-
+ cp COPYING debian/copyright
+ cd build && ../configure $(confflags)
+ touch $@
+
+build/build-stamp: build/configure-stamp
+ # Add here commands to compile the package.
+ $(MAKE) binary
+ touch $@
+
+build/build-doc-stamp: build/configure-stamp
# Add here commands to compile the package.
- make
- touch build-stamp
+ $(MAKE) doc
+ touch $@
clean:
dh_testdir
# dh_testroot
- rm -f build-stamp
+ -$(MAKE) clean
+ -$(MAKE) distclean
+
rm -rf build
# Add here commands to clean up after the build process.
- -$(MAKE) clean
- -$(MAKE) distclean
- dh_clean
+ dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
-binary-indep: libapt-pkg-doc
+binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
-libapt-pkg-doc: build debian/shlibs.local
+libapt-pkg-doc: build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
dh_installdirs -p$@
#
# libapt-pkg-doc install
-#
- cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
- build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
- cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
- dh_installdocs -p$@
+#
+ dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
+ $(BLD)/docs/files* $(BLD)/docs/method* \
+ doc/libapt-pkg2_to_3.txt doc/style.txt
dh_installexamples -p$@
# dh_installmenu -p$@
# dh_installinit -p$@
# dh_installcron -p$@
- dh_installmanpages -p$@
+# dh_installman -p$@
# dh_undocumented -p$@
dh_installchangelogs -p$@
dh_fixperms -p$@
# dh_suidregister -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+apt-doc: build-doc
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_clean -p$@ -k
+#
+# apt-doc install
+#
+ # Copy the guides
+ dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
+ $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+ dh_installchangelogs -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
+
# Build architecture-dependent files here.
-binary-arch: apt libapt-pkg-dev
+binary-arch: apt libapt-pkg-dev apt-utils
apt: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
- dh_installdirs -p$@
+ dh_installdirs -p$@ /usr/share/bug/$@
#
# apt install
#
- cp build/bin/apt-* debian/tmp/usr/bin/
-
+ cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+
+ # Remove the bits that are in apt-utils
+ rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+
# install the shared libs
- find build/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
- find build/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
-
- cp build/bin/methods/* debian/tmp/usr/lib/apt/methods/
-
- cp build/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
-# cp debian/sources.list debian/tmp/etc/apt/
-
- # Copy the users guide
- cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
- cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
-
- # Copy the offline guide
- cp build/docs/offline.text debian/tmp/usr/doc/apt/offline.txt
- cp -a build/docs/offline.html/* debian/tmp/usr/doc/apt/offline.html/
-
- cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
-
-# head -n 500 ChangeLog > debian/ChangeLog
+ find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+ cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
+ cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
+ cp -r $(BLD)/locale debian/apt/usr/share/
- dh_installdocs -p$@
- dh_installexamples -papt build/docs/examples/*
-# dh_installmenu -papt
-# dh_installinit -papt
-# dh_installcron -papt
- dh_installmanpages -p$@
+ cp debian/bugscript debian/apt/usr/share/bug/apt/script
-# dh_undocumented -papt
+# head -n 500 ChangeLog > debian/ChangeLog
+
+ dh_installexamples -p$@ $(BLD)/docs/examples/*
+ dh_installman -p$@
+
+ dh_installdocs -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
-# dh_suidregister -p$@
+ dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
dh_installdeb -p$@
- LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
- dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
+ dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
#
# libapt-pkg-dev install
#
- ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
- cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
+ cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
+ cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
+# ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+ cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
dh_installdocs -p$@
-# dh_installmenu -papt
-# dh_installinit -papt
-# dh_installcron -papt
- dh_installmanpages -p$@
+# dh_installmenu -p$@
+# dh_installinit -p$@
+# dh_installcron -p$@
+# dh_installman -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_fixperms -p$@
# dh_suidregister -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+apt-utils: build debian/shlibs.local
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_clean -p$@ -k
+ dh_installdirs -p$@
+
+ # install the shared libs
+ find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+
+ cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+ dh_installdocs -p$@
+
+ # Install the man pages..
+ dh_installman -p$@
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+ dh_installdeb -p$@
+ LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+ dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
-source diff:
+source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
# Update from CVS
super-l33ch: l33ch Makefile.in
configure:
- make configure
+ $(MAKE) configure
l33ch-stamp: super-l33ch
- touch l33ch-stamp
+ touch $@
really-clean: clean
-find -name Makefile.in -print0 | xargs -0r rm -f
cvs-build:
rm -rf debian/cvs-build
- cvs update
- buildlib/mkChangeLog
- make startup
- make doc
- tar c --exclude CVS --exclude debian/cvs-build . |\
+ cvs update -d
+ $(MAKE) startup
+ $(MAKE) doc
+ tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
(mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-# The next line isn't needed, as debuild will make the .tar.gz for us.
-# (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
- (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG) -us -uc)
+ (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+
+cvs-mkul:
+ -mkdir -p ../upload-$(APT_DEBVER)
+ cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)