+apt (1.2.3) unstable; urgency=high
+
+ [ Julian Andres Klode ]
+ * Set seekpos to 0 after reopening files in Seek() (Closes: #812994, #813000)
+
+ [ David Kalnischkies ]
+ * get dpkg lock in build-dep if cache was invalid again (Closes: 814139)
+
+ -- Julian Andres Klode <jak@debian.org> Wed, 10 Feb 2016 18:02:20 +0100
+
+apt (1.2.2) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * always create pkg at the time pkg:arch is created
+ * reimplement build-dep via apts normal resolver
+ (Closes: #137560, #444930, #489911, #583914, #728317, #812173)
+ * parse version correctly from binary Source field (Closes: 812492)
+ * get sources for packages in multiple releases again (Closes: 812497)
+ * only warn about missing/invalid Date field for now (Closes: 809329)
+ * support <libc>-<kernel>-<cpu> in architecture specs.
+ Thanks to Bálint Réczey for initial patch (Closes: #812212)
+ * avoid building dependency tree in 'source' command
+
+ [ Stefan Bühler ]
+ * fix "Mismatched free() / delete / delete []" in simple_buffer
+
+ [ Julian Andres Klode ]
+ * Do not buffer writes larger than the buffer if possible
+ * Drop the g++ build-dep, transition is done
+ * NEWS: Prefix the keep deb option with Binary::apt:: (Closes: #812111)
+ * rred: If there were I/O errors, fail
+ * Correctly report write errors when flushing buffered writer
+ * test: Fix apt-key tests to work with current gpg 2.1
+
+ [ Manuel "Venturi" Porras Peralta ]
+ * Spanish program translation update (Closes: 813467)
+
+ [ Adrian Wielgosik ]
+ * Try avoiding loading long package description
+ * Avoid temporary strings in SubstVar.
+
+ [ Fredrik Fornwall ]
+ * edspsystem.cc: include <stdlib.h> for mkdtemp (Closes: #807367)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 04 Feb 2016 22:50:43 +0100
+
+apt (1.2.1) unstable; urgency=high
+
+ [ Zhou Mo ]
+ * po: update zh_CN programs translation
+
+ [ Julian Andres Klode ]
+ * Remap StringView instances pointing into the cache (Closes: #812251)
+
+ [ Michael Vogt ]
+ * Log calling SUDO_USER or PKEXEC_UID in history.log.
+ Thanks to Thomas Reusch
+
+ -- Julian Andres Klode <jak@debian.org> Mon, 25 Jan 2016 18:03:50 +0100
+
+apt (1.2) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Do not break apt-file (<< 3.0~exp1~), 2.X works fine
+ * Version the build-depends on liblz4-dev to >= 0.0~r126
+ * search: Handle packages without description (Closes: #810622)
+ * Only enable pipelining if server is HTTP/1.1 (Closes: #810796)
+
+ [ Mattia Rizzolo ]
+ * Sort the list of sources to be built and linked (Closes: #810509)
+
+ [ Michael Vogt ]
+ * Do not show multiple identical apt-cache showsrc entries (Closes: #734922)
+
+ [ David Kalnischkies ]
+ * evaluate sourceslist-list-format entity in vendors sources.list.
+ Thanks to Niels Thykier for reporting on IRC
+ * update symbols file
+ * fix M-A:foreign provides creation for unknown archs
+ * revert file-hash based action-merging in acquire (Closes: 810046)
+ * return correct position in APT::StringView::(r)find
+
+ [ Zhou Mo ]
+ * po: update simplified chinese programs translation
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 15 Jan 2016 19:52:19 +0100
+
+apt (1.2~exp1) experimental; urgency=medium
+
+ [ Beatrice Torracca ]
+ * Italian manpages translation update (Closes: 809522)
+
+ [ David Kalnischkies ]
+ * add optional support for comments in pkgTagFile
+ * support comments in debian/control parsing (Closes: 806775)
+ * properly parse comments in apt_preferences and deb822-style sources
+ * include all compressed Packages/Sources files in Release file
+ * use one 'store' method to rule all (de)compressors
+ * ensure compression cleanup even without lists-cleanup
+ * allow pdiff bootstrap from all supported compressors
+ * keep compressed indexes in a low-cost format
+ * support '-' and no parameter for stdin in apt-helper cat-file
+ * tests: limit autotest-functionname generation to sane characters
+ * use filesize of compressed pdiffs for the limit if possible
+ * remove uncompressed leftover partial file before pdiff bootstrap
+
+ [ Michael Vogt ]
+ * Add support for APT::Periodic::CleanInterval.
+ Thanks to Martin-Éric Racine
+ * Add bash-completion support for the "apt" command (Closes: #747094)
+ * Add new APT::Keep-Downloaded-Packages option (Closes: #160743)
+
+ [ Julian Andres Klode ]
+ * Change compressor costs to be 100 apart
+ * apt-cache: stats: Average is over used, not all, buckets
+ * Increase APT::Cache-HashTableSize default to 50503
+ * travis: pull liblz4-dev from wily
+ * FileFd: (native) LZ4 support
+ * apt-helper: cat-file: Add -C/--compress option
+ * CopyFile: Use 64 * 1024 instead of 64000 as buffer size
+ * acquire: Allow parallelizing methods without hosts
+ * rred: Run in parallel
+ * Introduce internal APT::StringView class
+ * Switch performance critical code to use APT::StringView
+ * pkgCacheGenerator::StoreString: Get rid of std::string
+ * pkgCacheGenerator: CurMd5.Value() cannot be empty
+ * AvailableDescriptionLanguages: Use one string for all iterations
+ * NEWS: Document recompression of indices
+ * Store the size of strings in the cache
+ * libapt-pkg5.0: Add Breaks appstream (<< 0.9.0-3~)
+
+ [ Helmut Grohne ]
+ * Allow building without libgtest-dev under <nocheck> build profile
+ (Closes: #809726)
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 08 Jan 2016 21:41:10 +0100
+
+apt (1.1.10) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * deal with empty values properly in deb822 parser (Closes: 808102)
+
+ [ Beatrice Torracca ]
+ * fix 3 typos/omissions in apt.conf(5) (Closes: 809160)
+
+ [ Julian Andres Klode ]
+ * BufferedWriter: flushing: Check for written < size instead of <=
+ * aptconfiguration: Set default compression level to 6
+ * BufferedFileFdPrivate: Make InternalFlush() save against errors
+ * Switch to DJB hashing and use prime number as table size
+ * Turn tolower_ascii() and isspace_ascii() into inline functions
+ * Fix test case that was broken by switch of hash function
+ * pkgTagSection::Scan: Fix read of uninitialized value
+ * pkgCacheGenerator: Allow passing down an already created cache
+ * Add support for calculating hashes over the entire cache
+ * Do not sync the cache file
+
+ -- Julian Andres Klode <jak@debian.org> Wed, 30 Dec 2015 00:40:53 +0100
+
apt (1.1.9) unstable; urgency=medium
Highlights: buffered rred writes and slightly faster cache generation (~10%)