]> git.saurik.com Git - apt.git/blobdiff - debian/rules
merged from debian-sid
[apt.git] / debian / rules
index 7405f860118b4cc33ff56e078796a0503a714d86..b6f45a38e4b242e44f213d40040d78d67da3c518 100755 (executable)
@@ -70,6 +70,10 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 # Find the libapt-pkg major version for use in other control files
 include buildlib/libversion.mak
 
+# Determine which library package names to use
+LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
+
 # do not fail as we are just experimenting with symbol files for now
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
@@ -93,6 +97,10 @@ build/configure-stamp: configure
 build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
        $(MAKE) binary
+       # compat symlink for the locale split
+       mkdir -p build/usr/share 
+       cd build/usr/share && ln -f -s ../../locale .
+       # done here
        touch $@
 
 build/build-doc-stamp: build/configure-stamp
@@ -161,7 +169,7 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: libapt-pkg4.10 libapt-inst1.2 apt libapt-pkg-dev apt-utils apt-transport-https
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
 apt: build build-doc
        dh_testdir -p$@
@@ -222,7 +230,7 @@ libapt-pkg-dev: build
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@
+       dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -253,37 +261,39 @@ apt-utils: build
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg4.10: build
+$(LIBAPT_PKG): build
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
        dh_installdirs -p$@
 
        dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_installdeb -p$@
        dh_makeshlibs -p$@
+       dh_installdeb -p$@
        dh_shlibdeps -p$@ 
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-inst1.2: build
+$(LIBAPT_INST): build
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
        dh_installdirs -p$@
 
        dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_installdeb -p$@
        dh_makeshlibs -p$@
+       dh_installdeb -p$@
        dh_shlibdeps -p$@ 
        dh_gencontrol -p$@
        dh_md5sums -p$@