* apt-pkg/acquire-item.cc:
- remove zero size files on I-M-S hit
* methods/https.cc:
- - only send LastModified if we actually have one
+ - only send LastModified if we actually have a file
- send range request with if-range
- delete failed downloads
+ - delete zero size I-M-S hits
* apt-pkg/deb/dpkgpm.{cc,h}:
- merged dpkg-log branch, this lets you specify a
Dir::Log::Terminal file to log dpkg output to
C. Litzenberger" <dlitz@dlitz.net> for the patch (closes: #441942)
* Fix compilation warnings:
- apt-pkg/indexfile.cc: conversion from string constant to 'char*';
+ - apt-pkg/acquire-item.cc: likewise;
+ - apt-pkg/cdrom.cc: '%lu' expects 'long unsigned int', but argument
+ has type 'size_t';
+ - apt-pkg/deb/dpkgpm.cc: initialization order and conversion from
+ string constant to 'char*';
+ - methods/gpgv.cc: conversion from string constant to 'char*';
+ - methods/ftp.cc: likewise;
+ - cmdline/apt-extracttemplates.cc: likewise;
+ - apt-pkg/deb/debmetaindex.cc: comparison with string literal results
+ in unspecified behaviour;
+ * cmdline/apt-get.cc: adds 'autoremove' as a valid comment to usage
+ statement of apt-get (closes: #445468).
+ * cmdline/apt-get.cc: really applies Julien Danjou <acid@debian.org>
+ patch to add 'purge' command line argument (closes: #133421).
[ Ian Jackson ]
* dpkg-triggers: Deal properly with new package states.
* apt-pkg/contrib/mmap.cc:
- don't fail if msync() returns > 0
- -- Otavio Salvador <otavio@debian.org> Mon, 06 Aug 2007 10:44:53 -0300
+ -- Otavio Salvador <otavio@debian.org> Sat, 06 Oct 2007 18:23:42 -0300
apt (0.7.6) unstable; urgency=low