]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Avoid mangling configure.in on incomplete changelog
[apt.git] / debian / rules
index d4d2fb61c22e5ea98a7c4af2f265fc5dd6b50746..a4d826de5850d70d5827b5e8a9c37f4fefe7104e 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.65 2004/04/30 04:37:47 mdz Exp $
+# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -39,6 +39,7 @@ build:
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -57,9 +58,11 @@ endif
 
 # Rebuild configure.in to have the correct version from the change log
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
 .PHONY: configure.in
 configure.in:
        sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+fi
 else
 configure.in:
 endif
@@ -105,7 +108,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+       cd build && ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -186,7 +189,7 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -210,7 +213,7 @@ apt: build debian/shlibs.local
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ 
-
+       dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -312,15 +315,23 @@ binary: binary-indep binary-arch
 # edit configure.in
 # debian/rules cvs-build
 
+CVS_BUILDDIR=apt-$(APT_DEBVER)
+CVS_ROOT=$(shell cat CVS/Root)
+CVS_MODULE=$(shell cat CVS/Repository)
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update -d
-       $(MAKE) startup
-       $(MAKE) doc
-       tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
-               (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-       (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+       mkdir -p debian/cvs-build
+       (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
+       $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
+       (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
 
 cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)
        cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+       rm -rf debian/arch-build
+       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+       tla inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+       $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))