]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Substituted 'apt-archive' with 'apt-ftparchive'.
[apt.git] / debian / rules
index 006d2de8a61d3a68535aad60c4b6336091e4eccf..f6ff3c47a4033bac10478c2d04cfa79f558a3723 100755 (executable)
@@ -125,8 +125,8 @@ build/build-doc-stamp: build/configure-stamp
 clean:
        dh_testdir
 #      dh_testroot
 clean:
        dh_testdir
 #      dh_testroot
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ -f Makefile ] && $(MAKE) clean
+       [ -f Makefile ] && $(MAKE) distclean
 
        rm -rf build
 
 
        rm -rf build
 
@@ -217,6 +217,9 @@ apt: build debian/shlibs.local
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
+       # copy lintian override
+       cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
+
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
        rm -f build/po/*.pot
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
        rm -f build/po/*.pot