]> git.saurik.com Git - apt.git/blobdiff - debian/rules
apt.cron.daily: catch invalid dates due to DST time changes
[apt.git] / debian / rules
index dfee44fde60dd621a053322055100695aa181997..f1eb62b5718530252753cd93933b85df8554ea56 100755 (executable)
@@ -38,7 +38,7 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -125,8 +125,8 @@ build/build-doc-stamp: build/configure-stamp
 clean:
        dh_testdir
 #      dh_testroot
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ -f Makefile ] && $(MAKE) clean
+       [ -f Makefile ] && $(MAKE) distclean
 
        rm -rf build
 
@@ -185,8 +185,8 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt-transport-https apt libapt-pkg-dev apt-utils
-apt: build debian/shlibs.local
+binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -204,17 +204,22 @@ apt: build debian/shlibs.local
        find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
        cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
 
        cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/$@/usr/share/
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
-       cp debian/apt.logrotate debian/$@/etc/logrorate.d/apt
+       cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
        cp share/debian-archive.gpg debian/$@/usr/share/$@
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
+       # copy lintian override
+       cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
+
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
        rm -f build/po/*.pot
@@ -292,7 +297,7 @@ apt-utils: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-transport-https: build debian/shlibs.local
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -300,9 +305,9 @@ apt-transport-https: build debian/shlibs.local
 
        # install the method
        mkdir -p debian/$@/usr/lib/apt/methods
-       mv $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+       cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
 
-       dh_installdocs -p$@
+       dh_installdocs -p$@ debian/apt-transport-https.README
        dh_installexamples -p$@
 
        # Install the man pages..