]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/deb/dpkgpm.cc:
[apt.git] / debian / changelog
index 17affee4fc0628ead9fafc8fc6db8ed90f98094d..7d2417cf4c4def0eb2d896c8d9e87c9cd9b0ad92 100644 (file)
@@ -1,4 +1,30 @@
-apt (0.7.26) UNRELEASED; urgency=low
+apt (0.7.26~exp4) experimental; urgency=low
+
+  * apt-pkg/depcache.cc:
+    - "reinstall" the correct version for a killed pseudo package
+  * apt-pkg/packagemanager.cc:
+    - don't try to "unpack" pseudo packages twice
+  * apt-pkg/contrib/fileutl.cc:
+    - add a parent-guarded "mkdir -p" as CreateDirectory()
+  * apt-pkg/acquire.{cc,h}:
+    - add a delayed constructor with Setup() for success reporting
+    - check for and create directories in Setup if needed instead of
+      error out unfriendly in the Constructor (Closes: #523920, #525783)
+    - optional handle a lock file in Setup()
+  * apt-pkg/acquire-item.cc:
+    - Acquire::ForceHash to force method for expected hash
+  * cmdline/apt-get.cc:
+    - remove the lock file handling and let Acquire take care of it instead
+    - display MD5Sum in --print-uris if not forced to use another method
+      instead of displaying the strongest available (Closes: #576420)
+    - regex for package names executed on Grp- not PkgIterator
+  * apt-pkg/deb/dpkgpm.cc:
+    - remove Chroot-Directory from files passed to install commands.
+      Thanks to Kel Modderman for report & patch! (Closes: #577226)
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Sat, 03 Apr 2010 14:58:39 +0200
+
+apt (0.7.26~exp3) experimental; urgency=low
 
   [ Christian Perrier ]
   * German translation update. Closes: #571037
@@ -43,6 +69,7 @@ apt (0.7.26) UNRELEASED; urgency=low
   * cmdline/apt-get.cc:
     - add a --only-upgrade flag to install command (Closes: #572259)
     - fix memory leaks in error conditions in DoSource()
+    - try version match in FindSrc first exact than fuzzy (LP: #551178)
   * apt-pkg/contrib/cmndline.cc:
     - save Commandline in Commandline::AsString for logging
   * apt-pkg/deb/debversion.cc:
@@ -60,17 +87,48 @@ apt (0.7.26) UNRELEASED; urgency=low
   * doc/po/de.po:
     - correct a few typos in the german manpage translation.
       Thanks to Chris Leick and Georg Koppen! (Closes: #574962)
+  * apt-pkg/contrib/strutl.cc:
+    - convert all toupper calls to tolower_ascii for a little speedup
+
+  [ Jean-Baptiste Lallement ]
+  * apt-pkg/contrib/strutl.cc:
+    - always escape '%' (LP: #130289) (Closes: #500560)
+    - unescape '%' sequence only if followed by 2 hex digit
+    - username/password are urlencoded in proxy string (RFC 3986)
 
   [ Julian Andres Klode ]
+  * cmdline/apt-cache.cc:
+    - Change behavior of showsrc to match the one of show (Closes: #512046).
+  * cmdline/apt-key:
+    - Honor Apt::GPGV::TrustedKeyring (Closes: #316390)
   * cmdline/apt-mark:
     - Use the new python-apt API (and conflict with python-apt << 0.7.93.2).
   * apt-inst/contrib/arfile.h:
     - Add public ARArchive::Members() which returns the list of members.
+  * apt-pkg/policy.cc:
+    - Always return a candidate if there is at least one version pinned > 0
+      (Closes: #512318)
+  * ftparchive/apt-ftparchive.cc:
+    - Read default configuration (Closes: #383257)
   * debian/rules:
     - Fix the libraries name to be e.g. libapt-pkg4.9 instead of
       libapt-pkg-4.9.
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Sun, 14 Mar 2010 16:47:07 +0100
+  [ Michael Vogt ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - fix backgrounding when dpkg runs (closes: #486222)
+  * cmdline/apt-mark:
+    - show error on incorrect aguments (LP: #517917), thanks to
+      Torsten Spindler
+  * cmdline/apt-get.cc:
+    - if apt-get source foo=version or foo/distro can not be found,
+      error out (LP: #502641)
+  * apt-pkg/packagemanager.cc:
+    - better debug output 
+  * doc/examples/configure-index:
+    - add missing Debug::pkgPackageManager option
+
+ -- Michael Vogt <mvo@debian.org>  Thu, 01 Apr 2010 17:30:43 +0200
 
 apt (0.7.26~exp2) experimental; urgency=low
 
@@ -1470,6 +1528,13 @@ apt (0.7.6) unstable; urgency=low
 
  -- Otavio Salvador <otavio@debian.org>  Wed, 01 Aug 2007 19:49:51 -0300
 
+apt (0.7.6) unstable; urgency=low
+
+  * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
+    directory downloading on non-linux architectures (closes: #435597)
+
+ -- Otavio Salvador <otavio@debian.org>  Wed, 01 Aug 2007 19:49:51 -0300
+
 apt (0.7.5) unstable; urgency=low
 
   [ Otavio Salvador ]