]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/aptconfiguration.cc:
[apt.git] / debian / changelog
index e451bf755d4908d5104f65a6fc1b1096a782b5a8..5d4f8720c172e47a79490820934f449033042f65 100644 (file)
@@ -5,6 +5,7 @@ apt (0.9.4) UNRELEASED; urgency=low
     - after many years of pointless discussions disable http/1.1 pipelining
       by default as many webservers and proxies seem to be unable to conform
       to specification must's (rfc2616 section 8.1.2.2) (LP: #996151)
+    - add spaces around PACKAGE_VERSION to fix FTBFS with -std=c++11
   * apt-pkg/pkgcachegen.cc:
     - make IsDuplicatedDescription static so that it is really private
       as we don't need a symbol for it as it is not in a header
@@ -21,6 +22,25 @@ apt (0.9.4) UNRELEASED; urgency=low
       are no longer build in the same target as the manpages
   * apt-pkg/acquire-methods.cc:
     - factor out into private Dequeue() to fix access to deleted pointer
+  * apt-pkg/contrib/fileutl.cc:
+    - ensure that we close compressed fds, wait for forks and such even if
+      the FileFd itself is set to not autoclose the given Fd
+  * cmdline/apt-get.cc:
+    - use the host architecture, not the build architecture for matching
+      of [architecture restrictions] in Build-Depends (Closes: #672927)
+  * doc/makefile:
+    - build manpages with the correct l10n.gentext.default.language setting
+      to get the correct section titles provided by docbook
+  * doc/po/de.po:
+    - updated german manpage translation by Chris Leick, thanks!
+  * apt-pkg/packagemanager.cc:
+    - do not run into loop on new-pre-depends-breaks (Closes: #673536)
+  * doc/*.xml:
+    - add a few translator notes and reword some paragraphs to ensure that
+      translators and users alike can better understand them (Closes: #669409)
+  * apt-pkg/aptconfiguration.cc:
+    - longcode Translation files are saved with encoded underscore,
+      so make sure to pick these files up as well for Acquire::Languages
 
   [ Raphael Geissert ]
   * apt-pkg/acquire*.cc: