]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* methods/gpgv.cc:
[apt.git] / debian / changelog
index 657211e5f9e3e783605b29dad9b89e6146c7db00..e2a0365ac6bfcef75ec41c342e15cf5769b24b31 100644 (file)
@@ -1,4 +1,156 @@
-apt (0.7.15) UNRELEASED; urgency=low
+apt (0.7.17) UNRELEASED; urgency=low
+
+  [ Osamu Aoki ]
+  * Updated cron script to support backups by hardlinks and 
+    verbose levels.  All features turned off by default. 
+  * Added more error handlings.  Closes: #438803, #462734, #454989, 
+  * Refactored condition structure to make download and upgrade performed 
+    if only previous steps succeeded. Closes: #341970
+  * Documented all cron script related configuration items in 
+    configure-index.
+
+  [ Michael Vogt ]
+  * apt-pkg/depcache.cc:
+    - when checking for new important deps, skip critical ones
+      (LP: #236360)
+  * document --install-recommends and --no-install-recommends
+    (thanks to Dereck Wonnacott, LP: #126180)
+  * make "apt-get build-dep" installed packages marked automatic
+    by default. This can be changed by setting the value of
+    APT::Get::Build-Dep-Automatic to false (thanks to Aaron 
+    Haviland, closes: #44874, LP: #248268)
+  * apt-pkg/indexcopy.cc:
+    - support having CDs with no Packages file (just a Packages.gz)
+      by not forcing a verification on non-existing files
+     (LP: #255545)
+  * cmdline/apt-cache.cc:
+    - remove the gettext from a string that consists entirely 
+      of variables (LP: #56792)
+  * doc/makefile:
+    - add examples/apt-https-method-example.conf
+  * apt-pkg/cacheiterators.h:
+    - add missing checks for Owner == 0 in end()
+  * apt-pkg/deb/dpkgpm.cc:
+    - fix potential hang when in a backgroud process group
+    - fix SIGHUP handling (closes: #463030)
+  * apt-pkg/indexrecords.cc:
+    - fix some i18n issues
+  * apt-pkg/contrib/strutl.h:
+    - add new strprintf() function to make i18n strings easier
+  * methods/gpgv.cc:
+    - fix compiler warning
+  * cmdline/apt-get.cc:
+    - fix "apt-get source pkg=ver" if binary name != source name
+      and show a message (LP: #202219)
+  * apt-pkg/deb/debsystem.cc:
+    - make strings i18n able 
+
+  [ Dereck Wonnacott ]
+  * apt-ftparchive might write corrupt Release files (LP: #46439)
+  * Apply --important option to apt-cache depends (LP: #16947) 
+
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 12 Sep 2008 11:34:24 +0200
+
+apt (0.7.17~exp2) experimental; urgency=low
+
+  [ Eugene V. Lyubimkin ]
+  * apt-pkg/acquire-item.cc:
+    - Added fallback to uncompressed 'Packages' if neither 'bz2' nor 'gz'
+      available. (Closes: #409284)
+  * apt-pkg/algorithm.cc:
+    - Strip username and password from source URL in error message.
+      (Closes: #425150)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com>  Fri, 24 Oct 2008 23:45:17 +0300
+
+
+apt (0.7.17~exp1) experimental; urgency=low
+
+  [ Luca Bruno ]
+  * Fix typos:
+    - apt-pkg/depcache.cc
+  * Fix compilation warnings:
+    - apt-pkg/acquire.cc
+    - apt-pkg/versionmatch.cc
+  * Compilation fixes and portability improvement for compiling APT against non-GNU libc
+    (thanks to Martin Koeppe, closes: #392063):
+    - buildlib/apti18n.h.in:
+      + textdomain() and bindtextdomain() must not be visible when --disable-nls
+    - buildlib/inttypes.h.in: undefine standard int*_t types
+    - Append INTLLIBS to SLIBS:
+      + cmdline/makefile
+      + ftparchive/makefile
+      + methods/makefile
+  * doc/apt.conf.5.xml:
+    - clarify whether configuration items of apt.conf are case-sensitive
+      (thanks to Vincent McIntyre, closes: #345901)
+
+ -- Luca Bruno <lethalman88@gmail.com>  Sat, 11 Oct 2008 09:17:46 +0200
+
+apt (0.7.16) unstable; urgency=low
+
+  [ Luca Bruno ]
+  * doc/apt-cache.8.xml:
+    - search command uses POSIX regex, and searches for virtual packages too
+      (closes: #277536)
+  * doc/offline.sgml: clarify remote and target hosts
+    (thanks to Nikolaus Schulz, closes: #175940)
+  * Fix several typos in docs, translations and debian/changelog
+    (thanks to timeless, Nicolas Bonifas and Josh Triplett,
+    closes: #368665, #298821, #411532, #431636, #461458)
+  * Document apt-key finger and adv commands
+    (thanks to Stefan Schmidt, closes: #350575)
+  * Better documentation for apt-get --option
+    (thanks to Tomas Pospisek, closes: #386579)
+  * Retitle the apt-mark.8 manpage (thanks to Justin Pryzby, closes: #471276)
+  * Better documentation on using both APT::Default-Release and
+    /etc/apt/preferences (thanks to Ingo Saitz, closes: #145575)
+  
+  [ Michael Vogt ]
+  * doc/apt-cache.8.xml:
+    - add missing citerefentry
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 10 Oct 2008 23:44:50 +0200
+
+apt (0.7.15) unstable; urgency=low
+
+  * Upload to unstable
+
+ -- Michael Vogt <mvo@debian.org>  Sun, 05 Oct 2008 13:23:47 +0200
+
+apt (0.7.15~exp3) experimental; urgency=low
+
+  [Daniel Burrows]
+  * apt-pkg/deb/dpkgpm.cc:
+    - Store the trigger state descriptions in a way that does not break
+      the ABI.  The approach taken makes the search for a string O(n) rather
+      than O(lg(n)), but since n == 4, I do not consider this a major
+      concern.  If it becomes a concern, we can sort the static array and
+      use std::equal_range().  (Closes: #499322)
+
+  [ Michael Vogt ]
+  * apt-pkg/packagemanager.cc, apt-pkg/deb/dpkgpm.cc:
+    - move the state file writting into the Go() implementation
+      of dpkgpm (closes: #498799)
+  * apt-pkg/algorithms.cc:
+    - fix simulation performance drop (thanks to Ferenc Wagner
+      for reporting the issue)
+
+ -- Michael Vogt <mvo@debian.org>  Wed, 01 Oct 2008 18:09:49 +0200
+
+apt (0.7.15~exp2) experimental; urgency=low
+
+  [ Michael Vogt ]
+  * apt-pkg/pkgcachegen.cc:
+    - do not add multiple identical descriptions for the same 
+      language (closes: #400768)
+
+  [ Program translations ]
+  * Catalan updated. Closes: #499462
+
+ -- Michael Vogt <mvo@debian.org>  Tue, 23 Sep 2008 07:29:59 +0200
+
+apt (0.7.15~exp1) experimental; urgency=low
 
   [ Christian Perrier ]
   * Fix typo in cron.daily script. Closes: #486179
@@ -27,6 +179,7 @@ apt (0.7.15) UNRELEASED; urgency=low
   * Vietnamese updated. Closes: #497893
   * Portuguese updated. Closes: #498411
   * Greek updated. Closes: #498687
+  * Polish updated.
 
   [ Michael Vogt ]
   * merge patch that enforces stricter https server certificate
@@ -42,8 +195,10 @@ apt (0.7.15) UNRELEASED; urgency=low
   * add DPkg::NoTriggers option so that applications that call
     apt/aptitude (like the installer) defer trigger processing
     (thanks to Joey Hess)
+  * doc/makefile:
+    - add examples/apt-https-method-example.conf
   
- -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 25 Jul 2008 20:31:05 +0200
+ -- Michael Vogt <mvo@debian.org>  Tue, 16 Sep 2008 21:27:03 +0200
 
 apt (0.7.14) unstable; urgency=low
 
@@ -473,7 +628,7 @@ apt (0.7.3) unstable; urgency=low
     Daniel Burrows, closes: #429378)
   * fixes in the auto-mark code (thanks to Daniel
     Burrows)
-  * fix FTFBFS by changing build-depends to
+  * fix FTBFS by changing build-depends to
     libcurl4-gnutls-dev (closes: #428363)
   * cmdline/apt-get.cc:
     - fix InstallTask code when a pkgRecord ends 
@@ -537,7 +692,7 @@ apt (0.7.2) unstable; urgency=low
 
 apt (0.7.1) experimental; urgency=low
 
-  * ABI library name change because its build against
+  * ABI library name change because it's built against
     new glibc
   * implement SourceVer() in pkgRecords 
      (thanks to Daniel Burrows for the patch!)
@@ -587,9 +742,9 @@ apt (0.7.1) experimental; urgency=low
 
 apt (0.7.0) experimental; urgency=low
 
-  * Package that contains tall the new features
+  * Package that contains all the new features
   * Removed all #pragma interface/implementation
-  * Branch that contains tall the new features:
+  * Branch that contains all the new features:
   * translated package descriptions
   * task install support
   * automatic dependency removal (thanks to Daniel Burrows)