]> git.saurik.com Git - apt.git/blobdiff - debian/rules
[ Nicolas François ]
[apt.git] / debian / rules
index f6ff3c47a4033bac10478c2d04cfa79f558a3723..d19531dfcf41e774e8e66628e11f512af333deda 100755 (executable)
@@ -186,7 +186,8 @@ apt-doc: build-doc
 # Build architecture-dependent files here.
 
 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
-apt: build debian/shlibs.local
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -226,7 +227,7 @@ apt: build debian/shlibs.local
        rm -f po/*.pot
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ 
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
@@ -269,6 +270,7 @@ libapt-pkg-dev: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -284,7 +286,7 @@ apt-utils: build debian/shlibs.local
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -307,7 +309,7 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        mkdir -p debian/$@/usr/lib/apt/methods
        cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
 
-       dh_installdocs -p$@
+       dh_installdocs -p$@ debian/apt-transport-https.README
        dh_installexamples -p$@
 
        # Install the man pages..