]> git.saurik.com Git - apt.git/blobdiff - debian/rules
ensure that FileFd::Size returns 0 in error cases
[apt.git] / debian / rules
index 79a6dbe0cc6bb812ff871a23c12722a32999e2f5..3979bd810301e8c224fb7daa7679baa6e03d72ad 100755 (executable)
@@ -110,6 +110,7 @@ build/build-manpages-stamp: build/configure-stamp
 
 clean:
        dh_testdir
+       dh_clean
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
@@ -182,6 +183,8 @@ apt: build build-manpages
 # apt install
 #
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+       cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir