]> git.saurik.com Git - apt.git/blobdiff - debian/rules
debian/rules: Call dh_makeshlibs for 'apt'
[apt.git] / debian / rules
index 06ccdac31c245478923b43bdd0ed55cb9b99cd0b..3aa86480e36bd090948774eb82fffc5e40c68665 100755 (executable)
@@ -3,6 +3,9 @@
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
 
+# build in verbose mode by default to make it easy to diangose issues
+export NOISY=1
+
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -214,9 +217,10 @@ apt: build-binary build-manpages debian/apt.install
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -p$@
        dh_installdeb -p$@
        dh_shlibdeps -p$@
-       dh_gencontrol -p$@
+       dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
        dh_md5sums -p$@
        dh_builddeb -p$@